Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-17-2013, 10:11 PM
GRN ENVY's Avatar
Member
My Jeep: 2010 5.7L WK
 
Join Date: Feb 2013
Location: Bonita Springs
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 711
GRN ENVY is on a distinguished road
Is it normal?

For the past week or two, when the jeep hasn't been driven for several hours and is cold. When ever I back out of my spot and go to full lock to get out of the space, the jeep stops moving on its on and makes an almost tire rubbing sound in the front, no evidence if rubbing and on stock wheels and tires, and suspension. And when moving foward it does Not want to turn, I can still turn but it has resistance, and whips back quicker than it should. Will only do this for 100 yds and stops then drives normal , any ideas? I have a 2010 GC 5.7 w/ quadra drive II any help is appreciated
__________________

__________________
Reply With Quote
  #2  
Old 03-18-2013, 12:07 PM
GRN ENVY's Avatar
Member
My Jeep: 2010 5.7L WK
 
Join Date: Feb 2013
Location: Bonita Springs
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 711
GRN ENVY is on a distinguished road
Re: Is it normal?

Anyone?
__________________

__________________
Reply With Quote
  #3  
Old 03-18-2013, 12:45 PM
brentwoodkris's Avatar
The Ever-Dissatisfied Tinkerer
My Jeep: 2005 5.7L WK
 
Join Date: Jan 2010
Location: Columbia, MO
Posts: 980
Thanks: 4
Thanked 22 Times in 21 Posts
Rep Power: 3762
brentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond repute
Garage
Re: Is it normal?

Sounds like what happens when your transfer case engages in 4LO. Your turning radius being affected means it's likely that your front differential is actually working via the transfer case. I'd start there (i.e. make sure you're in regular drive without 4LO, etc). If that's not it, sounds like it would be a TCM type issue or computer related unless you've never maintenanced your TC, etc.
__________________
'05 WK GC 5.7L HEMI, Goodyear Wrangler SilentArmors, Monroe Reflex Front Struts/Monroe Load Adjusting Rear Shocks, EBC Drilled/Slotted Sport Rotors, Wagner Ceramic Brake Pads, Taylor Shorties, SRT8 Stock CAI Conversion, K&N Drop-in, Block Heater, 18.5% Tint All Around, Boston SE Speakers, 12" Alpine Type-R Sub w/ sealed box w/ RF PRIME R1000-1D, ScanGauge II w/ windshield mount, BT Catch Can w/custom bracket, Swagman Fork Mount Bicycle Rack, WeatherTech front floor liners, SRT8 Pedal Covers, eBay full LED lighting kit, Custom MDS Indicator LED Light, Mega Raizin Voltage Stabilizer & Grounding Kit, Challenger IAT Sensor, Escort Passport 9500ix, Python 5706P RS/Security/KE w/ extras, SA 5 switch panel, Fumoto Oil Valve, Overland WG Steering wheel.
Reply With Quote
  #4  
Old 03-18-2013, 01:16 PM
GRN ENVY's Avatar
Member
My Jeep: 2010 5.7L WK
 
Join Date: Feb 2013
Location: Bonita Springs
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 711
GRN ENVY is on a distinguished road
Re: Is it normal?

Quote:
Originally Posted by brentwoodkris View Post
Sounds like what happens when your transfer case engages in 4LO. Your turning radius being affected means it's likely that your front differential is actually working via the transfer case. I'd start there (i.e. make sure you're in regular drive without 4LO, etc). If that's not it, sounds like it would be a TCM type issue or computer related unless you've never maintenanced your TC, etc.
Its definitely not in 4lo, that would be obvious. I bought the truck at 54k miles, it has 58k now. There may not have been any maintenance done. I think when I get to work, dealership. I'll have my service guys do the diff, TC, and tranny fluid change. see if that fixes it.
__________________
Reply With Quote
  #5  
Old 04-08-2013, 08:35 AM
GRN ENVY's Avatar
Member
My Jeep: 2010 5.7L WK
 
Join Date: Feb 2013
Location: Bonita Springs
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 711
GRN ENVY is on a distinguished road
Re: Is it normal?

Still doing it, here is a video of the noise, any ideas? made an appointment to see what the dealer thinks and hopefully its covered under warranty.

Turn up your volume its kind of quiet but you can definitely here the grinding noise

__________________
Reply With Quote
  #6  
Old 04-08-2013, 01:10 PM
GRN ENVY's Avatar
Member
My Jeep: 2010 5.7L WK
 
Join Date: Feb 2013
Location: Bonita Springs
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 711
GRN ENVY is on a distinguished road
Re: Is it normal?

Anyone?
__________________
Reply With Quote
  #7  
Old 04-09-2013, 10:24 AM
ALPINEST4RS's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: Mar 2010
Location: Brighton, MI
Posts: 340
Thanks: 8
Thanked 1 Time in 1 Post
Rep Power: 2071
ALPINEST4RS is on a distinguished road
Re: Is it normal?

i can't hear it. is it a clicking noise at full lock? mine had the same issue. i just rebuilt my front end and its all good now.
__________________
2006 Jeep Grand Cherokee WK 3.7L - SOLD (lil bro's)
2007 Jeep Grand Cherokee WK 4.7L -SOLD
2011 - Mazdaspeed3 - Cornfed /GTX3076/CP Pistons/Carrilo Rods/CPE FMIC/ JBR WP 3.5/FREEK'D
Reply With Quote
  #8  
Old 04-10-2013, 08:25 AM
GRN ENVY's Avatar
Member
My Jeep: 2010 5.7L WK
 
Join Date: Feb 2013
Location: Bonita Springs
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 711
GRN ENVY is on a distinguished road
Re: Is it normal?

Quote:
Originally Posted by ALPINEST4RS View Post
i can't hear it. is it a clicking noise at full lock? mine had the same issue. i just rebuilt my front end and its all good now.
Yeah, the clicking noise, what failed on yours to cause that
__________________
Reply With Quote
  #9  
Old 04-11-2013, 09:01 AM
ALPINEST4RS's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: Mar 2010
Location: Brighton, MI
Posts: 340
Thanks: 8
Thanked 1 Time in 1 Post
Rep Power: 2071
ALPINEST4RS is on a distinguished road
Re: Is it normal?

I'm not sure, but I'm thinking the spider gears did it in. I just replaced everything...
__________________

__________________
2006 Jeep Grand Cherokee WK 3.7L - SOLD (lil bro's)
2007 Jeep Grand Cherokee WK 4.7L -SOLD
2011 - Mazdaspeed3 - Cornfed /GTX3076/CP Pistons/Carrilo Rods/CPE FMIC/ JBR WP 3.5/FREEK'D
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is this normal?? or an issue?? Speedtech Troubleshooting/Problems 6 06-21-2013 09:04 PM
is this Normal? Blueflame1979 Troubleshooting/Problems 13 05-17-2013 08:18 AM
Is this Normal CatMan879 Troubleshooting/Problems 4 03-13-2013 06:17 PM
Is this normal? JDubz Troubleshooting/Problems 4 03-28-2012 11:09 PM
Is this normal? Redcivic47 Grand Cherokee - WK2 - 3 04-26-2011 03:37 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.