Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-20-2012, 09:42 AM
ONEbadHEEPtruck's Avatar
Member
My Jeep: 2008 3.7L WK
 
Join Date: Feb 2011
Location: Long Island, NY
Posts: 574
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 1846
ONEbadHEEPtruck is on a distinguished road
Jeep problems!!! Wooo :(

Currently sitting in jeep waiting to see whats going on with my truck, the issue started a few days ago when I was driving and noticed when I turn my left signal on it would blink really fast on my dash, knowing that that means a blinker is out once I got out of my truck I saw my driver taillight was out.. Great... So a day goes by and it was randomly working but I couldn't figure out why, so yesterday I decide to do an experiment and I turned off my headlights and put my blinker on and my taillight worked fine, and then I turned my headlights on and put the blinker on and my taillights were out and once again my signal was blinking so fast in the front. Finally figuring it out Im sitting here in jeep hoping it's covered under warranty and that they can get me out of here ASAP. Has anyone else had this issue?
__________________

__________________
Engine: 3.7L V6
Tires: Pirelli Scorpion Tires
Wheels: 20" Helo HE866
Accessories: 20% Tints | Rain Guards | Pinstriping | Mud Flaps | Jeep rubber floor mats | HID Xenon Headlamps | Chrome Moldings | Chrome Grille | Mygig RER
Future Mods: Sono Finito!!!!!!! wooooo finally lots of $$$$ later
Reply With Quote
  #2  
Old 07-20-2012, 09:51 AM
DAVY27's Avatar
Premium Member
Photobucket
 
Join Date: Jun 2009
Location: City that Never Sleeps
Posts: 9,042
Thanks: 394
Thanked 132 Times in 127 Posts
Rep Power: 1659899
DAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond reputeDAVY27 has a reputation beyond repute
Garage
Send a message via AIM to DAVY27
Re: Jeep problems!!! Wooo :(

replace the fuse and save your time going to dealer
__________________

__________________

2009 Jeep Grand Cherokee SRT Design
SRT Exterior,Magnaflow 14590 w/ SRT resonators,V2 CF Medic Hood,Injen Powerflow Intake,Flying Ryan Ported TB,Custom Painted Halo Headlights,HID lows/fogs,SRT Springs,Stillens,Gloss Black SRT Reps,Mopar Spoiler, Custom Painted Moldings with Snakeskin green GC letterings, Mopar Stripe,Tinted LED tails/rear fogs, TLS Harness,Switchbacks, Stage6 5" Tips,Custom Door Handle Leds,5% Tint,Altec Plate,HID Reverse,Mopar Front Emblem/ Rear Logo,Powerwire,Interior Leds,RGB LED cupholders,Mygig,Weathertech Mats,LXHarness Leds,Rear Cargo Light Mod,Lockpic V4,GlossBlack Vinyl Interior Pieces
Reply With Quote
  #3  
Old 07-20-2012, 10:56 AM
ONEbadHEEPtruck's Avatar
Member
My Jeep: 2008 3.7L WK
 
Join Date: Feb 2011
Location: Long Island, NY
Posts: 574
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 1846
ONEbadHEEPtruck is on a distinguished road
Re: Jeep problems!!! Wooo :(

Quote:
Originally Posted by DAVY27 View Post
replace the fuse and save your time going to dealer
Sitting there already I thought it could've been a fuse is there a thread about how to do that?
__________________
Engine: 3.7L V6
Tires: Pirelli Scorpion Tires
Wheels: 20" Helo HE866
Accessories: 20% Tints | Rain Guards | Pinstriping | Mud Flaps | Jeep rubber floor mats | HID Xenon Headlamps | Chrome Moldings | Chrome Grille | Mygig RER
Future Mods: Sono Finito!!!!!!! wooooo finally lots of $$$$ later
Reply With Quote
  #4  
Old 07-20-2012, 11:01 AM
jlewissystem's Avatar
Fo sheezy my neezy
My Jeep: 2006 5.7L WK
 
Join Date: Oct 2010
Location: STL, MO
Posts: 1,467
Thanks: 37
Thanked 67 Times in 61 Posts
Rep Power: 1278259
jlewissystem has a reputation beyond reputejlewissystem has a reputation beyond reputejlewissystem has a reputation beyond reputejlewissystem has a reputation beyond reputejlewissystem has a reputation beyond reputejlewissystem has a reputation beyond reputejlewissystem has a reputation beyond reputejlewissystem has a reputation beyond reputejlewissystem has a reputation beyond reputejlewissystem has a reputation beyond reputejlewissystem has a reputation beyond repute
Re: Jeep problems!!! Wooo :(

Check wkjeeps.com
__________________

2006 5.7 WK ORT | DiabloSport Predator | FlyinRyan Custom TCM Tune & Ported Throttle Body | (Painted Red) OME HD | Moto Metal 951's | 265/70/17 Duratrac's | Custom SEGUARO Front Bumper | Magnaflow Cat Back 16631 | Airaid Intake | Jet 180 T-Stat | BTT Catch Can | XenonDepot 5000 HID Lows | LED Fogs | JR's Custom Shorty Antenna | De-badged | Rola Roof Rack | MOAR LYTES: Eagle Eye HID Spots | Rigid D2's (Rear) | 7" LED SYDE Lights | 4xGuard Front Skid | Aries Rear Tail Light Guards | FULL Interior LED's | Interior VINYL Wrap | (Painted Red) Strut Bar | Pioneer AVH-4200 | Custom Rear Camera | (Painted Red) Calipers | Gorilla Black Locking "System" | SRT8 Shift Knob | (BUILD THREAD)
Reply With Quote
  #5  
Old 07-24-2012, 11:54 PM
tri0829's Avatar
Member
My Jeep: 2006 3.7L WK
 
Join Date: Jun 2010
Location: Buffalo, New York
Posts: 521
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 2040
tri0829 is on a distinguished road
Re: Jeep problems!!! Wooo :(

i had the exact same thing happen to me. hyper fast blinker. it would go crazy sometimes and then fine others. i thought maybe the bulb was going out and i changed the blub same issue. i took it to the dealer they said the circuit board for the brake light was bad so i changed that same issue. i thought it might be the led tailights i have plugged the old ones in same issue. i finally got it to work after taking the bulbs out in the front blinkers and putting them back in.

--long story short try to clean the connectors for the blinkers, i think this was the issue because after doing this i havent had a problem in months. (i didnt actually clean mine they just started working after i took the bulb out and replaced it a few times) im not sure what they sell to clean them with but ive seen stuff out there. hope that works out, if not id check your rear circuit board could be related to that too i know they have a tendency to get fried
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just got my first jeep - 2 problems/questions Aghotbi Trouble Shooting/Problems/Service 17 03-15-2012 07:24 PM
Jeep has problems starting nrlewellen47 Engine Performance/Intake/Exhaust 3 11-11-2011 10:56 PM
a few problems w/ the jeep.... jth_9 Troubleshooting/Problems Discussion 13 02-25-2011 05:25 PM
Problems with my jeep col95 Troubleshooting/Problems 2 11-21-2010 04:59 PM
JEEP still having ALOT of problems 06SRT8300C Grand Cherokee - WK 54 02-05-2010 06:45 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:59 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community