Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-31-2012, 06:35 AM
Member
My Jeep: 2005 4.7L WK
 
Join Date: Feb 2012
Location: St petersburg Flordia
Posts: 207
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1101
jeremyc653 is on a distinguished road
Limp mode

Hey everyone We just recently bought a 2005 jeep wk my issues are sometimes when driving the rpms will go to 4k and the jeep will only drive up to 20 mph. any ideas on what might be causing this?
__________________

__________________
Reply With Quote
  #2  
Old 05-31-2012, 06:49 AM
Member
My Jeep: 2005 4.7L WK
 
Join Date: Feb 2012
Location: St petersburg Flordia
Posts: 207
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1101
jeremyc653 is on a distinguished road
Re: Limp mode

kind of feels like it has no power
__________________

__________________
Reply With Quote
  #3  
Old 05-31-2012, 10:31 AM
WK HEMInKY's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Dec 2010
Location: Louisville Kentucky
Posts: 90
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 23277
WK HEMInKY has a reputation beyond reputeWK HEMInKY has a reputation beyond reputeWK HEMInKY has a reputation beyond reputeWK HEMInKY has a reputation beyond reputeWK HEMInKY has a reputation beyond reputeWK HEMInKY has a reputation beyond reputeWK HEMInKY has a reputation beyond reputeWK HEMInKY has a reputation beyond reputeWK HEMInKY has a reputation beyond reputeWK HEMInKY has a reputation beyond reputeWK HEMInKY has a reputation beyond repute
Re: Limp mode

When my jeep went into limp mode I was on the expressway and It wa stuck in 3rd gear, I was merging and all the sudden i felt it downshift real hard and the normal "D" for drive was a 3 and I could not get out of the gear. Sounds like you are expieriencing the same issue I had but a different solenoid in your transmission went out. All in all I had a solenoid go bad in my tranny, not the end of the world if it is just a single one and I'd also advise that you go ahead and do a transmission service(fluids, filters and seals)
__________________
Reply With Quote
  #4  
Old 05-31-2012, 11:05 AM
CPT2010's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: May 2010
Location: New Orleans
Posts: 1,198
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 2785
CPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond reputeCPT2010 has a reputation beyond repute
Re: Limp mode

it could be a few things.

Mine did that...

Problem was a bad cell in the battery. It would make the jeep stay in 4th and act funny like you said about the rpms.

A lot of batterys die when the first strong waves of heat start to come through for summer.

A little tip. your battery might read good like mine did. So being the battery was under warranty, i took my battery out and brought to walmart and told them it was bad and got a free replacement without any hassle.

I hope this helps.
__________________
2005 WK 5.7 Limited / AFE CAI / Powerstick exhaust / predator tuned / Gloss black viper rims / Tinted tails / 6K lows and fogs / SRT8 front bumper / custom side rails ;) / 5% tint all around / Custom stereo / pioneer 4300dvd / neon accent lighting / Green/white halo's

Coming soon- 180 thermostat./ or a jeep srt8

Reply With Quote
  #5  
Old 05-31-2012, 12:27 PM
Member
My Jeep: 2007 3.7L WK
 
Join Date: Sep 2011
Location: connecticut
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1083
garllo is on a distinguished road
Re: Limp mode

Another cause could be the notorious shift bezel assembly. Very common problem and the jeep will act as yours has. Search the forum and you will gain alot of info on this. There is also a pretty good how to- pertaining to disassembling and cleaning the unit. You don't want to run off and buy a new one first shot because they run around $600. Pull the codes and that should narrow it down! Best of luck.
__________________
Reply With Quote
  #6  
Old 05-31-2012, 01:50 PM
Escape's Avatar
Senior Member
 
Join Date: Jul 2009
Location: Michigan
Posts: 1,911
Thanks: 0
Thanked 26 Times in 25 Posts
Rep Power: 113179
Escape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond repute
Re: Limp mode

Pull the codes before you disconnect the battery.

If it went into limp mode then there should be codes. It will help you narrow down the cause.

Post those up. It could be many different things.

When it does the limp mode crap in an '05 just shift it into neutral and restart..then place it back into drive. This can be done while moving in an 05, not sure on other years.
__________________
[SIGPIC][/SIGPIC]
Forged, Stroked, Blown, Bottle Fed & More
Reply With Quote
  #7  
Old 05-31-2012, 10:54 PM
JMLoughrey's Avatar
Member
My Jeep: 2007 3.7L WK
 
Join Date: Aug 2011
Location: Farmington, CT
Posts: 520
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 72939
JMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond repute
Re: Limp mode

can be done on an 07 as well.
__________________
Reply With Quote
  #8  
Old 06-01-2012, 06:44 AM
Member
My Jeep: 2005 4.7L WK
 
Join Date: Feb 2012
Location: St petersburg Flordia
Posts: 207
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1101
jeremyc653 is on a distinguished road
Re: Limp mode

first off thanks everyone. When it goes it to this mode it only last for 30 sec and then works fine there is no cel so idk if there are codes to pull.
__________________
Reply With Quote
  #9  
Old 06-01-2012, 02:25 PM
JMLoughrey's Avatar
Member
My Jeep: 2007 3.7L WK
 
Join Date: Aug 2011
Location: Farmington, CT
Posts: 520
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 72939
JMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond reputeJMLoughrey has a reputation beyond repute
Re: Limp mode

Odd, when mine went into limp mode it blew a mass amount of codes.
__________________
Reply With Quote
  #10  
Old 06-02-2012, 06:44 AM
Member
My Jeep: 2005 4.7L WK
 
Join Date: Feb 2012
Location: St petersburg Flordia
Posts: 207
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1101
jeremyc653 is on a distinguished road
Re: Limp mode

Quote:
Originally Posted by JMLoughrey View Post
Odd, when mine went into limp mode it blew a mass amount of codes.
if it is showing codes it would only be while it was doing it. my wife drives it 99% of the time it happened only one time to me and i didn't notice cel
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LIMP Mode :( lll2for3lll Troubleshooting/Problems 38 02-27-2012 01:41 PM
2005 WK 5.7 limp mode and stuck in 3rd [3]; RUDEZ Grand Cherokee - WK 6 08-22-2011 05:24 AM
Air Suspension - Limp Home Mode Sege Suspension/Driveline/Brakes/Wheels/Tires 2 08-09-2011 08:27 PM
Limp Mode 2006 SRT8 BigHemi2 Trouble Shooting/Problems/Service 19 07-13-2011 04:40 PM
3.7L GC - Limp Mode P0762 P0763 NEED HELP !!! DJ BoNiOmArIo Troubleshooting/Problems Discussion 41 08-05-2010 08:55 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:23 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community