Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-22-2014, 03:24 PM
Member
 
Join Date: Dec 2009
Posts: 229
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2319
amw5 is on a distinguished road
Oil Pressure Sending Unit

Hey guys,

I got a P0520 / P0522 and took a look under the jeep and noticed that the connector to a plug/sensor just behind the oil filter had come loose. Is that where the pressure sensor unit is? At any rate, I was able to pull the red tab to the right and remove the connector, but I can't get it to "click" back into place on the sensor!? Does the red clip need to be pushed back in before attempting to put the connector back on? I tried pushing it back on with the red tab pushed back in and it still wouldn't click into place. I'm thinking that is why I have the code, for the connector won't mate right up to the sensor plug all the way.

What gives?
__________________

__________________
'06 Overland: Performance Suspension, AEM Intake, Eagle Intake Manifold, BT Catchcan, Inertia Performance Heads, SRTMax Cam, Non-MDS Lifters, Custom Pushrods, American Racing Longtubes w/cats, Flyin Ryan 84mm TB Prototype, Paramount Performance Billet 4000 TC, PP Stage II Modified Valve Body, PP Certified Flex Plate, CMR Tune, and Stock SRT catback...
Reply With Quote
  #2  
Old 04-22-2014, 04:00 PM
Member
 
Join Date: Jan 2012
Posts: 181
Thanks: 1
Thanked 2 Times in 2 Posts
Rep Power: 1526
Boomer914 is on a distinguished road
Re: Oil Pressure Sending Unit

red tab needs to be out before pushing clip back in. then clip in and push red tab in to lock connector.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Pressure Sending Unit 2007 Hemi 5.7L Denali16 Troubleshooting/Problems 3 12-31-2014 10:55 PM
Changing oil pressure sending unit 5.7 anyoldiron Troubleshooting/Problems 4 05-05-2013 03:12 PM
Oil sending unit. Randomhero180 Troubleshooting/Problems 5 12-19-2012 04:50 PM
fuel tank sending unit problems petit Troubleshooting/Problems Discussion 1 10-01-2012 07:02 PM
Low oil pressure, changed sending unit, what next? kavik Troubleshooting/Problems 10 03-19-2012 09:32 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:23 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.