Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-27-2012, 10:37 AM
Temerarius's Avatar
Premium Member
My Jeep: 2009 3.7L WK
 
Join Date: Jul 2012
Location: Seattle, WA
Posts: 735
Thanks: 73
Thanked 55 Times in 42 Posts
Rep Power: 1007100
Temerarius has a reputation beyond reputeTemerarius has a reputation beyond reputeTemerarius has a reputation beyond reputeTemerarius has a reputation beyond reputeTemerarius has a reputation beyond reputeTemerarius has a reputation beyond reputeTemerarius has a reputation beyond reputeTemerarius has a reputation beyond reputeTemerarius has a reputation beyond reputeTemerarius has a reputation beyond reputeTemerarius has a reputation beyond repute
P0717 and an MB Transmission

So, my 2009 JGC threw a P0717 error (goes into gimp mode and locks down the tranny).

It's a bad input speed sensor on the transmission.. no biggy.. UNLESS you have the Mercedes transmission (which my 3.7 does apparently) and not the 45RFE that most every other model has in it.

If it had the 45RFE, it would be a simple bolt to replace the sensor.

But, as it's the Merc, you have to drop the tranny and replace the entire assembly.

Part ran about $250 plus fluids and what not... grand total was about $800.

Ye been warned fellow 09 3.7 JCG owners...
__________________

__________________
Reply With Quote
  #2  
Old 09-28-2012, 10:48 PM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1653069
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: P0717 and an MB Transmission

you do NOT need to drop the trans, its the lead frame where the speed sensors are located, it mounts above the valve body, dropping the pan (easiest pan EVER), remove the guide bushing (the plug bushing) and drop the valve body. unsnap the lead frame, snap the new one in and reverse procedure.
__________________

__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #3  
Old 09-29-2012, 11:39 PM
stashgto's Avatar
Member
My Jeep: 2008 3.7L WK
 
Join Date: May 2012
Location: Staten Island N.Y.
Posts: 720
Thanks: 0
Thanked 18 Times in 18 Posts
Rep Power: 110084
stashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond repute
Re: P0717 and an MB Transmission

I did mine a few months ago like 2005 said there's no need to drop the trans.
__________________
Reply With Quote
  #4  
Old 03-05-2013, 10:32 AM
BLKCRD's Avatar
Member
My Jeep: 2008 3.0L WK
 
Join Date: Mar 2010
Location: Cultus Lake/ Vancouver BC
Posts: 65
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1822
BLKCRD is on a distinguished road
Re: P0717 and an MB Transmission

Hello guys,
My Jeep is having the same problem. I'm getting the same code P0717. Dealer recommended replacing the Electrohydraulic Unit. Did you chanage just the sensor or the whole unit? price is a lot different for each.
__________________

2008 Jeep GC Limited CRD6/SRT8 Springs/R.Swaybar/WK Bilsteins/SRT8Wheels/Nittos/GDE EcoTune
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission fluid Jinx Troubleshooting/Problems 15 12-11-2011 03:28 PM
Transmission leak Motteler621 Troubleshooting/Problems Discussion 2 10-25-2011 09:55 PM
89 YJ transmission Sodelcustoms Wrangler-YJ, TJ & JK 3 10-11-2011 04:14 AM
Transmission Issues Crestwood1001 Grand Cherokee - WK 34 08-07-2011 09:45 PM
Which transmission do I have? magradze Troubleshooting/Problems 5 04-07-2010 01:54 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:39 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.