Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-04-2011, 03:43 PM
JLaudioJeepGC05's Avatar
New Member
My Jeep: 2005 4.7L WK
 
Join Date: Nov 2009
Location: Central MA
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
JLaudioJeepGC05 is on a distinguished road
PAC C2R-CHY4 aftermarket radio harness problems. Need some help

Hi my names Jeff and ive been having a few problems with my system lately so ill start by telling you what i got. I drive a 2005 Jeep Grand Cherokee with a 4.7L V8 in it and I have a JL Audio 13w7 powered by a JL Audio 1000/1. I also have an XS Power D6500 for my battery and 0/1 guage wire running to a splitter to 4 guage wire to my amp in the back. there's a 100 amp fuse under the hood by the battery and i also put a 100 amp fuse in after the splitter on the 4 guage wire.
I recently purchased the d6500 from mechman.com because I was having low voltage problems and I had an optima yellow top for over 4 years and i've heard they've had their share of problems so when i talked to the guy there he said that changing the battery and doing the big 3 upgrade should solve my voltage drop problems and that my stock 160 amp alternator should power the system fine. So i changed my battery (end of october) and replaced my factory grounds and power wire from the alternator with 0/1 gauge wire and that seemed to fix my problem until about a month ago when everything started going crazy. I would be driving around and when i would go to crank my system it would cut off completly (by completly i mean my head unit would shut right off and my gauges would start acting funny and all my lights in the cluster would flash on and shut back off) but when i would keep the rpms up it would seem to still play so i figured it was my alternator. So i went and bought a new alternator from the local parts store and put that in to see if it would help.
Now whenever I had problems before it would always come up on the amp as low voltage but now it wants to shut my head unit off right away and the amp seems to be working fine. So after i changed my alternator out the problem didnt get any better but i could play it somewhat loud just not where i usually have it and certain songs it would just want to shut my head unit right off. So my next thought was maybe my head unit could be bad. It was an alpine i got about 4 years ago when i originally bought my system, so i went out and bought a new alpine head unit only to have the same problems. So now it got to the point where i couldnt play my radio at all without it going crazy even my air bag light would stay on but i found out it was my clock spring that was messed up.
So after i fixed that i figured i had it made and everything would be fine but i went to crank it it still cut off the head unit when i did so now i was really disappointed and decided to completly cut the power to my system in the trunk. So i removed the fuse and shut off all subwoofer controls on my head unit so my system was not getting any signal at all and i cranked it with just the speakers in my jeep and it plays fine no problems the head unit stays on and everything. Ive checked my grounds and cant see anything wrong with them I also adjusted the input sensitivity on my amp because i think that may have been what started it all. I had this system in a 99 Jeep Cherokee first and thats what it was set to but i have the 05 GC now and I have the kicker speaker and amplifier upgrade. Whenever i had problems before only my sub would cut off but my speakers would still play and the sub would eventually kick back on now it just cuts everything off radio, speakers and sub and it still makes my rpms go crazy and the air bag light will flash on and go off so i really dont want it to mess up another clock spring.
So my next thought is maybe there is something wrong in the radios wiring harness. I have the PAC C2R-CHY4 harness and ive had it for about 2 years now. I think its this because I have the steering wheel controls but theyre not hooked up because you need another adapter and this radio harness must tie into it somehow and the steering wheel controls are tied into the clock spring as well as the cruise control. So at the moment i have the system disconnected and everything else seems to work fine but just the other day with the sub still disconnected it did the same thing with just my speakers playing so im really starting to think its something in the harness. In the instructions it has a diagram of a relay if "more current is needed" but i dont know how and where to wire this in and if this is what my problem is.
So i was hoping someone may have had the same problems im having with this wiring harness because ive checked all my grounds and they were all fine and ive run out of ideas as to what it could be. I appreciate any help thanks
__________________

__________________
Reply With Quote
  #2  
Old 06-05-2011, 09:01 AM
ekaz's Avatar
Member
My Jeep: 2009 7.0L SRT8
 
Join Date: Oct 2009
Location: Chicago
Posts: 561
Thanks: 1
Thanked 11 Times in 10 Posts
Rep Power: 2433
ekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond repute
Re: PAC C2R-CHY4 aftermarket radio harness problems. Need some help

I have an 09 with a hd600/4 and a 750/1 and didn't have the big 3 done and didn't have any of those issues. Have you tried a different amp? Maybe something is going on in the amp and that's the only thing you haven't tried.
__________________

__________________
Unlawful Gathering
Click for details!
2012 300 SRT
2011 GC Overland
2009 Modern Blue Pearl (for sale)
Headlights by DC Customs
Powered by PWR
Shifted by SHR
Tooned by Toona
Blinged by Billet Technologies
Reply With Quote
  #3  
Old 06-06-2011, 04:07 PM
JLaudioJeepGC05's Avatar
New Member
My Jeep: 2005 4.7L WK
 
Join Date: Nov 2009
Location: Central MA
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
JLaudioJeepGC05 is on a distinguished road
Re: PAC C2R-CHY4 aftermarket radio harness problems. Need some help

Well it did the same thing when i had the fuse out for my system so all that was playing was my speakers. Thats why i dont think its the system anymore
__________________
Reply With Quote
  #4  
Old 06-06-2011, 04:44 PM
ekaz's Avatar
Member
My Jeep: 2009 7.0L SRT8
 
Join Date: Oct 2009
Location: Chicago
Posts: 561
Thanks: 1
Thanked 11 Times in 10 Posts
Rep Power: 2433
ekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond repute
Re: PAC C2R-CHY4 aftermarket radio harness problems. Need some help

PAC has newer versions of the interfaces, I'd try one of those if I were you. If you want, I can take a look and see if I have a spare laying around you can try.
__________________
Unlawful Gathering
Click for details!
2012 300 SRT
2011 GC Overland
2009 Modern Blue Pearl (for sale)
Headlights by DC Customs
Powered by PWR
Shifted by SHR
Tooned by Toona
Blinged by Billet Technologies
Reply With Quote
  #5  
Old 07-30-2012, 08:35 AM
fox_hound's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jul 2012
Location: south carolina
Posts: 77
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 21878
fox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond repute
Re: PAC C2R-CHY4 aftermarket radio harness problems. Need some help

Id look into replacing the harness all together. they make one called the pac RP4-CH11. it combines the harness for the radio and the harness for the steering wheel controls into one. plus it cost about the same as the radio harness by itself, anywhere from $100 - $125. If you have basically elimanated the system as the problem its probably in the harness. could be just a loose connection.
__________________
Reply With Quote
  #6  
Old 07-31-2012, 06:40 PM
Madanio24's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,805
Thanks: 0
Thanked 20 Times in 20 Posts
Rep Power: 11021
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: PAC C2R-CHY4 aftermarket radio harness problems. Need some help

Are you sure you did the big 3 upgrade right? on min ei left all the factory grounds in place and ran bigger cables in parallel not to upset the stock wiring. If your gauges are moving like that it could be a bad ground. My system is pumping plenty of power with 2400 amps worth or power using the stock original alternator from 05 to power it with non of your problems.

If you can physically disconnect the fuse from your battery to the amps, and remove the radio fuse and the car still acts up its nothing to do with your radio system.
__________________

__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Aftermarket amp/PAC C2A-CHY3 question nick.jeff Audio, Video, Navigation & Electronic Modifications 9 03-08-2011 10:36 PM
Aftermarket radio install problems cbnbmore Audio/Visual/Navigation 16 09-13-2010 05:44 AM
Radio problems scott.mcaloon Troubleshooting/Problems 3 08-15-2010 01:39 PM
PAC C2R-CHY4 Install Help RossC Grand Cherokee - WK 6 05-11-2010 12:28 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:59 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community