Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 07-25-2013, 01:25 PM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Feb 2013
Location: Stamford, CT
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 592
LJSMITH1 is on a distinguished road
Re: Please help exercise my electrical demon!

The ignition switch could be the issue. However, one other thing to look for is what happened with my '06 Jeep Limited.

I randomly had the Airbag Warning Light and the ESP/BAS light come on while driving. Everything else seemed to be ok. On the advice of another forum, I replaced the clockspring. The issue was not resolved.

While coincidentally working on my driver's seat cushion, I found a wire harness that had worn right through the insulation against one of the seat mounting brackets. There was bare conductor showing! The only way you can see this is by taking the seat out of the car and looking at the harness. I had taken the seat cushion off to repair the worn-out foam bolster on the side.

After repairing and securing the harness, I soon noticed that the lights on the instrument panel were not having problems anymore. That was at around 70K miles ago and I am at 138K now. No issues.

Just another place to look...Good Luck!
__________________

__________________
Reply With Quote
  #14  
Old 10-01-2013, 03:43 PM
Bagodohnutz's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: May 2013
Location: Lakewood, CO
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 524
Bagodohnutz is on a distinguished road
Garage
So after two days at the dealership I got the call... $955 to replace the ignition switch and Wireless control module. They say they are also pulling a code for an open circuit on the clock spring and $289 to fix that as we'll. Any opinions?
__________________

__________________
Reply With Quote
  #15  
Old 10-01-2013, 07:38 PM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2010
Location: Kingston, Ontario
Posts: 803
Thanks: 0
Thanked 15 Times in 14 Posts
Rep Power: 276907
dr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond repute
Quote:
Originally Posted by Bagodohnutz View Post
So after two days at the dealership I got the call... $955 to replace the ignition switch and Wireless control module. They say they are also pulling a code for an open circuit on the clock spring and $289 to fix that as we'll. Any opinions?
I would try replacing the ignition switch first (easy to do yourself and a cheap fix).

After that is done, see if it solves your problem - if not, then look at the other things on the dealers wish list.

I wouldn't trust the remaining diagnosis at this point, as it is possible a faulty switch is causing other errors to show.
__________________
Reply With Quote
  #16  
Old 10-02-2013, 06:17 AM
Member
 
Join Date: Mar 2013
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 593
topat46 is on a distinguished road
Re: Please help exercise my electrical demon!

I would do those repairs myself. Not that hard if you are handy with tools. "Good Luck".
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WTF! Where should I start my electrical demon hunt! Bagodohnutz Troubleshooting/Problems Discussion 2 07-12-2013 07:07 PM
Electrical Help chinookguy25 Troubleshooting/Problems 36 06-08-2013 05:23 PM
SAND DEMON :: 2005 Jeep Grand Cherokee 05WK4.7 Member Garage Discussions 0 10-24-2012 04:38 AM
Not A SRT8 WK2 But A WK2 Speed Demon Review! NYCSRTATE Grand Cherokee SRT - WK2 17 12-04-2010 12:37 AM
02 WJ 4.7 demon possesed squeal/chirp 02JeepGrandCherokee Engine Performance/Intake/Exhaust 11 06-21-2010 01:27 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:15 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community