Possible Transmission problem! - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-21-2014, 11:54 AM
Member
 
Join Date: Aug 2014
Posts: 9
Thanks: 4
Thanked 0 Times in 0 Posts
Rep Power: 851
DMB423 is on a distinguished road
Possible Transmission problem!

Hi everyone,
So i have a 2010 Grand Cherokee with 83,000 Miles and i was experiencing a pretty violent vibration when i would drive on the highway. At 2000, 2500, and 3000RPMs i would feel this vibration. I took it to the dealer and they said my Transmission oil was very dirty and they suggested we flush the trans and put New oil in. They did that and it seemed to clear up the issue about 80% of the time. I am still getting a slight vibration but it is driving much better.
My concern now is, what if the trans still has a problem because i am still feeling the vibration to some degree? Does this mean my trans is starting to go bad and i will have to replace it 1 or 2 years down the road? Any suggestions on what to do or how to handle this? Any advice is greatly appreciated!

-Adam

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 08-21-2014, 12:07 PM
macfan's Avatar
Member
My Jeep: 2014 3.2L KL
 
Join Date: Oct 2013
Location: Fenton, Michigan USA
Posts: 608
Thanks: 130
Thanked 92 Times in 77 Posts
Rep Power: 5909
macfan has a reputation beyond reputemacfan has a reputation beyond reputemacfan has a reputation beyond reputemacfan has a reputation beyond reputemacfan has a reputation beyond reputemacfan has a reputation beyond reputemacfan has a reputation beyond reputemacfan has a reputation beyond reputemacfan has a reputation beyond reputemacfan has a reputation beyond reputemacfan has a reputation beyond repute
Re: Possible Transmission problem!

Quote:
Originally Posted by DMB423 View Post
Hi everyone,
So i have a 2010 Grand Cherokee with 83,000 Miles and i was experiencing a pretty violent vibration when i would drive on the highway. At 2000, 2500, and 3000RPMs i would feel this vibration. I took it to the dealer and they said my Transmission oil was very dirty and they suggested we flush the trans and put New oil in. They did that and it seemed to clear up the issue about 80% of the time. I am still getting a slight vibration but it is driving much better.
My concern now is, what if the trans still has a problem because i am still feeling the vibration to some degree? Does this mean my trans is starting to go bad and i will have to replace it 1 or 2 years down the road? Any suggestions on what to do or how to handle this? Any advice is greatly appreciated!

-Adam
This is exactly why I always purchase the Mopar extended service contract. Having said that, what is the standard power train warranty on the 2010? Could be you are worrying about something you don't need to be worrying about.
Reply With Quote
The Following User Says Thank You to macfan For This Useful Post:
  #3  
Old 08-21-2014, 12:25 PM
Member
 
Join Date: Aug 2014
Posts: 9
Thanks: 4
Thanked 0 Times in 0 Posts
Rep Power: 851
DMB423 is on a distinguished road
Re: Possible Transmission problem!

My power train warranty expires in March or 100,000 miles. Im trying to get this corrected while i still have the warranty. I don't want to have to replace a transmission on the truck right after it expires, which is what i'm afraid will happen. The dealer ship is going to try to fix it before it just has to put in a new trans, but by doing that if it cant be fixed and needs to be replaced i am running out of time.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need advice with possible transmission issue! DMB423 Troubleshooting/Problems 14 08-26-2014 07:24 PM
Possible air strut problem Djv1389 Trouble Shooting/Problems/Service 0 07-14-2012 12:12 AM
Possible problem after upgrade on 430n computerwiz621 Audio/Visual/Navigation 12 01-23-2012 01:49 PM
Possible speed sensor or transmission issue. southernfryedyankee Troubleshooting/Problems 26 10-16-2011 10:00 AM
possible blend door problem rlane Troubleshooting/Problems 4 02-23-2010 05:32 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.