Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-26-2011, 12:48 PM
Member
 
Join Date: Sep 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1051
jmolli is on a distinguished road
Prestone Coolant Causing Water Pump Problems??

replaced the water pump on my 05 3.7L WK about two years ago at 70,000 miles. The bearings had begun to fail and I had a chattering at idle from the pump pulley. I installed a brand new Mopar pump from the dealer. I topped off any coolant lost in changing the pump with a 50/50 mixture of Prestone and distilled water. I probably added about a gallon of the Prestone mix. (Note that I was lazy and didn't drain the coolant, I just pulled the pump and let the coolant spill out into my catch basin).

Now only two years and 35,000 miles later, the new pump is leaking! The bearings seam fine but I am loosing fluid overnight after it cools down. I've never seen anything like it, it only leaks when the outside temp goes below freezing. Once you start it up and get up to operating temp, the leak goes away! It appeared to be leaking past the water pump gasket/seal. I've just installed another new OEM pump and topped off with 50/50 Prestone again.

Now I've noticed that Jeep cautions against mixing "non-hoat" anti-freeze with the OEM "hoat" anti-freeze. My question is did my mixing 50/50 Prestone with the factory coolant, lead to the new pump/gasket failing in just two years??

Does the Prestone attack the rubber water pump gasket/seal?? I'm thinking I should do a coolant flush and re-fill with OEM coolant.


Thanks in advance for your replies.
__________________

__________________
Reply With Quote
  #2  
Old 12-26-2011, 02:30 PM
SvenskaJeepGuy's Avatar
Let's Roll
My Jeep: 2006 4.7L WK
 
Join Date: Dec 2009
Location: Scranton PA
Posts: 13,069
Thanks: 137
Thanked 159 Times in 149 Posts
Rep Power: 1255290
SvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond repute
Garage
Re: Prestone Coolant Causing Water Pump Problems??

that could be the problem, but it is too late for a flush if it is already leaking
__________________

__________________
Reply With Quote
  #3  
Old 12-25-2012, 02:38 PM
psychojeepers's Avatar
Member
My Jeep: 2005 4.7L WK
 
Join Date: Sep 2010
Location: nebraska
Posts: 77
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1485
psychojeepers is on a distinguished road
Re: Prestone Coolant Causing Water Pump Problems??

i am havin the same problem and exact same everything to the problem above and did the same thing with the new seal and filling back up with 50/50 mix...
__________________

2005 JGC WK 4.7L Oo|||||||oO
K&N Intake, Superchips flashpaq, Custom 3" catback, Bilsteins, X-Factor 3.5" lift, Spidertrax 1.5" spacers, 265/70 Nitto Terra Grapplers
Reply With Quote
  #4  
Old 12-26-2012, 07:30 AM
Member
 
Join Date: Aug 2012
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 730
goflick is on a distinguished road
Re: Prestone Coolant Causing Water Pump Problems??

Quote:
Originally Posted by jmolli View Post
c My question is did my mixing 50/50 Prestone with the factory coolant, lead to the new pump/gasket failing in just two years?
Yes, drain it, flush it and put the correct coolant in and you should be ok.
__________________
Reply With Quote
  #5  
Old 12-26-2012, 09:17 AM
Member
 
Join Date: Dec 2012
Location: Norcross GA
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 580
JeepTechGA is on a distinguished road
Re: Prestone Coolant Causing Water Pump Problems??

Highly doubt flushing it will fix anything The bearings are doing the same thing out the wheep hole
__________________
Reply With Quote
  #6  
Old 12-26-2012, 09:58 AM
Member
 
Join Date: Aug 2012
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 730
goflick is on a distinguished road
Re: Prestone Coolant Causing Water Pump Problems??

My bad, you are going to need a change the pump again.
__________________
Reply With Quote
  #7  
Old 01-03-2013, 03:47 PM
Member
My Jeep: 2007 3.7L WK
 
Join Date: Sep 2010
Location: South Jersey
Posts: 137
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1537
Drew is on a distinguished road
Re: Prestone Coolant Causing Water Pump Problems??

Personally I just think the pumps are JUNK. I had my first pump go out, literally blowing coolant all over the road, at 43k (untouched OEM only fluid) and just replaced another 2 weeks ago with just over 75k miles (again, untouched OEM only fluid).
So, I'm on my 3rd OEM pump at just over 75k miles....with OEM fluid.
__________________
Reply With Quote
  #8  
Old 01-03-2013, 05:40 PM
stashgto's Avatar
Member
My Jeep: 2008 3.7L WK
 
Join Date: May 2012
Location: Staten Island N.Y.
Posts: 718
Thanks: 0
Thanked 18 Times in 18 Posts
Rep Power: 109916
stashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond reputestashgto has a reputation beyond repute
Re: Prestone Coolant Causing Water Pump Problems??

WOW I was going to ask if I have 100,000 when I should think about changing it. That sounds terrible maybe I'll just change it to stay ahead of the curve. Are there any other brands that maybe better?
__________________
Reply With Quote
  #9  
Old 01-05-2013, 03:08 PM
Member
My Jeep: 2006 5.7L WK
 
Join Date: May 2012
Location: West MI
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 840
dsjr2006 is on a distinguished road
Re: Prestone Coolant Causing Water Pump Problems??

Our Jeeps require G05 Fluid, not just any off the shelf 50/50. The non-HOAT fluid supposedly causes premature failures.
__________________

__________________
'06 WK 5.7 Hemi - QD2 - OME MD - JK Sahara 18" wrapped in 275/65R18 Goodyear Duratracs - DS Predator - AFE Intake
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water Pump batman Cherokee-SJ and XJ 14 02-15-2012 04:57 PM
Water pump leakage Frango100 Troubleshooting/Problems 31 01-15-2011 03:28 PM
Water Pump Leak? mrkrabs318 Trouble Shooting/Problems/Service 7 11-07-2010 09:21 PM
6.1 OEM water pump BJB Grand Cherokee SRT8 - WK 3 06-11-2010 06:38 AM
water pump problem tomg Troubleshooting/Problems 1 05-06-2010 02:30 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:54 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community