Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-30-2012, 01:50 PM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,937
Thanks: 20
Thanked 29 Times in 28 Posts
Rep Power: 11277
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Problem with all o2 sensors?

Guys I was driving home yesterday from the shore and i was stuck in a lot of traffic, stop and go for an hour. My check engine light came on, i pulled the codes and got the following:

U0100 - Lost communication with ECM/PCM
P0032 - Bank 1 Upstream Oxygen Sensor Circuit High
P0038- Bank 1 Downstream Oxygen Sensor Circuit High
P0052- Bank 2 Upstream Oxygen Sensor Circuit High
P0058- Bank 2 Downstream Oxygen Sensor Circuit High

Idle has been pretty weird over the past few days.
__________________

__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #2  
Old 09-30-2012, 02:16 PM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,937
Thanks: 20
Thanked 29 Times in 28 Posts
Rep Power: 11277
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: Problem with all o2 sensors?

All 02 sensors were changed in the spring.
__________________

__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #3  
Old 10-01-2012, 03:20 AM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,937
Thanks: 20
Thanked 29 Times in 28 Posts
Rep Power: 11277
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: Problem with all o2 sensors?

Bump!
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #4  
Old 10-01-2012, 06:54 PM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,937
Thanks: 20
Thanked 29 Times in 28 Posts
Rep Power: 11277
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: Problem with all o2 sensors?

Anybody?
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #5  
Old 10-02-2012, 07:23 PM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,937
Thanks: 20
Thanked 29 Times in 28 Posts
Rep Power: 11277
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: Problem with all o2 sensors?

Bump!!! Not sure if I should get a new PCM.
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #6  
Old 10-03-2012, 11:31 AM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652943
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: Problem with all o2 sensors?

It appers they all use the same G101, and they all use the same splice 146 to the ground. I would inspect all your grounds and make sure they are clean and tight.

S146 is in the harness on the right side of the bellhousing approx 3-6 inches from the engine.
G101 is right near the battery.
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #7  
Old 10-03-2012, 12:00 PM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,937
Thanks: 20
Thanked 29 Times in 28 Posts
Rep Power: 11277
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Smile Re: Problem with all o2 sensors?

Thank you! I am an idiot when I was working on my hid headlights, I disconnected that ground and forgot to screw it in all the way! Works great now.
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #8  
Old 10-03-2012, 08:05 PM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652943
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: Problem with all o2 sensors?

Glad I could help.
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #9  
Old 10-03-2012, 09:59 PM
SvenskaJeepGuy's Avatar
Let's Roll
My Jeep: 2005 4.7L WK
 
Join Date: Dec 2009
Location: Scranton PA
Posts: 13,091
Thanks: 140
Thanked 163 Times in 153 Posts
Rep Power: 1255353
SvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond repute
Garage
Re: Problem with all o2 sensors?

Glad it was something simple! That could have got expensive real quick
__________________
Reply With Quote
  #10  
Old 10-03-2012, 10:09 PM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,937
Thanks: 20
Thanked 29 Times in 28 Posts
Rep Power: 11277
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: Problem with all o2 sensors?

The mistakes I sometimes make lol
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #11  
Old 10-04-2012, 01:35 AM
SvenskaJeepGuy's Avatar
Let's Roll
My Jeep: 2005 4.7L WK
 
Join Date: Dec 2009
Location: Scranton PA
Posts: 13,091
Thanks: 140
Thanked 163 Times in 153 Posts
Rep Power: 1255353
SvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond reputeSvenskaJeepGuy has a reputation beyond repute
Garage
Re: Problem with all o2 sensors?

Quote:
Originally Posted by Madanio24 View Post
The mistakes I sometimes make lol
im dealing with a decent mistake i made to my jeep as well. hopefully i am able to fix it easily too
__________________
Reply With Quote
  #12  
Old 10-04-2012, 09:58 AM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,937
Thanks: 20
Thanked 29 Times in 28 Posts
Rep Power: 11277
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: Problem with all o2 sensors?

What did you do?
__________________

__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
O2 Sensors Billyb.cpt Grand Cherokee - WK 10 04-23-2012 06:26 PM
o2 sensors for cats B.P.O.D Performance Modifications 22 01-29-2010 04:20 PM
TPMS Sensors saleen032 Grand Cherokee - WK 8 10-20-2009 06:08 PM
TPMS sensors Bslagle05 Visual Modifications 1 06-16-2009 06:23 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:57 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community