Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-14-2012, 01:57 AM
New Member
 
Join Date: Nov 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
dunnie0420 is on a distinguished road
rough idle, really bad

sup guys, new here as title says ive got a few issues with my moms 2007 laredo 4.7, 105k. Runs like SHIT! burns alot of oil. smokes like a 2stroke amd ticks im thinking a lifter. but it recently started with this idle problem. start in park idle bounces up and down to about 1300 then drops down around 500, and has even stalled out a couple times. but it drives ok. its been a problem for a while as my mom is a bit neglectful and funds are extremly tight. no engine light, until tonight. I was going through a parking lot going about 15 mph, came to a quick stop and the engine stalled out. it didnt bog down or anything seeming like a missfire, it just stopped like you turned it off. Shortly after i was on the highway going around 65/70mph, i herd a loud bang sounded like hitting a big bump the engine light popped on, rpms were at like 800, and there was zero throttle respose for a few seconds. I put it in neutral and rolled to a stop. I immediately shit myself (not literaly) as I pulled to the side of the highway. went to start the car again after about 3 tries i was on the phone with my boy with AAA. after about 5 minutes of thinking i was going to die i gave it a try and it started right up and i drove it home 10 miles no problem. Even stoppped to get gas turned it off started up and drove. but the light is still on. I dont know alot of much outside of my car i mean getting into these newer vehicles and all the low blinker fluid lights and fancy such hahaha and i dont have the slightest idea where to start or what to search for, i know all about google and search feature no luck for me. help is very much appreciated.

tthanks in advance, Matt

p.s. it happened at 9:05 p.m, I could literaly see autozone. im going to get the code scanned in the morning will update. bsa light (im pretty sure) is illuminated also and its got a ad solinoid in the tranny ive read seems to be quite common on these but im sure the problms arent related, or maybe wrong...
__________________

__________________
Reply With Quote
  #2  
Old 11-14-2012, 03:59 PM
brentwoodkris's Avatar
The Ever-Dissatisfied Tinkerer
My Jeep: 2005 5.7L WK
 
Join Date: Jan 2010
Location: Columbia, MO
Posts: 941
Thanks: 2
Thanked 15 Times in 15 Posts
Rep Power: 3610
brentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond repute
Garage
Re: rough idle, really bad

Sounds like a misfiring/timing issue. I'd start with a the standard tune up if your mother didn't take care of it. Stalling could also be caused by bad coils if it's indeed the ignition system as I suspect.

Check these (not necessarily in this order): Ignition system, air delivery system (esp TB/MAF/IAT), fuel delivery system (clogged injectors, fuel pump).

Also note that the batteries in these WK's have been known to exhibit CRAZY symptoms when the voltages vary even slightly. Make sure you get yours load tested.
__________________

__________________
'05 WK GC 5.7L HEMI, Goodyear Wrangler SilentArmors, Monroe Reflex Front Struts/Monroe Load Adjusting Rear Shocks, EBC Drilled/Slotted Sport Rotors, Wagner Ceramic Brake Pads, Taylor Shorties, SRT8 Stock CAI Conversion, K&N Drop-in, Block Heater, 18.5% Tint All Around, Boston SE Speakers, 12" Alpine Type-R Sub w/ sealed box w/ RF PRIME R1000-1D, ScanGauge II w/ windshield mount, BT Catch Can w/custom bracket, Swagman Fork Mount Bicycle Rack, WeatherTech front floor liners, SRT8 Pedal Covers, eBay full LED lighting kit, Custom MDS Indicator LED Light, Mega Raizin Voltage Stabilizer & Grounding Kit, Challenger IAT Sensor, Escort Passport 9500ix, Python 5706P RS/Security/KE w/ extras, SA 5 switch panel, Fumoto Oil Valve, Overland WG Steering wheel.
Reply With Quote
  #3  
Old 11-14-2012, 04:44 PM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,941
Thanks: 22
Thanked 29 Times in 28 Posts
Rep Power: 11287
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: rough idle, really bad

Get the codes checked. I would change sparkplugs check resistance on coils and seafoam.
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
4.7 HO Engine Rough Idle Problem rojpon74 Engine Performance/Intake/Exhaust 20 03-15-2012 08:28 PM
Weird idle/ rough running bry@n Trouble Shooting/Problems/Service 0 02-07-2012 09:39 AM
Rough Idle, Vacuum Leak? PeterB16 Engine Performance/Intake/Exhaust 6 12-03-2011 11:22 PM
Rough idle on decline? TheAngryMinnow Grand Cherokee - WK 0 01-22-2011 10:26 AM
Rough idle on first start of the day rhodesian Grand Cherokee - ZJ 2 11-13-2010 05:58 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:23 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community