Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-16-2011, 05:27 PM
Member
My Jeep: 2006 3.7L WK
 
Join Date: Jun 2011
Location: Ft Campbell
Posts: 23
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1214
tomczak is on a distinguished road
Seafoam gone bad! Help please

So I was having a rough idle on my 06 3.7L GC so I tried to use seafoam. Never had an issue before using it. Well I put a half a can in the brake vacuum line. Then 1/4 in the oil and 1/4 in the tb. Well it smoked up after I let it sit. It idles better, but now I have a hesitation well I hit the gas from a stand still. Also I noticed if I hit my brakes with the heat on full power the whole heater die down for a few seconds bout 10 secs. Like it lost power for a few. I tried taking it out for a 10 mile trip both on the highway and in the city. I also forgot to mention I disconnected the battery for bout 2 mins. Please if any one can help.
__________________

__________________
Reply With Quote
  #2  
Old 11-16-2011, 06:00 PM
Bleeding Blue's Avatar
Member
My Jeep: 2005 3.7L WK
 
Join Date: May 2011
Location: Indianapolis, IN
Posts: 509
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 27931
Bleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond repute
Re: Seafoam gone bad! Help please

Did you get any on the sensors inside the TB?
__________________

__________________
Reply With Quote
  #3  
Old 11-16-2011, 06:12 PM
Redpit's Avatar
Member
My Jeep: 2008 5.7L WK
 
Join Date: Jul 2011
Location: NY
Posts: 330
Thanks: 0
Thanked 13 Times in 13 Posts
Rep Power: 2996
Redpit has a reputation beyond reputeRedpit has a reputation beyond reputeRedpit has a reputation beyond reputeRedpit has a reputation beyond reputeRedpit has a reputation beyond reputeRedpit has a reputation beyond reputeRedpit has a reputation beyond reputeRedpit has a reputation beyond reputeRedpit has a reputation beyond reputeRedpit has a reputation beyond reputeRedpit has a reputation beyond repute
Re: Seafoam gone bad! Help please

Fouled spark plugs maybe? I know that is a real possibility with seafoam, also double check to see if your vacuum line is connected well.
__________________

Gibson Exhaust, AFE Stage 2 Intake, Diablosport programmer, FlyinRyan trans tune & PCM tune, Brush Guard, Tail light Guards, HID Lows & Fogs, LED interior lights, SRB 100w Fog lights, Plasti-dipped wheels, 245/70/17 General Grabber AT2's, and Vent Visor Rain Guards
Reply With Quote
  #4  
Old 11-16-2011, 06:22 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,356
Thanks: 487
Thanked 68 Times in 65 Posts
Rep Power: 469787
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Seafoam gone bad! Help please

Next time take it to an auto shop for a fuel system service instead of using sea foam.
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #5  
Old 11-16-2011, 06:46 PM
Member
My Jeep: 2006 3.7L WK
 
Join Date: Jun 2011
Location: Ft Campbell
Posts: 23
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1214
tomczak is on a distinguished road
K so I took out all the spark plugs some how they lost their gap they had a smaller gap than they are suppose to. Don't understand how that happened unless the shop I took it to gap them too small. It's running better now except the after market pcv valve I bought from autozone is really loud with the clicking. I do have one question I have this extra vacuum line on the back of the TB that has a yellowish plug on the end of it. Looks like it is coming from the back of the engine. Does anyone know if that should be like that or is it not hooked up like it is suppose to?.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Seafoam! 01grand Grand Cherokee - WJ 0 11-06-2011 08:30 PM
seafoam turner1 Grand Cherokee - WK 11 09-10-2011 08:13 AM
2010 Jeep Liberty Seafoam: The aftermath Knightrider03m Liberty-KJ and KK 8 05-08-2011 11:13 PM
Seafoam: Questions GR33N D3M0N Grand Cherokee - WK 8 03-09-2011 12:15 AM
seafoam? good or bad results 99PlatinumWJ Engine Performance/Intake/Exhaust 8 12-16-2010 09:42 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:45 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community