Service 4wd system - Page 2 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 11-17-2014, 07:28 AM
New Member
 
Join Date: Dec 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
teacher54 is on a distinguished road
Re: Service 4wd system

I'm in Scotland and had the latest update done recently, checked 4 Lo was working before I left dealer - all OK

Reply With Quote
Sponsored Links
Advertisement
 
  #14  
Old 11-17-2014, 07:30 AM
Member
 
Join Date: Nov 2012
Posts: 13
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 1564
Foxy69 is on a distinguished road
Re: Service 4wd system

Quote:
Originally Posted by teacher54 View Post
I'm in Scotland and had the latest update done recently, checked 4 Lo was working before I left dealer - all OK

Hi, did they charge u for it? How long has it lasted so far?



Sent from my iPad using JeepGarage
Reply With Quote
  #15  
Old 11-17-2014, 07:48 AM
New Member
 
Join Date: Dec 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
teacher54 is on a distinguished road
Re: Service 4wd system

no charge and that was on Oct 30th. Was told it was the latest update. There is also an update re ignition switch issues coming soon once parts are available.
Reply With Quote
  #16  
Old 11-17-2014, 08:04 AM
Member
 
Join Date: Nov 2012
Posts: 13
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 1564
Foxy69 is on a distinguished road
Re: Service 4wd system

Ok great thanks. Not sure how nice my dealers will be as they already denied faults when I spoke to them in June


Sent from my iPad using JeepGarage
Reply With Quote
  #17  
Old 12-18-2014, 07:06 PM
Member
 
Join Date: Sep 2014
Posts: 54
Thanks: 2
Thanked 1 Time in 1 Post
Rep Power: 938
Furyous68 is on a distinguished road
Re: Service 4wd system

UPDATE:

The wife sent me a pic of the dash showing a "Service 4WD System" message... S.O.B.!

I will let you guys know what I find.

Question: Are wheel speed sensors tied to the 4WD system?
Reply With Quote
  #18  
Old 12-19-2014, 06:32 AM
Hutch801's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2014
Location: Brisbane, QLD
Posts: 827
Thanks: 120
Thanked 139 Times in 115 Posts
Rep Power: 17415
Hutch801 has a reputation beyond reputeHutch801 has a reputation beyond reputeHutch801 has a reputation beyond reputeHutch801 has a reputation beyond reputeHutch801 has a reputation beyond reputeHutch801 has a reputation beyond reputeHutch801 has a reputation beyond reputeHutch801 has a reputation beyond reputeHutch801 has a reputation beyond reputeHutch801 has a reputation beyond reputeHutch801 has a reputation beyond repute
Garage
what year is yours.
__________________
Hutch: 2014 Grand Cherokee Blackhawk in Black of Course.....CRD Feel the Power..
Reply With Quote
  #19  
Old 12-19-2014, 07:14 AM
SilverLimited's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Dec 2009
Location: North Carolina
Posts: 64
Thanks: 1
Thanked 2 Times in 2 Posts
Rep Power: 2690
SilverLimited is on a distinguished road
Re: Service 4wd system

Quote:
Originally Posted by Furyous68 View Post
UPDATE:

The wife sent me a pic of the dash showing a "Service 4WD System" message... S.O.B.!

I will let you guys know what I find.

Question: Are wheel speed sensors tied to the 4WD system?
Yes they are.

My 05 Limited AWD 5.7L started throwing "service 4wd system" and "service ABS" lights/codes intermittently last year. They would clear on the next ignition cycle for days and weeks at a time, but got progressively worse. The main DTC (U1417) related to the front left wheel sensor, and the scanner also showed left rear wheel speed sensor codes. Had 130+k on the front hub bearings/speed sensors so decided to replace both. Additionally replaced the left rear speed sensor. I have not had a any IP lamps alarms or codes since in the 3 months since they were replaced. The transfer case TSB was already performed prior to replacing these bearings and sensors, but I never had any problems with shifting into or out of 4Low after the TSB.
__________________

15 WK2 Overland QTII 3.6L
05 WK Limited QDII 5.7L
01 WJ Limited QD 4.7L
00 WJ Laredo 4.0L -gone
Reply With Quote
  #20  
Old 12-19-2014, 08:00 AM
Member
 
Join Date: Nov 2012
Posts: 13
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 1564
Foxy69 is on a distinguished road
Re: Service 4wd system

I did the fuse removal trick and so far it has lasted a month and still working. Spoke to local dealer and jeep hq and told them I just wanted the new update and they said they will diagnose my truck and if it was that they would do it but if they found anything else I'd have to pay.

They got you all ways haven't they?? Not gona take it at mo as my 4wd low is still working. Don't trust any of them


Sent from my iPhone using JeepGarage
Reply With Quote
  #21  
Old 12-19-2014, 09:18 AM
Member
 
Join Date: Sep 2014
Posts: 54
Thanks: 2
Thanked 1 Time in 1 Post
Rep Power: 938
Furyous68 is on a distinguished road
Re: Service 4wd system

Thanks Silver Limited. I haven't checked the code yet but I had a sneaking suspicion it might be related. My front passenger axle boot is torn and has thrown grease all up around there. Plus, we just got a ton of rain out here in CA. Wouldn't surprise me if one or the other (or combination of the two) is messing with the sensors. I'll report back.
Reply With Quote
  #22  
Old 12-19-2014, 05:21 PM
SilverLimited's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Dec 2009
Location: North Carolina
Posts: 64
Thanks: 1
Thanked 2 Times in 2 Posts
Rep Power: 2690
SilverLimited is on a distinguished road
Re: Service 4wd system

Quote:
Originally Posted by Furyous68 View Post
Thanks Silver Limited. I haven't checked the code yet but I had a sneaking suspicion it might be related. My front passenger axle boot is torn and has thrown grease all up around there. Plus, we just got a ton of rain out here in CA. Wouldn't surprise me if one or the other (or combination of the two) is messing with the sensors. I'll report back.
Interesting that you mentioned the "rain" one of the things I noticed was both the IP lamps and throwing the code had a tendency to show up the day after rainy (heavy) days. I'm pretty convinced that putting in the new front hub bearings/sensors, and the left rear nailed my problem. I'll probably pick up the sensor for the right rear over the winter and install it to put the chance of it throwing codes to the wayside.

Then we can move onto the next WK screwup with the ignition switch recall that Chrysler still doesn't have the parts available. Curious how that's going to work out.
Reply With Quote
  #23  
Old 12-26-2014, 08:36 AM
Member
 
Join Date: Dec 2014
Posts: 45
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 845
jdmm08 is on a distinguished road
Re: Service 4wd system

This sounds similar to what I'm seeing but are you all getting an ABS light too?


Sent from my iPhone using JeepGarage
Reply With Quote
  #24  
Old 12-26-2014, 12:52 PM
Member
 
Join Date: Sep 2014
Posts: 54
Thanks: 2
Thanked 1 Time in 1 Post
Rep Power: 938
Furyous68 is on a distinguished road
Re: Service 4wd system

I didn't get an ABS light. Interestingly though... the message is gone, and 4Lo works just fine. I didn't do anything. Hasn't rained in about a week either.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
service 4wd system CatMan879 Troubleshooting/Problems Discussion 33 02-13-2014 06:46 PM
" service electric break system " and " service 4WD system " Rexie1983 Troubleshooting/Problems 0 03-18-2013 07:48 AM
Abs light, service brake system and 4wd system chaase68 Troubleshooting/Problems 15 08-09-2012 06:49 AM
Service Light - SERVICE 4WD SYSTEM - ?? Only 30K miles.... babygorilla Grand Cherokee - WK 4 02-17-2011 08:09 PM
Service 4WD System Message cain45 Grand Cherokee - WK 18 09-13-2010 06:49 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:07 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.