Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 09-02-2012, 04:32 PM
Madanio24's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,812
Thanks: 0
Thanked 20 Times in 20 Posts
Rep Power: 11033
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: service electric brake system

Come'on guys!! Bump. Driving with no abs or tranction control!!!
__________________

__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #14  
Old 09-03-2012, 01:57 PM
Madanio24's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,812
Thanks: 0
Thanked 20 Times in 20 Posts
Rep Power: 11033
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: service electric brake system

BUMP!!! one of the codes is for left rear speed sensor. could this be causing the other 8 codes?
__________________

__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #15  
Old 09-03-2012, 03:04 PM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,749
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652821
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: service electric brake system

when I first read through this my guess was a speed sensor, when a spseed sensor drops to 0 it will actuate the abs to stop the wheel from "slipping" your "vibration" you felt... mine did the same thing when a wheel speed sensor failed.

not sure on the other codes though.
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #16  
Old 09-03-2012, 08:43 PM
Madanio24's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,812
Thanks: 0
Thanked 20 Times in 20 Posts
Rep Power: 11033
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: service electric brake system

The weird thing was the car was fine when I left it. Sat for 3 months then all of these codes happened at once basically. I hope these codes are from the speed sensor. Thanks for answering.
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #17  
Old 09-07-2012, 12:20 AM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Jan 2012
Location: Harrisburg Pa
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 876
DaGreenMile is on a distinguished road
Send a message via Skype™ to DaGreenMile
Re: service electric brake system

Quote:
Originally Posted by Madanio24 View Post
Come'on guys!! Bump. Driving with no abs or tranction control!!!

im going with one of your wheel speed sensor only because i just had the same problem with on of mine i would be driving and the abs would kick in while braking the the abs traction control and service electric brake lights will all come on. On my truck it just so happen to be my front right side
__________________
Reply With Quote
  #18  
Old 09-07-2012, 07:58 AM
Madanio24's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,812
Thanks: 0
Thanked 20 Times in 20 Posts
Rep Power: 11033
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: service electric brake system

DId you check how many codes you had? I have 8 abs codes. and one of them is for the left rear wheel speed sensor.
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #19  
Old 09-07-2012, 02:19 PM
*sox*'s Avatar
Italien MOPAR Guy :-)

 
Join Date: Oct 2011
Location: Basel / Switzerland
Posts: 1,782
Thanks: 84
Thanked 64 Times in 54 Posts
Rep Power: 570708
*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute*sox* has a reputation beyond repute
Send a message via MSN to *sox* Send a message via Skype™ to *sox*
Re: service electric brake system

check the wheel sensor.
__________________
.....Have pity with my, my English is not the best



Massively Over Powered And Respected



Sox`s World
Reply With Quote
  #20  
Old 09-07-2012, 02:30 PM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Jan 2012
Location: Harrisburg Pa
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 876
DaGreenMile is on a distinguished road
Send a message via Skype™ to DaGreenMile
Re: service electric brake system

Quote:
Originally Posted by Madanio24 View Post
DId you check how many codes you had? I have 8 abs codes. and one of them is for the left rear wheel speed sensor.
thats just it i didnt get a code for the wss it came up something else cant remember the code but i knew it was because i would hit a bump on that side and right away all lights would come on. and when i check the wires to the sensor were being pulled tight in on spot so i fixed the problem and re ran the wires loose and going on a month now and still no problems
__________________
Reply With Quote
  #21  
Old 09-07-2012, 04:55 PM
Madanio24's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,812
Thanks: 0
Thanked 20 Times in 20 Posts
Rep Power: 11033
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: service electric brake system

Changed rear wheel speed sensor problem resolved. The sensor was so rusted in I had to break it off and hit it from the inside of the hub to get it out. Problem resolved.
__________________

__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Abs light, service brake system and 4wd system chaase68 Troubleshooting/Problems 15 08-09-2012 05:49 AM
service electric brake system warning.. need help! DMack89 Troubleshooting/Problems 10 01-20-2012 06:08 PM
Service electric brake system Cutthroat Grand Cherokee - WK 0 08-27-2011 02:29 PM
Service Electric Braking System hillj28 Grand Cherokee - WK 3 07-29-2011 01:56 PM
service electric brake system nenejeepGC2005 Grand Cherokee - WK 7 12-16-2010 01:35 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:30 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community