Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-13-2013, 01:16 PM
paroxysym's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: Feb 2011
Location: Baltimore, Md
Posts: 958
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 10281
paroxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond repute
still getting a misfire.. why?

So a couple weeks ago I got a CEL for a misfire on cylinder 2. Cleared it with my SC and did alittle research. Ran a bottle of techron and a full tank of gas through the jeep, followed it up with a second bottle of chevron injector cleaner with techron and still the CEL came back. So this past weekend I swapped the cylinder 1 coil pack with cylinder 2 and replaced the spark plug in cylinder 2. I also threw a bottle of seafoam in the tank and took a drive out of state. Tonight it's back and I don't know where to go from here.

Thoughts fellas? I keep clearing it with my SC, is that bad?
__________________

__________________
2007.5 WK Laredo 4.7
- OEM+ -

Future Mods: N/A
Reply With Quote
  #2  
Old 02-13-2013, 02:47 PM
brentwoodkris's Avatar
The Ever-Dissatisfied Tinkerer
My Jeep: 2005 5.7L WK
 
Join Date: Jan 2010
Location: Columbia, MO
Posts: 936
Thanks: 0
Thanked 14 Times in 14 Posts
Rep Power: 3600
brentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond repute
Garage
Re: still getting a misfire.. why?

Is the misfire for the same cylinder as before? Or did it follow the coil pack? If it followed the coil pack, it's probably a bad pack. I noticed that you didn't say you pulled the plug, and it could just be a fouled/bad/wrong gapped plug. I know with my 5.7L, they're picky about plugs...If you have a lot of miles, might be a time for a full tune up. Also noted that you didn't mention the age of the wires and if they're OEM, etc. Be sure to checkk those too. Have you done any work to it recently that would have affected the ignition system?
__________________

__________________
'05 WK GC 5.7L HEMI, Goodyear Wrangler SilentArmors, Monroe Reflex Front Struts/Monroe Load Adjusting Rear Shocks, EBC Drilled/Slotted Sport Rotors, Wagner Ceramic Brake Pads, Taylor Shorties, SRT8 Stock CAI Conversion, K&N Drop-in, Block Heater, 18.5% Tint All Around, Boston SE Speakers, 12" Alpine Type-R Sub w/ sealed box w/ RF PRIME R1000-1D, ScanGauge II w/ windshield mount, BT Catch Can w/custom bracket, Swagman Fork Mount Bicycle Rack, WeatherTech front floor liners, SRT8 Pedal Covers, eBay full LED lighting kit, Custom MDS Indicator LED Light, Mega Raizin Voltage Stabilizer & Grounding Kit, Challenger IAT Sensor, Escort Passport 9500ix, Python 5706P RS/Security/KE w/ extras, SA 5 switch panel, Fumoto Oil Valve, Overland WG Steering wheel.
Reply With Quote
  #3  
Old 02-13-2013, 04:39 PM
paroxysym's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: Feb 2011
Location: Baltimore, Md
Posts: 958
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 10281
paroxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond repute
Re: still getting a misfire.. why?

well the plugs maybe have 15k on them and i pulled the plug from cylinder 2 and replaced it with a new one and properly gapped it. the code stayed with cylinder 2 after changing coil packs. also what wires are you talking anout? i was thinking of running a can of seafoam through the brake booster as well, but wouldnt that require me to change all my plugs afterwards?

this is frustrating, i hate CELs
__________________
2007.5 WK Laredo 4.7
- OEM+ -

Future Mods: N/A
Reply With Quote
  #4  
Old 02-13-2013, 04:51 PM
brentwoodkris's Avatar
The Ever-Dissatisfied Tinkerer
My Jeep: 2005 5.7L WK
 
Join Date: Jan 2010
Location: Columbia, MO
Posts: 936
Thanks: 0
Thanked 14 Times in 14 Posts
Rep Power: 3600
brentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond repute
Garage
Re: still getting a misfire.. why?

Oh whoops I see you have a 08 4.7. My 05 5.7 has a wire loom or shorties if people replace them. You probably just have 8 plugs, and I have 16...a few differences. Regarding the seafoam, I ran 1/2 a can through my booster and didn't swap plugs afterwards with no performance loss.

CELs can be tricky. Hopefully someone with more knowledge about your specific motor will chime in soon.
__________________
'05 WK GC 5.7L HEMI, Goodyear Wrangler SilentArmors, Monroe Reflex Front Struts/Monroe Load Adjusting Rear Shocks, EBC Drilled/Slotted Sport Rotors, Wagner Ceramic Brake Pads, Taylor Shorties, SRT8 Stock CAI Conversion, K&N Drop-in, Block Heater, 18.5% Tint All Around, Boston SE Speakers, 12" Alpine Type-R Sub w/ sealed box w/ RF PRIME R1000-1D, ScanGauge II w/ windshield mount, BT Catch Can w/custom bracket, Swagman Fork Mount Bicycle Rack, WeatherTech front floor liners, SRT8 Pedal Covers, eBay full LED lighting kit, Custom MDS Indicator LED Light, Mega Raizin Voltage Stabilizer & Grounding Kit, Challenger IAT Sensor, Escort Passport 9500ix, Python 5706P RS/Security/KE w/ extras, SA 5 switch panel, Fumoto Oil Valve, Overland WG Steering wheel.
Reply With Quote
  #5  
Old 02-13-2013, 04:55 PM
Member
My Jeep: 2006 5.7L WK
 
Join Date: Dec 2011
Location: NorCal
Posts: 247
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 1395
DannyVtCa has a reputation beyond reputeDannyVtCa has a reputation beyond reputeDannyVtCa has a reputation beyond reputeDannyVtCa has a reputation beyond reputeDannyVtCa has a reputation beyond reputeDannyVtCa has a reputation beyond reputeDannyVtCa has a reputation beyond reputeDannyVtCa has a reputation beyond repute
Re: still getting a misfire.. why?

Check compression in that cylinder to see if your valves and rings are alright. You have any coolant loss? Those 4.7 are notorious for sludging the oil drain backs and causing head gasket failures. My brothers blew the head gasket on a '02 high output and my father in law blew one on his '01 durango. Coolant will misfire a cylinder. But, I'd lean more towards ignition and compression first, wires, injectors, coil pack. If the swapping of coil pack didn't solve it. Get a new injector, hemi injectors are 40-50 bucks... Yours must be less. It's not hard at all to take the rails off and pop a new injector in. If your compression is wrong, well... New valves will be needed and that I don't know about.
__________________
2006 Limited 5.7, SRT8 Manifolds, 3'' custom walker quietflow system, Crazy Jay Cam, Inertia Performance Heads, Airaid intake tube w/ KN drop in filter, srt8 pushrods, bilsteins, diablo
Reply With Quote
  #6  
Old 02-13-2013, 05:04 PM
Member
My Jeep: 2006 5.7L WK
 
Join Date: Dec 2011
Location: NorCal
Posts: 247
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 1395
DannyVtCa has a reputation beyond reputeDannyVtCa has a reputation beyond reputeDannyVtCa has a reputation beyond reputeDannyVtCa has a reputation beyond reputeDannyVtCa has a reputation beyond reputeDannyVtCa has a reputation beyond reputeDannyVtCa has a reputation beyond reputeDannyVtCa has a reputation beyond repute
Re: still getting a misfire.. why?

Leak down tests are a bit more complicated and tell you more. To do a compression pop the fuel pump fuse out. Remove all the spark plugs from one side, thread compression gauge in and crank her over. Hopefully it's not the problem and just a bad fuel injector, but its good to know if you have any cylinders starting to lose compression. I find it pretty relaxing working on my jeep, I think of it as a little bit of garage therapy. :-)
__________________
2006 Limited 5.7, SRT8 Manifolds, 3'' custom walker quietflow system, Crazy Jay Cam, Inertia Performance Heads, Airaid intake tube w/ KN drop in filter, srt8 pushrods, bilsteins, diablo
Reply With Quote
  #7  
Old 02-13-2013, 10:20 PM
paroxysym's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: Feb 2011
Location: Baltimore, Md
Posts: 958
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 10281
paroxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond repute
Re: still getting a misfire.. why?

It went out today. I'm thinking the seafoam probably ran its course. I filled her up with a fresh tank of premium so lets see how this pans out.
__________________
2007.5 WK Laredo 4.7
- OEM+ -

Future Mods: N/A
Reply With Quote
  #8  
Old 02-18-2013, 11:29 AM
paroxysym's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: Feb 2011
Location: Baltimore, Md
Posts: 958
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 10281
paroxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond repute
Re: still getting a misfire.. why?

meh its back again... damnit!
__________________
2007.5 WK Laredo 4.7
- OEM+ -

Future Mods: N/A
Reply With Quote
  #9  
Old 02-18-2013, 01:05 PM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,417
Thanks: 55
Thanked 132 Times in 114 Posts
Rep Power: 542605
robpp has disabled reputation
Re: still getting a misfire.. why?

egr?
__________________
Reply With Quote
  #10  
Old 02-18-2013, 01:57 PM
paroxysym's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: Feb 2011
Location: Baltimore, Md
Posts: 958
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 10281
paroxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond repute
Re: still getting a misfire.. why?

Quote:
Originally Posted by robpp View Post
egr?
ehhh i had the dealer change that around 75k? they could have not, i wish i stayed with the jeep when they did it.

ill have to take a look.

is there any foreseeable damage if i just continue to clear the code and continue on with it? its not running rough or anything- it does get alittle jumpy/rough when i lug her in OD, but i usually give her some gas and kick her down a gear.
__________________
2007.5 WK Laredo 4.7
- OEM+ -

Future Mods: N/A
Reply With Quote
  #11  
Old 02-18-2013, 02:03 PM
ALPINEST4RS's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: Mar 2010
Location: Brighton, MI
Posts: 340
Thanks: 8
Thanked 1 Time in 1 Post
Rep Power: 1952
ALPINEST4RS is on a distinguished road
Re: still getting a misfire.. why?

if you replaced the plug and swapped coils and it still on two.. sounds like carbon build up on the valve gap. leakdown test is the way to go..

if you continue to run the car misfiring, you can melt the converter down costing you big down the road.
__________________
2006 Jeep Grand Cherokee WK 3.7L - SOLD (lil bro's)
2007 Jeep Grand Cherokee WK 4.7L -SOLD
2011 - Mazdaspeed3 COBB AP/CS TIP-SRI/ CPE Axle Back/ Stage 1 RMM/ Internals/ Wiseco Pistons/ Forged Rods
Reply With Quote
  #12  
Old 02-18-2013, 02:56 PM
paroxysym's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: Feb 2011
Location: Baltimore, Md
Posts: 958
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 10281
paroxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond repute
Re: still getting a misfire.. why?

Quote:
Originally Posted by ALPINEST4RS View Post
if you replaced the plug and swapped coils and it still on two.. sounds like carbon build up on the valve gap. leakdown test is the way to go..

if you continue to run the car misfiring, you can melt the converter down costing you big down the road.
Is it worth running a can of seafoam through the brake booster? would i need to replace all the plugs afterwards?

leak down test?
__________________

__________________
2007.5 WK Laredo 4.7
- OEM+ -

Future Mods: N/A
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cylinder misfire Seandmac Trouble Shooting/Problems/Service 2 02-01-2013 10:41 PM
Misfire on Cylinder 7 shizzle24 Troubleshooting/Problems 6 11-03-2012 05:53 PM
2005 3.7 misfire Stillchi Troubleshooting/Problems 18 10-15-2012 07:33 PM
Cylinder 6 Misfire dogface_313 Trouble Shooting/Problems/Service 4 05-17-2012 10:23 PM
misfire cyl. 1 jeepsterjohn Troubleshooting/Problems 6 04-09-2012 03:16 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:46 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community