Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-01-2013, 11:48 PM
WK2007's Avatar
Member
My Jeep: 2007 5.7L WK
 
Join Date: Aug 2012
Location: Missouri
Posts: 84
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1758
WK2007 has a reputation beyond reputeWK2007 has a reputation beyond reputeWK2007 has a reputation beyond reputeWK2007 has a reputation beyond reputeWK2007 has a reputation beyond reputeWK2007 has a reputation beyond reputeWK2007 has a reputation beyond reputeWK2007 has a reputation beyond reputeWK2007 has a reputation beyond reputeWK2007 has a reputation beyond reputeWK2007 has a reputation beyond repute
Strange behavior

Out of the blue my vehicle started engaging in some strange behavior. While driving, the transmission will kick out of MDS, although the road is flat. It has never done that before. Gear shifts are also more erratic than normal. When shifting from Park to Drive, or from Park to Reverse, a loud clunk followed yesterday, which it has also never done before. My stereo unit will play 10-15 seconds, then cut out, then come back on after a few seconds. The display will stay lit, and show that the song is still playing. This is driving me completely nuts

About one month ago, I added an amp and subwoofer to the car, and everything has worked fine up until today. I checked the maintenance free battery and it is showing green to yellow-ish color on the charge indicator. Maybe the battery is going out? Maybe the amp is drawing too much power, causing the alternator to go out? The alternator looks as if it is the original unit from the factory, so I would not be surprised if it is time to replace it (vehicle has 100K miles on it). If this issue is the alternator, any suggestions on replacements or upgrades?

If anyone has had similar problems, I would appreciate some comments/suggestions.

Thanks everyone!
__________________

Reply With Quote
  #2  
Old 01-21-2015, 10:49 PM
Member
My Jeep: 2013 3.6L
 
Join Date: Jan 2015
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 200
JustAnotherJeepGuy is on a distinguished road
Re: Strange behavior

Sounds like you have ground issue somewhere. i suggest Disconnect the amp and Subwoofer and Trace all your lines and make sure there not grounding out on any metal. as for the battery, even its at low charge you will start to notice other things like longer than usual start times. if the battery light is not on i can only assume the Alternator is doing its job and supply enough feed back to the battery.
I cannot comment on the transmission issue because im not really sure, but a grounding/short issue will cause Loads of issues beyond what was intended IE Installing after market stereo.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
8 Speed Transmission Downshifting Behavior mswlogo Grand Cherokee - WK2 - 21 08-21-2013 06:49 AM
"Oil change required" strange/premature behavior stratoblaster Grand Cherokee - WK 11 11-14-2012 07:58 AM
Hooligan Behavior MikeBoom Grand Cherokee - WK2 - 17 06-05-2012 09:33 PM
Strange Behavior of 730N(RHR) Sid Fields Audio/Visual/Navigation 5 08-05-2011 09:44 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:13 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.