Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-26-2012, 01:21 PM
Member
My Jeep: 2006 5.7L WK
 
Join Date: Feb 2011
Location: SoNH
Posts: 193
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1499
mrmotoguzzi00 is on a distinguished road
Garage
strange electrical issue, no lights on driver side rear

Haven't posted in awhile, life gets in the way

Anyway weird problem.... looked for a wiring diagram but didn't find anything.... at least not online and/or free

2006 wk hemi limited w/nav, noticed last week that the driver side tail light is out, tried a new bulb, still didn't work...

I just pulled both tail light assemblies out, the driver side works in passenger side connector....

Got the multimeter out and turned on the lights, i have power to 1 pin on both tail light connectors... hhhmmmm

also noticed that when i put the brakes on, the driver side lamp under the headlight goes on in a glow ?

and this morning the driver side blinker blinks real fast versus the left...

usually that's a bulb ?

with all that i'm thinking bad ground ?

any clues on where to look ?

Thanks

Mike
__________________

__________________
Reply With Quote
  #2  
Old 01-26-2012, 01:40 PM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,418
Thanks: 55
Thanked 132 Times in 114 Posts
Rep Power: 542612
robpp has disabled reputation
Re: strange electrical issue, no lights on driver side rear

bulb. one filament is out./
__________________

__________________
Reply With Quote
  #3  
Old 01-26-2012, 02:05 PM
Member
My Jeep: 2006 5.7L WK
 
Join Date: Feb 2011
Location: SoNH
Posts: 193
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1499
mrmotoguzzi00 is on a distinguished road
Garage
Re: strange electrical issue, no lights on driver side rear

wish it where that easy I swapped the entire tail light assembly from the other side and got no lights... i even put the driver side light assembly into the passenger side and it worked fine.
__________________
Reply With Quote
  #4  
Old 01-26-2012, 02:16 PM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,418
Thanks: 55
Thanked 132 Times in 114 Posts
Rep Power: 542612
robpp has disabled reputation
There are separate fuses per side. Wkjeeps.com for the list. There are dome relays as well.

It might be corrosion on the back of the lamp. It uses metal in the bulb holder to distribute the power perhaps something broke cracked there. Take off both and test all contacts and electrical path on bulb holder.

GL
__________________
Reply With Quote
  #5  
Old 01-26-2012, 02:22 PM
Member
My Jeep: 2006 5.7L WK
 
Join Date: Feb 2011
Location: SoNH
Posts: 193
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1499
mrmotoguzzi00 is on a distinguished road
Garage
Re: strange electrical issue, no lights on driver side rear

fuses, will check there....
__________________
Reply With Quote
  #6  
Old 01-26-2012, 02:28 PM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,418
Thanks: 55
Thanked 132 Times in 114 Posts
Rep Power: 542612
robpp has disabled reputation
Re: strange electrical issue, no lights on driver side rear

kool should say SOME RELAYS.
__________________
Reply With Quote
  #7  
Old 01-26-2012, 03:03 PM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652950
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: strange electrical issue, no lights on driver side rear

yes there are separate brake lamp fuses iirc... there are three fuses in the power distribution center (going front to back in the vehicle, all others face side to side).
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #8  
Old 01-26-2012, 03:07 PM
Member
My Jeep: 2006 5.7L WK
 
Join Date: Feb 2011
Location: SoNH
Posts: 193
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1499
mrmotoguzzi00 is on a distinguished road
Garage
Re: strange electrical issue, no lights on driver side rear

looking thru the owners manual, gotta bring it in the garage tonight and go thru them all Thanks Guys
__________________
Reply With Quote
  #9  
Old 01-26-2012, 07:53 PM
Member
My Jeep: 2006 5.7L WK
 
Join Date: Feb 2011
Location: SoNH
Posts: 193
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1499
mrmotoguzzi00 is on a distinguished road
Garage
Re: strange electrical issue, no lights on driver side rear

ok, we are in the garage and i'm armed with bulbs and fuses found a 15amp dead fuse. swapped that and i have tail lights again. Yeah

Now I hit the left blinker and it works for maybe 10 blinks then stops blinking and the front left starts blinking fast.... ug...

I cant find the blinker relay..... is there one ?

if so where ?

There a bunch of slots saying lt and turn but they also say tow... that part of the tow package ? figure they must be because pulling those has no effect on the lights...

oh and why isn't the fuse box actually labeled with numbers to match the manual ? argh...

gonna pull the tail light assembly and ohm everything out... maybe there is a crack or something after all...

be back in a few...
__________________
Reply With Quote
  #10  
Old 01-26-2012, 08:13 PM
Member
My Jeep: 2006 5.7L WK
 
Join Date: Feb 2011
Location: SoNH
Posts: 193
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1499
mrmotoguzzi00 is on a distinguished road
Garage
FIXED Re: strange electrical issue, no lights on driver side rear

It was the friggin tow harness, disconnected the inline tow harness connectors and plugged the jeep harness directly into the tail lights and wallah all is good again.

Will deal with that tow harness when it warms up in the spring

Thanks for the help Guys!!!!
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange Electrical Gremlins BLACK DOG Grand Cherokee - ZJ 6 06-03-2011 05:14 AM
Strange Issue with Instrument lights and 430N restarts on it own. singhgill Audio/Visual/Navigation 12 02-10-2011 06:59 PM
Rear driver side sound... ParaCAD Troubleshooting/Problems 4 12-27-2010 02:51 PM
driver side turnsignal and taillight issue! ducks unlimited Troubleshooting/Problems Discussion 7 01-11-2010 07:22 PM
SOB. Driver side Lights a No Go!! DAVY27 Grand Cherokee - WK 22 12-20-2009 05:23 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:51 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community