Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #133  
Old 08-03-2012, 10:38 AM
hummer recovery team's Avatar
Member
My Jeep: 2006 4.7L XK
 
Join Date: Jan 2012
Location: Rochester MN
Posts: 761
Thanks: 4
Thanked 10 Times in 10 Posts
Rep Power: 1153087
hummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond repute
Re: Surging, pulsing while driving

Prepare for a long post, My parents 2006 jeep commander with the 3.7 has 96,000 miles on it, Idle was terrible so I drove it and the same problems you expierienced I also did, so in this order is what i did, checked code, multiple cylinder misfire, so I changed plugs and I found water in the spark plug holes, blew out the holes and reinstalled brand new ngk v power plugs (the stock ones) started it up and it ran great than it shut off radomly, checked the plugs the gap was right but there was more water, so I looked at the coil packs, the rubber o ring on the base of the coil was dry rotted and my dad washed the engine out 3 days before the problem became persistent so im assuming the coils were bad so I replaced all 6 with airtex wells as well as sprayed seafoam aerosal in each spark plug hole, problem was better but not solved next I replaced the tps sensor as well as the iac and map sensor new pcv valve new air filter, problem alot better engine does not shake anymore, but the pulsing remains so I changed the tranny fluid and filter I cycled the tranny with hoses disconnected to get all old fluid out and new cycled in as well, I used castrol atf+4, changed the tranfer case fluid atf+4 also both front and rear diff with royal purple 75w-140, ran great alot better shifts, all that fluid was original so with 96,000 on the clock it was good to change those fluids, next I seafoamed the brake booster vac line and I poured half a can in the oil and a (FULL CAN) in the gas to really clean out the injectors, I drove it and holy smoke it was so white at first than just black as tar, I told my dad to drive the jeep until the gas was almost empty he did, than I changed the engine oil to mobile 1 full synthetic extended performance 5w30 with a mobil 1 filter, he previously ran royal purple stuff filter as well as 5w30 oil, took her for a spin and bam alot better much improvement, but I hate to say this, the problem was not all fixed all though I cant here the motor running with the windows down and engine in drive the rpms are at 650 which is where they should be, next I took off the throttle body and cleaned it well and sprayed some seafoam aerosol in the intake manifold while I had the tbody off I decided to do a home port job with a die grinder and different compounds, reinsatlled and wow big differnece in throttle response, engine runs silent still very good sound at idle. I decided that the engine could just be suffering from tranny lock up issues since the engine is sound now, so the guy who rebuilt my tranny in my jeep, took a look at the jeep and fixed the leaking cooler return hoses for the tranny and he retuned the tranny shift points with this scan tool it was a huge looking computer tool and the problem is gone!!! Than yesterday my dad said the engine idle is at 800 so I look at the throttle body and the chrome tube off the side of the t body is cracked so hence creating a vacuum leak so Im looking for a throttle body to fix that now, but overall this took me 2 weeks to figure out and cost my parents about $1,000 in parts and the tranny guys labor, the jeep has never ran so great, like I said the idle is perfect no bucking no hesitation and no rough shaking just an overall better ride since the tranny re tune the shifts are nice and firm it deffinitly doesnt shift like a girls jeep now!

Hope this helps answer a few of your Q's

-Connor
__________________

__________________
06 XK 4.7, Lots of Mods.

"Jeep is Americas only true sports car" -Enzo Ferrari
Reply With Quote
  #134  
Old 08-03-2012, 06:02 PM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,937
Thanks: 20
Thanked 29 Times in 28 Posts
Rep Power: 11275
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: Surging, pulsing while driving

Wow nice writeup! Who exactly did you get to retune the trans? and i have done basicvally everything you have done except I would very much now like to seal the coils with that clear grease because i noticed it is much worse in the rain the problem.
__________________

__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #135  
Old 08-03-2012, 08:26 PM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,937
Thanks: 20
Thanked 29 Times in 28 Posts
Rep Power: 11275
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: Surging, pulsing while driving

Do you think i should add the sonnax line pressure booster to help with my pulsing problem?
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #136  
Old 08-04-2012, 11:00 AM
hummer recovery team's Avatar
Member
My Jeep: 2006 4.7L XK
 
Join Date: Jan 2012
Location: Rochester MN
Posts: 761
Thanks: 4
Thanked 10 Times in 10 Posts
Rep Power: 1153087
hummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond repute
Re: Surging, pulsing while driving

I went to Q Transmission in Rochester MN, I used the dielectric grease on my new coils and on the o rings, the sonnax line booster at least quentin at the tranny shop said would make the shifts firmer, so I had him just retune the trans and re tune when the tourque converter locks up.
__________________
06 XK 4.7, Lots of Mods.

"Jeep is Americas only true sports car" -Enzo Ferrari
Reply With Quote
  #137  
Old 08-04-2012, 12:12 PM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,937
Thanks: 20
Thanked 29 Times in 28 Posts
Rep Power: 11275
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: Surging, pulsing while driving

How much was the cost of it? and did he retune it manually or use a specific tune he had? Very interesting by the way. Will the pressure booster stop the torque converter lockup by using higher pressure?
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #138  
Old 08-05-2012, 10:21 AM
hummer recovery team's Avatar
Member
My Jeep: 2006 4.7L XK
 
Join Date: Jan 2012
Location: Rochester MN
Posts: 761
Thanks: 4
Thanked 10 Times in 10 Posts
Rep Power: 1153087
hummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond repute
Re: Surging, pulsing while driving

He has a computer and put the tranny in a relearn mode or something and went from there. No idea about the sonnax.
__________________
06 XK 4.7, Lots of Mods.

"Jeep is Americas only true sports car" -Enzo Ferrari
Reply With Quote
  #139  
Old 08-05-2012, 11:48 AM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,937
Thanks: 20
Thanked 29 Times in 28 Posts
Rep Power: 11275
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: Surging, pulsing while driving

damn i wonder why the dealers couldnt figure this out. The mechanic i spoke to knew the torque converter was locking up and opening but he couldnt figure out why because the voltage from the tps to the tranny was normal. They even sent fly by results to chrysler for analysis and all sensors were normal. I hope my tuner i ordered can correct this problem because I am pretty OCD about how my car runs lol.
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #140  
Old 08-05-2012, 02:00 PM
paroxysym's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: Feb 2011
Location: Baltimore, Md
Posts: 955
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 10275
paroxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond repute
Re: Surging, pulsing while driving

alright so quick update..

yesterday i had the 90k service done. i had both diffs drained refilled along with the case. as for the tranny i had it drained and refilled, along with both filters replaced, as well as my spark plugs replaced. drove her home, everything seemed fine. she still shuttle shifts every now and then, but the vibe i had when hitting it and merging into traffice around 45-55 is gone. i also am not experiencing and more rough shifting (it was kind of slam into gear from time to time when i let off and got back on it). the hesitation from 3-4 is still there but like i said its not as pronounced. she is actually shifting nicely.

im running the stock tune with my superchips. im going to be adding the sonnax line pressure adapter this week and maybe switching my tune to the 91 tune. i think that may help the shifts, but im not 100%. its bareable now that i know i have done what i can as far as maintenance and it hasnt throw a CEL or anything, maybe its just something i need to get used to until the jeep itself throws a code to tell me somethings up.
__________________
2007.5 WK Laredo 4.7
- OEM+ -

Future Mods: N/A
Reply With Quote
  #141  
Old 08-05-2012, 04:22 PM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,937
Thanks: 20
Thanked 29 Times in 28 Posts
Rep Power: 11275
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: Surging, pulsing while driving

Im thinking it could be my tranny fluid. They added half of mobil1 half of valvoline. Let me know how the pressure booster works and if it imrpvoes shifting.
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #142  
Old 08-05-2012, 05:10 PM
paroxysym's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: Feb 2011
Location: Baltimore, Md
Posts: 955
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 10275
paroxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond repute
Re: Surging, pulsing while driving

Quote:
Originally Posted by Madanio24 View Post
Im thinking it could be my tranny fluid. They added half of mobil1 half of valvoline. Let me know how the pressure booster works and if it imrpvoes shifting.
I showed up with the recommended tranny fluid amount and they still had to add more so I think they drained the hell out of it. I think they added some of my old fluid back in- it was really clean since I have it changed every 15k.

I'll report back on the pressure adapter. Im really starting to think its all in my head- as I have a habit to be a perfectionist about how my jeep runs and performs. I'm just accepting that's it's normal. Lol. Maybe when I bump up to a 33" tire it will be normal haha.
__________________
2007.5 WK Laredo 4.7
- OEM+ -

Future Mods: N/A
Reply With Quote
  #143  
Old 08-05-2012, 05:15 PM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Aug 2011
Location: Calgary, AB
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1121
fajita123 is on a distinguished road
Re: Surging, pulsing while driving

Hey, I also had surging / bucking while accelerating and sometimes while maintaining speed. I replaced the camshaft and crankshaft position sensors (<$50) and the problem was fixed.

(Before doing this, I had changed the EGR & spark plugs, but still had the problem).

Good luck!
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #144  
Old 08-05-2012, 06:21 PM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,937
Thanks: 20
Thanked 29 Times in 28 Posts
Rep Power: 11275
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: Surging, pulsing while driving

Quote:
Originally Posted by fajita123 View Post
Hey, I also had surging / bucking while accelerating and sometimes while maintaining speed. I replaced the camshaft and crankshaft position sensors (<$50) and the problem was fixed.

(Before doing this, I had changed the EGR & spark plugs, but still had the problem).

Good luck!
did you have any codes? I have changed a ton of parts and are unsure if its a problem with the transmission or engine. I have not replaced the camshaft position sensor or crankshaft position sensor.
__________________

__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Surging/shuddering between 40-60mph in 5.7l Troy Cruise Trouble Shooting/Problems/Service 44 01-02-2014 06:34 PM
surging jeep5.7 Troubleshooting/Problems 3 09-26-2011 01:30 PM
Surging at WOT then code thrown fajita123 Troubleshooting/Problems 4 09-12-2011 11:50 PM
Surging RPM Suppo32 Trouble Shooting/Problems/Service 6 08-06-2011 06:44 AM
Engine Surging jeep2011 Engine Performance/Intakes/Exhausts 12 11-11-2010 11:22 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:41 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community