Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #37  
Old 02-24-2012, 10:48 AM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,911
Thanks: 8
Thanked 28 Times in 27 Posts
Rep Power: 11222
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: Surging, pulsing while driving

Quote:
Originally Posted by tig488 View Post
i have/had the same issue. after plugs, egrs, vacuum leaks fixed, it still does it. there is a "dead" spot in the accelerator at around 1700 rpms. i have noticed mine only does it in overdrive, and not when i put it in 4th. it appears to be an overdrive problem. i did find that if i reset the ecu it gets better for a while, until the ecu relearns my driving habits. i also notice it got a little better when i topped off my tranny fluid. but it never fully goes away.
Were you getting an codes thrown for the vacuum leak? Mine does it in 3rd + and is very annoying pulsing and won't go away until i give it more gas and its a temp fix. I wish i could figure out what it is...
__________________

__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #38  
Old 02-24-2012, 03:48 PM
Bleeding Blue's Avatar
Member
My Jeep: 2005 3.7L WK
 
Join Date: May 2011
Location: Indianapolis, IN
Posts: 509
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 27876
Bleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond repute
Re: Surging, pulsing while driving

I just put new plugs in mine about 10,000 miles ago, but I may replace them again this spring to see if it helps.
__________________

__________________
"When my time on earth is gone, and my activities here are passed, I want they bury me upside down, and my critics can kiss my ass!"

- Bobby Knight
Reply With Quote
  #39  
Old 02-24-2012, 07:07 PM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,911
Thanks: 8
Thanked 28 Times in 27 Posts
Rep Power: 11222
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: Surging, pulsing while driving

Quote:
Originally Posted by Bleeding Blue View Post
I just put new plugs in mine about 10,000 miles ago, but I may replace them again this spring to see if it helps.
What the of plugs did you put in? i at first had autolite's from walmart lol and they were suppppppppper crappy. Now i switched to bosch platinum from auto zone and it started running a lot better. I just with my car was throwing codes so i knew that to change...........
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #40  
Old 02-24-2012, 08:24 PM
Bleeding Blue's Avatar
Member
My Jeep: 2005 3.7L WK
 
Join Date: May 2011
Location: Indianapolis, IN
Posts: 509
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 27876
Bleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond repute
Re: Surging, pulsing while driving

Quote:
Originally Posted by Madanio24 View Post
What the of plugs did you put in? i at first had autolite's from walmart lol and they were suppppppppper crappy. Now i switched to bosch platinum from auto zone and it started running a lot better. I just with my car was throwing codes so i knew that to change...........
Honestly im not sure, I replaced them the first week I got my Jeep and before I joined this forum. Im gonna go with the NGK's this go round though.
__________________
"When my time on earth is gone, and my activities here are passed, I want they bury me upside down, and my critics can kiss my ass!"

- Bobby Knight
Reply With Quote
  #41  
Old 02-24-2012, 09:38 PM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,911
Thanks: 8
Thanked 28 Times in 27 Posts
Rep Power: 11222
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: Surging, pulsing while driving

Good Choce! i Also mistakenly installed the automates into my Girlfriends mustang and the car didn't run well at all!! Then i switched to the oem motor craft plugs and it ran beautifully with no codes at all.
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #42  
Old 02-25-2012, 10:05 PM
Member
 
Join Date: Dec 2009
Posts: 278
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2145
tig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond repute
Re: Surging, pulsing while driving

Quote:
Originally Posted by Madanio24 View Post
Were you getting an codes thrown for the vacuum leak? Mine does it in 3rd + and is very annoying pulsing and won't go away until i give it more gas and its a temp fix. I wish i could figure out what it is...
i was getting P0600 which is a cylinder misfire. i havent gotten it in a long time. the WK isnt consistent, ill go a long time with issues, they they disappear.
__________________
Reply With Quote
  #43  
Old 02-26-2012, 05:46 PM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,911
Thanks: 8
Thanked 28 Times in 27 Posts
Rep Power: 11222
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: Surging, pulsing while driving

Quote:
Originally Posted by tig488 View Post
i was getting P0600 which is a cylinder misfire. i havent gotten it in a long time. the WK isnt consistent, ill go a long time with issues, they they disappear.
Mine used to do that too it would come on then turn off. Eventually it just stopped after the car sat for a few weeks.
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #44  
Old 03-09-2012, 07:17 AM
Member
 
Join Date: Oct 2009
Posts: 86
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 9316
harricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond repute
Re: Surging, pulsing while driving

Quote:
Originally Posted by Geevis View Post
I've had the same issue with my 06 for a while.. I believe it's been documented elsewhere on the site and is related to an issue with the torque converter.

From what I read, Geevis right. it's kind of a lugging at speed. I should've had the torque converter changed under my 7/70 but didnt. A new torque converter seem to cure that problem on the HEMI. I didnt renew the warranty so I'm SOL. I just select a lower gear. I drive around town in "3" I got a couple tenths on the MPG too....Since the stock system rattles at times, I am thinking about an improved exhaust system.....If the motor can breath better, it may broaden the torque curve and improve driveability.

that's a long shot though
__________________
Reply With Quote
  #45  
Old 03-18-2012, 09:04 AM
Madanio24's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,911
Thanks: 8
Thanked 28 Times in 27 Posts
Rep Power: 11222
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: Surging, pulsing while driving

Just an update... My problem is getting very bad. I will just be cruising and it will start pulsing if I have to go up a hill or needs more power. Then I have to push in the gas pedal very far in order to get it to stop. Almost to the point of accelerating rapidly. Dead spot in the throttle almost. Then I also get a vibrating sound when it pulses, almost like a cylinder is knocking. If I can't find solution I have to take it into a mechanic.
__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #46  
Old 03-18-2012, 10:21 AM
Bleeding Blue's Avatar
Member
My Jeep: 2005 3.7L WK
 
Join Date: May 2011
Location: Indianapolis, IN
Posts: 509
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 27876
Bleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond repute
Re: Surging, pulsing while driving

Quote:
Originally Posted by Madanio24 View Post
Just an update... My problem is getting very bad. I will just be cruising and it will start pulsing if I have to go up a hill or needs more power. Then I have to push in the gas pedal very far in order to get it to stop. Almost to the point of accelerating rapidly. Dead spot in the throttle almost. Then I also get a vibrating sound when it pulses, almost like a cylinder is knocking. If I can't find solution I have to take it into a mechanic.
Mine is doing the exact same still, I have to punch it to get through the pulsing. Frustrating.
__________________
"When my time on earth is gone, and my activities here are passed, I want they bury me upside down, and my critics can kiss my ass!"

- Bobby Knight
Reply With Quote
  #47  
Old 03-18-2012, 04:05 PM
Member
My Jeep: 2006 5.7L WK
 
Join Date: Dec 2009
Location: Home of the Mountain Blue Bird
Posts: 986
Thanks: 0
Thanked 18 Times in 16 Posts
Rep Power: 154863
jeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond repute
Re: Surging, pulsing while driving

Lazy O2 Sensor(s), Cat(s). going bad, MAP Sensor, in that order???
__________________
05 LX/RT & 06 WK/GCO, modded similarly, MDS "ON" Light, Vortex Gens, Debadged, DashHawk, BT Catch Can, SRT CAI W/Add Air Inlet, K&N Filter, Sonnax Trans Press Booster, SC Tuner W/Adv Trans Tuning App, DS Tuner, Cust tube headers w/3 in. catback, Bilsteins, SRT frt/rear bumpers, Eibach SRT Lwr Sprgs & Sways, FRI Sidewinder Cam Adv 2*, 6.1 valvetrain, SLP 25% UD Pulley, BBK 90mm TB, SOS Coils/.060 plug gaps. 20 in. SRT Reps.
Reply With Quote
  #48  
Old 03-18-2012, 07:21 PM
Bleeding Blue's Avatar
Member
My Jeep: 2005 3.7L WK
 
Join Date: May 2011
Location: Indianapolis, IN
Posts: 509
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 27876
Bleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond reputeBleeding Blue has a reputation beyond repute
Re: Surging, pulsing while driving

Is there a way to check the Cats? I replaced one of my O2's a few weeks ago, maybe I will just go ahead and do the other 3
__________________

__________________
"When my time on earth is gone, and my activities here are passed, I want they bury me upside down, and my critics can kiss my ass!"

- Bobby Knight
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Surging/shuddering between 40-60mph in 5.7l Troy Cruise Trouble Shooting/Problems/Service 44 01-02-2014 06:34 PM
surging jeep5.7 Troubleshooting/Problems 3 09-26-2011 01:30 PM
Surging at WOT then code thrown fajita123 Troubleshooting/Problems 4 09-12-2011 11:50 PM
Surging RPM Suppo32 Trouble Shooting/Problems/Service 6 08-06-2011 06:44 AM
Engine Surging jeep2011 Engine Performance/Intakes/Exhausts 12 11-11-2010 11:22 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:39 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community