Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 06-28-2012, 12:03 PM
Member
 
Join Date: Oct 2011
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 978
d9hp is on a distinguished road
Re: think my tranny is going...

Just FYI...I had the same problem with mine. Tow mode helped, as you mention.

It continued to get worse until one day it just tanked. Limp mode came on and it was just horrible. Felt like it had just completely blown.

Took it to the dealership and they said $6k for a new one. I had it towed to my buddy's shop and we dropped the pan.

The ****ing filter grommet had worn and the filter had dropped a tiny, tiny bit to where there wasn't enough of a seal on it.

Got a new one and put it back together and the damn thing hasn't caused me a single problem since.

I'd do a tranny service first thing and see where you're at after that. You might save yourself a huge heartache.
__________________

__________________
Reply With Quote
  #14  
Old 06-28-2012, 12:39 PM
Member
 
Join Date: Dec 2009
Posts: 278
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2048
tig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond repute
Re: think my tranny is going...

now that you mentioned it, i did have problems getting the grommet out when i did the internal filter change in the tranny. i used a screwdriver and tried to pop it out but couldnt in fear of damaging it. i wonder if i actually did damage it and the filter did drop. but isnt the flat square filter bolted in?
__________________

__________________
Reply With Quote
  #15  
Old 06-28-2012, 03:04 PM
Member
My Jeep: 2006 5.7L WK
 
Join Date: Dec 2009
Location: Home of the Mountain Blue Bird
Posts: 935
Thanks: 0
Thanked 17 Times in 15 Posts
Rep Power: 154714
jeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond repute
Re: think my tranny is going...

The correct installation of the main filter is critical to proper tranny operation. Here is the caution from the FSM regarding the filter installation:

"CAUTION: The primary oil filter seal MUST be fully
installed flush against the oil pump body. DO NOT
install the seal onto the filter neck and attempt to
install the filter and seal as an assembly. Damage
to the transmission will result."

If you're not sure it was installed correctly, IMO, it's probably worth another look to verify.
__________________
05 LX/RT & 06 WK/GCO, modded similarly, MDS "ON" Light, Vortex Gens, Debadged, DashHawk, BT Catch Can, SRT CAI W/Add Air Inlet, K&N Filter, Sonnax Trans Press Booster, SC Tuner W/Adv Trans Tuning App, DS Tuner, Cust tube headers w/3 in. catback, Bilsteins, SRT frt/rear bumpers, Eibach SRT Lwr Sprgs & Sways, FRI Sidewinder Cam Adv 2*, 6.1 valvetrain, SLP 25% UD Pulley, BBK 90mm TB, SOS Coils/.060 plug gaps. 20 in. SRT Reps.
Reply With Quote
  #16  
Old 06-28-2012, 03:27 PM
Member
 
Join Date: Dec 2009
Posts: 278
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2048
tig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond repute
Re: think my tranny is going...

im know i didnt install it as an assembly. i removed the old filter, attempted to remove the seal but didnt want to destroy anything so i stopped, then i installed the new filter. im just wondering if maybe i distorted the area in the seal that the filter tube slides into. i cant remember if it was stuttering right after i did the last tranny service but it has been going on for a while and it all of a sudden started happening pretty bad on every drive.

ill do a fluid change next week and double check that since its been about 60K miles since the last complete overhaul. should i replace the tranny cooler filter? i didnt do that before. i still have a brand new seal that i never installed.
__________________
Reply With Quote
  #17  
Old 06-28-2012, 04:38 PM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,328
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524722
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: think my tranny is going...

When changing the fluid, best is to change both filters as well. The round spin-on cooler return filter and the oval shaped pump inlet filter. A slight damage to the oval shaped filter seal could let a little air come together with the fluid and cause strange shift behaviour. If the filter would completely disconnect from the seal, the tranny looses all fluid pressure and finally the jeep will not move anymore.
The round spin-on filter can be somewhat hard to remove without the proper spanner.
Regarding the bucking at lower rpm, couldn't that be a problem of the engine itself?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #18  
Old 06-29-2012, 10:52 AM
Member
My Jeep: 2006 5.7L WK
 
Join Date: Dec 2009
Location: Home of the Mountain Blue Bird
Posts: 935
Thanks: 0
Thanked 17 Times in 15 Posts
Rep Power: 154714
jeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond repute
Re: think my tranny is going...

X2^^^. Also, IIRC, there was a TSB on some of the early (05-06) cooler return (spin on) filters, but I don't remember exactly what the problem was. Definitely change it though. Check for TSB's here: http://www.jeepgarage.org/showthread...369#post649369
__________________
05 LX/RT & 06 WK/GCO, modded similarly, MDS "ON" Light, Vortex Gens, Debadged, DashHawk, BT Catch Can, SRT CAI W/Add Air Inlet, K&N Filter, Sonnax Trans Press Booster, SC Tuner W/Adv Trans Tuning App, DS Tuner, Cust tube headers w/3 in. catback, Bilsteins, SRT frt/rear bumpers, Eibach SRT Lwr Sprgs & Sways, FRI Sidewinder Cam Adv 2*, 6.1 valvetrain, SLP 25% UD Pulley, BBK 90mm TB, SOS Coils/.060 plug gaps. 20 in. SRT Reps.
Reply With Quote
  #19  
Old 07-01-2012, 05:19 AM
kycoolcat's Avatar
Member
My Jeep: 2005 3.7L WK
 
Join Date: Apr 2010
Location: Paintsville, Ky.
Posts: 121
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1578
kycoolcat is on a distinguished road
Re: think my tranny is going...

sounds like the same problem i have been having with my 3.7 since i got it. i just change the trans filter and it will quit for awhile then start back after about 20k.
__________________
KYCOOLCAT
Reply With Quote
  #20  
Old 07-02-2012, 10:27 AM
Member
My Jeep: 2006 5.7L WK
 
Join Date: Dec 2009
Location: Home of the Mountain Blue Bird
Posts: 935
Thanks: 0
Thanked 17 Times in 15 Posts
Rep Power: 154714
jeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond repute
Re: think my tranny is going...

Kycoolcat, the transmission in your 3.7 is different, so some/most of the above may not apply to yours. The site for the TSB's applies to all models though.
__________________

__________________
05 LX/RT & 06 WK/GCO, modded similarly, MDS "ON" Light, Vortex Gens, Debadged, DashHawk, BT Catch Can, SRT CAI W/Add Air Inlet, K&N Filter, Sonnax Trans Press Booster, SC Tuner W/Adv Trans Tuning App, DS Tuner, Cust tube headers w/3 in. catback, Bilsteins, SRT frt/rear bumpers, Eibach SRT Lwr Sprgs & Sways, FRI Sidewinder Cam Adv 2*, 6.1 valvetrain, SLP 25% UD Pulley, BBK 90mm TB, SOS Coils/.060 plug gaps. 20 in. SRT Reps.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tranny wkjeepgirl86 Grand Cherokee - WK 5 11-26-2011 12:37 PM
tranny problem? MattyDipps Grand Cherokee - WK 8 10-12-2011 07:06 PM
'00 42RE Tranny vs. '96 43RE Tranny freemyer Troubleshooting/Problems 6 07-07-2011 11:03 PM
Tranny Djsal5 Grand Cherokee - WK 8 05-18-2011 04:01 PM
wk tranny help Publio Salazar Grand Cherokee - WK 1 02-28-2010 10:07 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:46 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community