Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-24-2012, 10:43 PM
Member
 
Join Date: Dec 2009
Posts: 278
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2173
tig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond repute
think my tranny is going...

ive read a few threads on this before and nothing about what causes it or how to fix it.

i have an 05 hemi, with 115K miles. ive had this slight studder for years but it seems to be getting worse. it happens when accelerating in the low rpm range when it should downshift but doesnt. it feels exactly like when youre driving a manual and try to go up a hill in too high of a gear and the car bucks. if i shift it myself it rarely does it because i can control the shift points. i added some fluid but no help.

tranny replacement?
__________________

__________________
Reply With Quote
  #2  
Old 06-25-2012, 12:42 AM
Escape's Avatar
Senior Member
 
Join Date: Jul 2009
Location: Michigan
Posts: 1,911
Thanks: 0
Thanked 26 Times in 25 Posts
Rep Power: 113206
Escape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond repute
Re: think my tranny is going...

Trans sounds mechanically fine.

Any codes?
Have you ever had it serviced (trans and engine)?
Correct spark plugs and are they properly gapped?
What does the fluid look like when you pull the dipstick out and place a dot of fluid on a piece of white paper?
Have the filters ever been changed?
Water in the fluid (looks like chocolate milk)?
Dropped the pan and looked for shavings/chunks?

If it's in the trans I'd say it's in the solenoids/fluid/sensors/filters or valve body.

If it's not slipping get it serviced.
__________________

__________________
[SIGPIC][/SIGPIC]
Forged, Stroked, Blown, Bottle Fed & More
Reply With Quote
  #3  
Old 06-25-2012, 09:28 AM
Member
 
Join Date: Dec 2009
Posts: 278
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2173
tig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond repute
Re: think my tranny is going...

i changed the tranny fluid and tranny filter at 65K miles. i use Castrol ATF4+ fluid. the engine is spot on, no issues with that. i dont get any codes,even during the surging it never throws a code. the fluid on the dipstick is still pink/red.

1st, 2nd, and 3rd gear changes are fine, if the rpms are over 2k. once it goes into 4th and OD, if the rpms are below 2K it hesitates with acceleration. i can even hold it steady and it will buck and stutter as long as i hold it there. then, if i stomp on it, it downshifts and goes, OR, goes into a kinda limp mode where it wont go just revs, then i have to let off for it to engage, then its fine.

ive changed the EGR, plugs, fluids, air filter, cleaned the TB, and have no CELs, i thought it might be low tranny fluid so i added some but it didnt help.

i called the jeep dealership, they said more than likely the filter and fluid are fine since i did it at 65K. i saw a TSB about something similar to this. i wonder if the shift points are out of spec. it feels exactly like trying to go uphill in a stickshift in too high of a gear.
__________________
Reply With Quote
  #4  
Old 06-25-2012, 10:03 AM
brentwoodkris's Avatar
The Ever-Dissatisfied Tinkerer
My Jeep: 2005 5.7L WK
 
Join Date: Jan 2010
Location: Columbia, MO
Posts: 935
Thanks: 0
Thanked 14 Times in 14 Posts
Rep Power: 3597
brentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond repute
Garage
Re: think my tranny is going...

Maybe your MDS is screwing up?
__________________
'05 WK GC 5.7L HEMI, Goodyear Wrangler SilentArmors, Monroe Reflex Front Struts/Monroe Load Adjusting Rear Shocks, EBC Drilled/Slotted Sport Rotors, Wagner Ceramic Brake Pads, Taylor Shorties, SRT8 Stock CAI Conversion, K&N Drop-in, Block Heater, 18.5% Tint All Around, Boston SE Speakers, 12" Alpine Type-R Sub w/ sealed box w/ RF PRIME R1000-1D, ScanGauge II w/ windshield mount, BT Catch Can w/custom bracket, Swagman Fork Mount Bicycle Rack, WeatherTech front floor liners, SRT8 Pedal Covers, eBay full LED lighting kit, Custom MDS Indicator LED Light, Mega Raizin Voltage Stabilizer & Grounding Kit, Challenger IAT Sensor, Escort Passport 9500ix, Python 5706P RS/Security/KE w/ extras, SA 5 switch panel, Fumoto Oil Valve, Overland WG Steering wheel.
Reply With Quote
  #5  
Old 06-25-2012, 10:53 AM
Member
My Jeep: 2006 5.7L WK
 
Join Date: Dec 2009
Location: Home of the Mountain Blue Bird
Posts: 992
Thanks: 0
Thanked 19 Times in 17 Posts
Rep Power: 154896
jeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond repute
Re: think my tranny is going...

Probably the easiest (and cheapest) way to beat this is to do two things.....get a Sonnax Line Pressure Booster, and a Superchips Tuner with the Advanced Transmission Tuning Application. Then you'll boost the trans. clutch clamping pressure and you can set the up/down shift schedules to suit your needs/desires. I've got both on my Hemi, and everything works great.

I'd also do another trans. service since it's been quite a while since you last did it.
__________________
05 LX/RT & 06 WK/GCO, modded similarly, MDS "ON" Light, Vortex Gens, Debadged, DashHawk, BT Catch Can, SRT CAI W/Add Air Inlet, K&N Filter, Sonnax Trans Press Booster, SC Tuner W/Adv Trans Tuning App, DS Tuner, Cust tube headers w/3 in. catback, Bilsteins, SRT frt/rear bumpers, Eibach SRT Lwr Sprgs & Sways, FRI Sidewinder Cam Adv 2*, 6.1 valvetrain, SLP 25% UD Pulley, BBK 90mm TB, SOS Coils/.060 plug gaps. 20 in. SRT Reps.
Reply With Quote
  #6  
Old 06-25-2012, 02:08 PM
Member
 
Join Date: Dec 2009
Posts: 278
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2173
tig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond repute
Re: think my tranny is going...

all good ideas, thanks guys, keep em coming.

ill probably do a tranny service to see if that helps.
__________________
Reply With Quote
  #7  
Old 06-25-2012, 10:26 PM
Escape's Avatar
Senior Member
 
Join Date: Jul 2009
Location: Michigan
Posts: 1,911
Thanks: 0
Thanked 26 Times in 25 Posts
Rep Power: 113206
Escape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond repute
Re: think my tranny is going...

Quote:
Originally Posted by tig488 View Post
1st, 2nd, and 3rd gear changes are fine, if the rpms are over 2k. once it goes into 4th and OD, if the rpms are below 2K it hesitates with acceleration. i can even hold it steady and it will buck and stutter as long as i hold it there. then, if i stomp on it, it downshifts and goes, OR, goes into a kinda limp mode where it wont go just revs, then i have to let off for it to engage, then its fine.
The reving without going is concerning. Do you have the limp mode dash lights when this happens? If not that sounds like a worn clutch pack.

I would do as suggested above and get a tuner for it and retune that trans as the factory settings suck and go from there.
__________________
[SIGPIC][/SIGPIC]
Forged, Stroked, Blown, Bottle Fed & More
Reply With Quote
  #8  
Old 06-26-2012, 02:30 AM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652942
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Just so its said... The aforementioned additions WILL NOT FIX ANYTHING. They may mask the problem (unlikely) but they will not fix your complaints.

*edit* Im not trying to be a douche with my response, I just want to make sure its known that adding modifications to the outside of a transmission will not fix something failing inside it might cover up the effects of the failing item(s) but will not fix anything.

Has it gotten worse or is it something that has just kinda been there for a long time? As suggested with the MDS, I have felt some less than stellar drivability from the MDS, just feeling like its taking too long to kick out. Ultimately this may be something you need to get to a shop... I will say even if you are a diy'er pulling this trans on your back in a garage would be HELL... impossible no, but HELL, yes.
Sent from my SCH-I500 using Tapatalk 2
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #9  
Old 06-27-2012, 12:51 PM
Member
 
Join Date: Dec 2009
Posts: 278
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2173
tig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond repute
Re: think my tranny is going...

not a single CEL or dash light comes on during this.
__________________
Reply With Quote
  #10  
Old 06-27-2012, 07:00 PM
Member
My Jeep: 2006 5.7L WK
 
Join Date: Dec 2009
Location: Home of the Mountain Blue Bird
Posts: 992
Thanks: 0
Thanked 19 Times in 17 Posts
Rep Power: 154896
jeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond reputejeepgcoman has a reputation beyond repute
Re: think my tranny is going...

2005JGC, I am sure no one is thinking you're a douche. Speak your mind man, LOL! IMO, the 545RFE is a little (actually quite a bit) lacking to begin with, and if there are no real problems after servicing and verifying it's working as the DCX folks say it should, then adding the "masks" is a pretty good way to resolve some of the built in problems many of us complain about. It's hard for me to say, but with the line pressure booster and the ATT App., I am now actually fairly satisfied with the way it operates. In tig488's situation, I'd for sure start with a trans. service, especially if he's unaware of the past maintenance history, or hasn't serviced it in a while.

As far as the MDS goes, you're right. Even the way mine is set up, the MDS is sometimes a little goofy. Most of it happens when it's right on the cusp of meeting the torque %age requirement for activation. In that case mine will hunt, and I just backshift a gear if it gets too bad. Mine, with the SC tuner, also is a little harsh on the disengagement, but engagement is normally good.
__________________
05 LX/RT & 06 WK/GCO, modded similarly, MDS "ON" Light, Vortex Gens, Debadged, DashHawk, BT Catch Can, SRT CAI W/Add Air Inlet, K&N Filter, Sonnax Trans Press Booster, SC Tuner W/Adv Trans Tuning App, DS Tuner, Cust tube headers w/3 in. catback, Bilsteins, SRT frt/rear bumpers, Eibach SRT Lwr Sprgs & Sways, FRI Sidewinder Cam Adv 2*, 6.1 valvetrain, SLP 25% UD Pulley, BBK 90mm TB, SOS Coils/.060 plug gaps. 20 in. SRT Reps.
Reply With Quote
  #11  
Old 06-28-2012, 09:06 AM
Member
 
Join Date: Dec 2009
Posts: 278
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2173
tig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond reputetig488 has a reputation beyond repute
Re: think my tranny is going...

so today i drove it in tow/haul mode, and it ran almost completely normal. granted the shift points are different in that mode so the rpms change and theres no OD, but it didnt hesitate at all. mpg is a little lower but runs much much better. it also ran a little better with TCS off. not saying those are fixing it, i was just trying anything.
__________________
Reply With Quote
  #12  
Old 06-28-2012, 09:26 AM
paroxysym's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: Feb 2011
Location: Baltimore, Md
Posts: 957
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 10278
paroxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond reputeparoxysym has a reputation beyond repute
Re: think my tranny is going...

mine does the same thing... feels like its lugging it in the higher gears- like it should downshift but it doesnt, until you punch it then it knocks itself down a gear and goes. i change my fluid every 15k as advised by a mechanic friend that works for jeep. these trannies can take a beating and surprisingly have had no problems.

maybe you should reset your the adaptives- disconnect the battery and let it set a few minutes, turn the headlights on and hold the brake for a minute. supposedly it clears your comp.. then when you connect and take it for a drive it relearns everything. i do this when i update my tune and such.

as for the comment about the sonnax line pressure booster- i plan on grabbing one of these. i dont see it as a mask, i see it as firming up the shift points on a tranny that already has some sloppy shift points from the factory. lets face it, if it didnt have autostick half the time- you would be fed up with it..
__________________

__________________
2007.5 WK Laredo 4.7
- OEM+ -

Future Mods: N/A
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tranny wkjeepgirl86 Grand Cherokee - WK 5 11-26-2011 12:37 PM
tranny problem? MattyDipps Grand Cherokee - WK 8 10-12-2011 07:06 PM
'00 42RE Tranny vs. '96 43RE Tranny freemyer Troubleshooting/Problems 6 07-07-2011 11:03 PM
Tranny Djsal5 Grand Cherokee - WK 8 05-18-2011 04:01 PM
wk tranny help Publio Salazar Grand Cherokee - WK 1 02-28-2010 10:07 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:21 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community