Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-28-2012, 07:48 PM
05WK's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Apr 2011
Location: North Texas
Posts: 1,304
Thanks: 23
Thanked 14 Times in 14 Posts
Rep Power: 14775
05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute
Threw a code....... P0700

Yesterday my ol' check engine light came on. I didnt have time to check, but later that night it was off.

Today, it comes back. I check it with my SCT tunner ( ) and it says P0700 but no additional info. I use the all mighty search tool on the site and find out it has to do with the TCM. im a little scared now. I tuned my jeep back to stock and in doing so it clears the codes. I'l wait a couple of days to see what happens.

Anyone else had this code come and go?

The jeep shifts fine, runs smooth, just like normal. I read that it is caused from the shifter bezel thing and needs to be replaced, $600-700, or taken apart and cleaned. Have any other solutions been found for this code??
__________________

__________________
05 Jeep GC WK, 3.7L, SCT programmer, K&N CAI, FASTMAN ported TB, Flowmaster Super 44 cat-back exhaust (Dumped), HD Bilstien's, 6000K HIDs, 5% Tint ALL the way around, Full Infiniti speaker system with an Alpine HU, TOBY Subwoofer(THE GREATEST), Plasti-diped Rims
Reply With Quote
  #2  
Old 10-28-2012, 08:47 PM
Madanio24's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2012
Location: Eastern Shore MD/NJ/NY
Posts: 1,806
Thanks: 0
Thanked 20 Times in 20 Posts
Rep Power: 11023
Madanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond reputeMadanio24 has a reputation beyond repute
Garage
Send a message via Skype™ to Madanio24
Re: Threw a code....... P0700

Have u done any recent mods to your jeep?
__________________

__________________
Matt
-05 WK Black
Too many mods to list...
-90 Integra GS
Reply With Quote
  #3  
Old 10-28-2012, 10:39 PM
New Member
 
Join Date: Apr 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
firebirdsix7 is on a distinguished road
Re: Threw a code....... P0700

The other day mine threw a P0700, a P0158, and another one that I can't recall, but they were all related to the system voltage more or less. Weird I know, but my transmission guy plugged his tool in, and for unknown reasons the P0700 was stored on the engine side as a pending, not an active code... I hadn't driven it in a week or so, and without really thinking about it cranked my stereo up shortly after taking off. But, i have a 545RFE, so it may be something else.
__________________
Reply With Quote
  #4  
Old 10-28-2012, 10:47 PM
05WK's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Apr 2011
Location: North Texas
Posts: 1,304
Thanks: 23
Thanked 14 Times in 14 Posts
Rep Power: 14775
05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute
Re: Threw a code....... P0700

No recent mods, and by voltage do you mean lack there of?

Yeah, i have the NAG1.

I havent done anything extra ordinary recently that i think could cause that. The only thing is that we had a complete sudden temperature drop. From averages of 80+ to freezing temps the past two days. Which is actually when it started......
__________________
05 Jeep GC WK, 3.7L, SCT programmer, K&N CAI, FASTMAN ported TB, Flowmaster Super 44 cat-back exhaust (Dumped), HD Bilstien's, 6000K HIDs, 5% Tint ALL the way around, Full Infiniti speaker system with an Alpine HU, TOBY Subwoofer(THE GREATEST), Plasti-diped Rims
Reply With Quote
  #5  
Old 10-29-2012, 08:45 AM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2010
Location: Kingston, Ontario
Posts: 765
Thanks: 0
Thanked 12 Times in 11 Posts
Rep Power: 276714
dr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond repute
Re: Threw a code....... P0700

The P0700 is simply the generic trouble code indicating the TCM has stored a fault.

It could be the shifter bezel, line pressures, slow engagement, incorrect ratios, etc., etc., etc. Anything wrong with the transmission will throw a P0700, and you'll need to take it to a place with a much better scan tool to pull it.

I would start by checking to make sure the transmission fluid is at the correct level - with such a swing in temperatures, it could be the fluid has contracted enough when starting cold to cause some issues.

If the trans level is fine, just wait and see if it comes back. If it does reappear, take it to a trans shop or the dealer to have them pull the code - you'll be swinging in the dark otherwise.
__________________
Reply With Quote
  #6  
Old 10-29-2012, 03:15 PM
New Member
 
Join Date: Apr 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
firebirdsix7 is on a distinguished road
Re: Threw a code....... P0700

Yeah, the voltage was a bit low, so it apparently spurred a code. I had the starter, alternator and the battery voltage checked, and all passed. Haven't had any problems with it since then.
__________________
Reply With Quote
  #7  
Old 10-29-2012, 08:24 PM
05WK's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Apr 2011
Location: North Texas
Posts: 1,304
Thanks: 23
Thanked 14 Times in 14 Posts
Rep Power: 14775
05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute
Re: Threw a code....... P0700

Yeah, de-tuned the vehicle to be safe, and the code has come back. I work at a NTB so ill have them pull the code if it comes back.
__________________
05 Jeep GC WK, 3.7L, SCT programmer, K&N CAI, FASTMAN ported TB, Flowmaster Super 44 cat-back exhaust (Dumped), HD Bilstien's, 6000K HIDs, 5% Tint ALL the way around, Full Infiniti speaker system with an Alpine HU, TOBY Subwoofer(THE GREATEST), Plasti-diped Rims
Reply With Quote
  #8  
Old 10-30-2012, 09:39 AM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,315
Thanks: 43
Thanked 126 Times in 108 Posts
Rep Power: 542377
robpp has disabled reputation
0700 is a generic code from trans module. Auto parts reader won't go that deep. You will need a starscan or witech from a stealer to read those codes.
__________________
Reply With Quote
  #9  
Old 10-30-2012, 06:17 PM
MRLOWOFFSETT's Avatar
Member
My Jeep: 2007 3.7L WK
 
Join Date: Dec 2011
Location: Birmingham,AL
Posts: 36
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 880
MRLOWOFFSETT is on a distinguished road
Send a message via AIM to MRLOWOFFSETT Send a message via Yahoo to MRLOWOFFSETT
Re: Threw a code....... P0700

I threw a P0700 and P2767(turbine speed senser)No light now but I'm taking it to the shop friday..would this cause the truck to downshift when it's not supposed to?
__________________
Reply With Quote
  #10  
Old 11-01-2012, 12:43 AM
05WK's Avatar
Senior Member
My Jeep: 2005 3.7L WK
 
Join Date: Apr 2011
Location: North Texas
Posts: 1,304
Thanks: 23
Thanked 14 Times in 14 Posts
Rep Power: 14775
05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute05WK has a reputation beyond repute
Re: Threw a code....... P0700

Had my mechanic check he trans and the fluid level seemed fine so I'm gonna have him do a flush and maybe that will prevent it from happening again.

Engine light hasn't returned, but better to be proactive.
__________________

__________________
05 Jeep GC WK, 3.7L, SCT programmer, K&N CAI, FASTMAN ported TB, Flowmaster Super 44 cat-back exhaust (Dumped), HD Bilstien's, 6000K HIDs, 5% Tint ALL the way around, Full Infiniti speaker system with an Alpine HU, TOBY Subwoofer(THE GREATEST), Plasti-diped Rims
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tranmission Codes P0700 and P0762 - 06 3.7L GC - Someone care to help ??? DJ BoNiOmArIo Troubleshooting/Problems Discussion 19 09-06-2013 12:21 PM
Check Engine Light And Code P0700 Zetzsche248 Troubleshooting/Problems 3 06-20-2012 10:26 AM
Threw code p0688 - Shutdown @ 70mph blackpepper Troubleshooting/Problems 8 02-15-2012 09:12 PM
P0700 code SLVRLTNG Trouble Shooting/Problems/Service 18 08-31-2011 06:30 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:49 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community