Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-19-2012, 09:32 PM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Aug 2012
Location: Keswick Ontario Canada
Posts: 80
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 800
covet66 is on a distinguished road
TPS fault...

Also on our road tripe today the light and warning came up for tire sensor system fault- but no codes in the EVIC, the schematic showed no readings from both rear tires, just the dashed lines. Cleared itself after a bit, but came on later on. It is off now after I drove to test the skid plate issue and get fuel. Will double check tire pressures and see if the fault reappears. Meanwhile I am reading up on the TPS.....
Really just starting to get comfortable in the Wk- had her going about 170 kms this evening- approx 105 mph south of the border- revs like crazy and pulls hard.
__________________

__________________
Reply With Quote
  #2  
Old 08-20-2012, 02:40 PM
brentwoodkris's Avatar
The Ever-Dissatisfied Tinkerer
My Jeep: 2005 5.7L WK
 
Join Date: Jan 2010
Location: Columbia, MO
Posts: 903
Thanks: 0
Thanked 8 Times in 8 Posts
Rep Power: 3541
brentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond repute
Garage
Re: TPS fault...

I've had this happen a couple of times, usually during longer trips. I'm pretty sure that the problem was solved when I replaced the multifunction switch though, because after the TPMS errors, I had the full dash/power on/off issue, replaced the MF switch, and haven't had either issue since [knock on wood].
__________________
'05 WK GC 5.7L HEMI, Goodyear Wrangler SilentArmors, Monroe Reflex Front Struts/Monroe Load Adjusting Rear Shocks, EBC Drilled/Slotted Sport Rotors, Wagner Ceramic Brake Pads, Taylor Shorties, SRT8 Stock CAI Conversion, K&N Drop-in, Block Heater, 18.5% Tint All Around, Boston SE Speakers, 12" Alpine Type-R Sub w/ sealed box w/ RF PRIME R1000-1D, ScanGauge II w/ windshield mount, BT Catch Can w/custom bracket, Swagman Fork Mount Bicycle Rack, WeatherTech front floor liners, SRT8 Pedal Covers, eBay full LED lighting kit, Custom MDS Indicator LED Light, Mega Raizin Voltage Stabilizer & Grounding Kit, Challenger IAT Sensor, Escort Passport 9500ix, Python 5706P RS/Security/KE w/ extras, SA 5 switch panel, Fumoto Oil Valve, Overland WG Steering wheel.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TPS Sensor/P0121 jdloaner Troubleshooting/Problems 5 07-17-2012 07:50 PM
TPS sensor Frango100 Grand Cherokee - WJ 2 06-11-2012 09:06 PM
Testing TPS? Bleeding Blue Troubleshooting/Problems 4 02-09-2012 05:06 PM
wheels without TPS? pcturbo Grand Cherokee - WK2 - 15 11-16-2011 11:31 AM
TPS - Can it be installed wrong? Martyp Troubleshooting/Problems 9 09-08-2011 12:07 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:52 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community