Trans Over Temp Msg - Car wont start - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-19-2014, 04:32 PM
Member
My Jeep: 2008 4.7L WK
 
Join Date: Oct 2014
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 991
Walter001 is on a distinguished road
Trans Over Temp Msg - Car wont start

Hello, i own a 2008 jeep grand cherokee limited, 4.7L, 50.000 mls. About 3 weeks ago i made a stop at the gas station, turned the engine off and after 5 minutes i tried to restart but nothing happened, only a trans over temp warning on display. 30 minutes later the engine started perfectly. This problem is permanent now, but it got worse, most of the times it wont start even if car is parked overnight. Since last week i have to disconnect the battery for 10 minutes, reconnect it and it starts normally. Once the engine starts i can drive during hours without any error msgs on display, everything works perfect until i turn the engine off. Selenoid Pack and Transmission fluid was changed 3 months ago. I took the car to my local jeep dealer, they said its a failed response from TCM and want me to change the PCM. I did a forum search but i canīt find the exactly same problem i have. Most other trans over temp errors are only flashing for a few seconds when they turn the key off, my msg is not flashing, it stays fixed on the display. Maybe somebody can tellme if i really need to spend over 3000$ for a new PCM, iam afraid this is not the real solution. Here in colombia the oficial jeep service has poorly trained technicians and is a very expensive service.

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 10-22-2014, 07:12 PM
Member
My Jeep: 2008 4.7L WK
 
Join Date: Oct 2014
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 991
Walter001 is on a distinguished road
Re: Trans Over Temp Msg - Car wont start

Problem fixed, it was the battery. I found another post saying that the WK is very sensitive with voltages below 12.5 volts. I checked my 1 year old battery and only got 12.1 volts. 3 days ago i bought a new one and the engine started right away, no more trans over temp msg since. New battery have a output of 12.8 volts. Do it myself and forum search saved me 3000$.
Reply With Quote
  #3  
Old 10-23-2014, 06:58 PM
Member
My Jeep: 2008 4.7L WK
 
Join Date: Oct 2014
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 991
Walter001 is on a distinguished road
Re: Trans Over Temp Msg - Car wont start

Thats weird, today the f..... trans over temp msg is back and car wont start again for more than half an hour. I just cant understand it, after replacing the battery i had not a single problem for 4 days and now it starts all over again. Probably the service is right and i have to change the pcm.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 10-23-2014, 07:23 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,615
Thanks: 23
Thanked 424 Times in 409 Posts
Rep Power: 529937
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Trans Over Temp Msg - Car wont start

Just to rule out any charging problems, did you check the battery voltage again after the problems returned?
A fully charged battery has indeed a voltage of 12.8V, while 12.5V already can be seen as an almost discharged battery. As soon as the engine is started, the voltage should go to 13.5-14.5V, indicating that the battery should be charging.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 10-23-2014, 07:42 PM
Member
My Jeep: 2008 4.7L WK
 
Join Date: Oct 2014
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 991
Walter001 is on a distinguished road
Re: Trans Over Temp Msg - Car wont start

Yes, that was my first thought, so i measured the battery again and still got 12.8 volts. With the engine running the output is constant at 14.5 volts. Now i receive new error codes from scanning: FDCM(C140F) / WCM(U0100) / WCM(U1197) / U140E. Before i changed the battery there was only code U0100, now there are 3 more.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 WK 3.7L Wont drive Service Elec Brake System Msg saffron98 Grand Cherokee - WK 14 09-18-2014 10:47 AM
trans says over temp dippinsoldier92 Troubleshooting/Problems Discussion 0 07-11-2013 06:37 PM
Trans Over Temp Blinking grand07cherokee Troubleshooting/Problems 9 01-27-2013 04:48 PM
Trans Over Temp msg displayed Roach333 Troubleshooting/Problems 3 08-17-2012 05:15 PM
Trans over temp - 2001 grand momof1 Troubleshooting/Problems 6 07-22-2012 08:42 AM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:46 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.