Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-22-2012, 06:59 PM
New Member
 
Join Date: May 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Roach333 is on a distinguished road
Trans Over Temp msg displayed

2006 JGC 4.7l. I recently took the jeep in too have the EVAP system checked/fixed because I needed to get the car smogged. I figured while the car was there I'd get the exhaust leak fixed at the same time.

Initially, I had codes P0455 and P0456 and the check gas cap message displayed. The mechanic ran a smoke test and changed a hose and the purge valve (plus new exhaust bolts and gaskets, but that's unrelated to my current problem).

Now initially the mechanic said he was hesitant to change the EGR valve as he's rarely seen those go but but thought it was leaking.

Here's where it gets weird. Immediately after picking up the jeep and driving it started having idle issues on start up. The idle would fluctuate while sitting in park. I then went and got an oil change because the smog station was in another state. Immediately after the oil change I'm driving at low speeds and the message trans over temp comes on!

I pulled over, turned off the car, and restarted it. I figured I was going to jump on the freeway and see if the message came back on; it didn't and I drove 300 miles round trip. Later that evening I was heading somewhere and the trans over temp message came back. !!!!!!! Yesterday my check gas cap msg comes back on and today the check engine light is back with P0457.

Is there any way these issues are all related or is the jeep possessed? I really dont think I should be having all these issues with only 70,000 miles.

Any help appreciated.
__________________

__________________
Reply With Quote
  #2  
Old 05-22-2012, 10:09 PM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652967
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: Trans Over Temp msg displayed

Typically when I see evap leaks on the WK platform its not actually a leak, its the esim switch on the charcoal canister. It is this switch that tells the pcm if there is a leak or not. Typically its just a false failure by a failing esim switch. I dont think I have EVER replaced an purge solenoid on a WK (not that they dont ever fail). I rarely use smoke when testing newer systems, most I go straight to the pressure test, seems like 9 times out of 10 there is no leak indicating a bad esim switch or something like the cap was loose.

EGR valves on the 4.7 are not as common as the hemi but they do fail.

Also a VERY common cause for idle fluctuation on the 4.7l is the throttle position sensor.

Trans temp, due to your symptoms (when it was coming on) It sounds like an erronious message. likely a circuit failure or sensor failure... the temperature sensor is in the transmission range sensor, the valve body must be removed to replace it.... I have seen this failure before.
__________________

__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #3  
Old 05-23-2012, 11:43 AM
New Member
 
Join Date: May 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Roach333 is on a distinguished road
Re: Trans Over Temp msg displayed

Thanks for the info. I paid $$ to get everything fixed so I'll relay the information to the mechanic when I take it in next week. I'm almost convinced the trans over temp is a faulty message because it's just too coincidental.

It's like the idle. I never had any issues with it, but it could have been due to the EVAP leak or the exhaust leak. One things for sure, it's not actually a loose gas cap.

Thanks again.
__________________
Reply With Quote
  #4  
Old 08-17-2012, 05:15 PM
Member
 
Join Date: Feb 2012
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1028
huskyenergy91 is on a distinguished road
Re: Trans Over Temp msg displayed

Bump...ever figure out what this message was?

Im getting the same message, and I get it almost every day
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trans Over Temp Blinking grand07cherokee Troubleshooting/Problems 9 01-27-2013 05:48 PM
Programming Active message displayed? svt393 Troubleshooting/Problems 1 01-27-2012 10:31 AM
'03 P455 Code - moe details in msg tommc4 Troubleshooting/Problems 2 09-05-2011 09:38 AM
Safe trans temp ekaz Performance Modifications 3 08-05-2011 09:21 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:56 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community