Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-28-2010, 07:52 PM
Member
My Jeep: 2005 4.7L WK
 
Join Date: May 2010
Location: Boston, MA
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1661
bullet700 is on a distinguished road
Transmission Over Temp

Dats the message i get on the dashboard of my '05 WK: TRANSMISSION OVER TEMP, with a check engine light on. it happened this morning. then i turn the car off, and turn it on again the message was gone and the check engine light was gone as well. has anybody experienced this before? wat seems to be the issue here? i noticed that the car has been acting weird too. at red light, when the folks in front of me start moving. i hit the gas, the car starts moving but very slowly, so slow the people in front of me would be far in front and the people behind start honking pro'bly saying "ARE U GONNA START F****** MOVING OR WAT?"
__________________

__________________
Reply With Quote
  #2  
Old 06-28-2010, 08:06 PM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,418
Thanks: 55
Thanked 133 Times in 115 Posts
Rep Power: 542668
robpp has disabled reputation
Re: Transmission Over Temp

it needs trans fluid.

let me guess, you have no dipstick and no one has ever checked it?????
__________________

__________________
Reply With Quote
  #3  
Old 06-28-2010, 10:00 PM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12407
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: Transmission Over Temp

does it shift gears or stuck in one gear?

this thread might help

http://jeepgarage.org/showthread.php...ght=prnd+bezel

or another thing is the starter ... yes sounds weird but the starter does trigger that code
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #4  
Old 06-29-2010, 09:57 AM
Member
My Jeep: 2005 4.7L WK
 
Join Date: May 2010
Location: Boston, MA
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1661
bullet700 is on a distinguished road
Re: Transmission Over Temp

it has a deep stick. and i get the tranny fluid check when they do the engine oil change. but yeah, after some google search i found out this is a pretty common problem with the TRANSMISSION OVER TEMP message. it's a sign that you soon need to change your starter. weird, i know.
well thank you guys!
__________________
Reply With Quote
  #5  
Old 04-11-2012, 01:29 PM
New Member
 
Join Date: Apr 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
wuwersaukas is on a distinguished road
Re: Transmission Over Temp

I am currently getting the Transmission Over Temp message but I just had a trans service done and I replaced the starter last year (for the 3rd time). The trans levels are find. Does anyone have any suggestions on what else to check?
__________________
Reply With Quote
  #6  
Old 04-11-2012, 07:13 PM
Member
My Jeep: 2008 4.7L WK
 
Join Date: Jun 2011
Location: Gunnison , CO
Posts: 250
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 56957
Bikemobile has a reputation beyond reputeBikemobile has a reputation beyond reputeBikemobile has a reputation beyond reputeBikemobile has a reputation beyond reputeBikemobile has a reputation beyond reputeBikemobile has a reputation beyond reputeBikemobile has a reputation beyond reputeBikemobile has a reputation beyond reputeBikemobile has a reputation beyond reputeBikemobile has a reputation beyond reputeBikemobile has a reputation beyond repute
Re: Transmission Over Temp

Quote:
Originally Posted by bullet700 View Post
it has a deep stick. and i get the tranny fluid check when they do the engine oil change. but yeah, after some google search i found out this is a pretty common problem with the TRANSMISSION OVER TEMP message. it's a sign that you soon need to change your starter. weird, i know.
well thank you guys!
Wut
__________________
2008 Laredo X 4.7 with 245/70-17 at2
2013 Hemi Durango Crew
Reply With Quote
  #7  
Old 05-08-2013, 03:37 PM
New Member
 
Join Date: May 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
jtgross30 is on a distinguished road
Re: Transmission Over Temp

Quote:
Originally Posted by wuwersaukas View Post
I am currently getting the Transmission Over Temp message but I just had a trans service done and I replaced the starter last year (for the 3rd time). The trans levels are find. Does anyone have any suggestions on what else to check?
did you ever find a solution to this problem. i have same issue on my 2006 hemi JGC.
__________________
Reply With Quote
  #8  
Old 05-08-2013, 03:39 PM
New Member
 
Join Date: May 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
jtgross30 is on a distinguished road
Re: Transmission Over Temp

had car fluids changes and same thign trans over temp warning and fan turning on. any ideas
__________________
Reply With Quote
  #9  
Old 05-08-2013, 05:34 PM
Combat's Avatar
Member
My Jeep: 2006 5.7L WK
 
Join Date: May 2012
Location: Rancho Cucamonga, CA
Posts: 183
Thanks: 1
Thanked 3 Times in 2 Posts
Rep Power: 1098
Combat has a reputation beyond reputeCombat has a reputation beyond repute
Garage
Re: Transmission Over Temp

I had the same issue with the trans over temp and fan coming on, had a transmission shop check the temperature and it was spiking up and down all over the place; however, when they checked the trans dip stick it was ice cold. They told me it was possibly a faulty sensor within a solenoid pack inside the trans.

Nonetheless, I didn't end up getting it fixed and eventually it ended up evolving into incorrect gear ratio codes and was told I needed a new transmission due to the fact my jeep would push into second gear. But thats just my jeep, who know yours might be a different situation.

Maybe you just have a faulty sensor, or something much worse? I would get it checked out immediately, could save you some money in the end.

Stage 3 trans on the way!!!! Ill keep you guys updated, this new trans should fix the issue. If not, then theres a bigger problem.
__________________
(06' Black JGC Limited with FULL SRT8 Body Kit, SRT8 Roof Rails and Mopar Spoiler, Mopar Front Bumper Grill Badge, Hemi345 BADGE, Diablo Trinity Programmer W/91 Performance Tune from ST Motorsports,SheraDon Stage 3 Performance Transmission + 2800 Stall, Inertia Performance Heads, Inertia Spartan Plus Cam, Srt8 Headers/Exhasut Manifolds, Full SRT8 Corsa Exhaust System W/ Reso Delete, Brian Quick 5" tips, 20% UD Pulley, 85mm Ported TB, K&N 77 Series CAI, Jet Flow 180* T-Stat, Billet Catch Can, 22 Inch Flat Black Factory Reproduction SRT 8 Replicas, Eibach Lowering Springs, Power Stop Rotors, Painted Red Calipers, Bosh Iridium Plugs, Shorty Billet Antennae, Limo Tint All Around with Mopar Matte Black Front Window Decal) and Jeep Black Ops Paramedic Hood
[SIGPIC][/SIGPIC]
Diablo Trinity Tuner(Best 1/4 13.29 @ 103mph,-Best 1/8 8.45 @ 84mph -Best 0-60 4.79sec
Reply With Quote
  #10  
Old 05-15-2013, 01:33 PM
Member
My Jeep: 2006 4.7L WK
 
Join Date: Apr 2010
Posts: 33
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1681
fcdd25 is on a distinguished road
Re: Transmission Over Temp

I've been having the same problem since June 2010 on my '06 GC 4.7L. Trans always shifts fine when TOT is not on. Couldn't find answers by asking dealers or local shops or surfing web.

Bought an infrared thermometer and for awhile when light came on I pulled over and shot the ray at tranny pan. Temp was always at 180 degrees (give or take a few) which is spec. Had fluid/filters replaced at dealer in January and it still comes on at times. It seems to go in streaks: nothing for a few weeks and then on/off for a few weeks. No pattern.

Realized this is probably just another of the many electrical glitches our Jeeps have and decided not to worry about it any more. Have driven about 45-50000 miles since first incident and tranny seems fine so far. If I ever find an answer I will post it. In the meantime make sure your fluid is always full and only use ATF+4 and don't lose sleep over it.
__________________
Reply With Quote
The Following User Says Thank You to fcdd25 For This Useful Post:
  #11  
Old 05-28-2013, 09:15 AM
Member
 
Join Date: Feb 2012
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1067
huskyenergy91 is on a distinguished road
Re: Transmission Over Temp

Bump....any new info on this?
__________________
Reply With Quote
  #12  
Old 06-19-2014, 10:12 PM
Laredo2006's Avatar
Member
My Jeep: 2006 4.7L WK
 
Join Date: Aug 2012
Posts: 292
Thanks: 8
Thanked 1 Time in 1 Post
Rep Power: 1486
Laredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond repute
Garage
Re: Transmission Over Temp

anything new ?

getting the same message, started getting it a day after I gave a long boost to a friend's car, had negative side wire connected to his battery instead of metal surface, not sure if any of this played a role....

I also had a water pump installed 1 month prior, bought a Cardone water pump fro rockauto and brought it to some bozo mechanic shop, I wonder if things went wrong there.

I'm going to the dealer tomorrow morning, if anyone has any more clues as to what it could be...I got the 2nd message today, got the first 2-3 days ago. Transmission Over Temp. Jeep is running ok, but I may be noticing a slight louder than usual fan noise...I could be wrong there though, it could be me wanting to hear the problem... I hope it's electrical.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
coolant leak - rad cap - temp gauge rvtifer Troubleshooting/Problems Discussion 9 12-22-2010 03:23 PM
Transmission clunk Phatcharger Troubleshooting/Problems 12 06-27-2010 07:44 AM
Transmission cooler? sanitarium16 Grand Cherokee - WK 12 06-21-2010 05:59 PM
Which transmission do I have? magradze Troubleshooting/Problems 5 04-07-2010 01:54 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:51 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.