Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-04-2013, 10:04 PM
Member
 
Join Date: Dec 2012
Posts: 63
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 687
Triplecrown is on a distinguished road
Trouble code P0700 and U0404

Today my CEL came on. I decided to stop at AutoZone to see what was going on and had them scan it. The scan tool pulled codes P0700 and U0404.

As I leave and start heading down the road, the CEL goes away!!

I drove around town to see if it would come back on, but it did not. Everything seems to be fine such as RPM, shifting is smooth, not stuck in any particular gear, shifts through all gears. Overall, nothing seems out of the ordinary. So, I stopped at another auto store and borrowed their scan tool. Even though the CEL was off, the codes from earlier were 'stored'. I went ahead and cleared the codes and am going to monitor this. I do not know if this played a role in anything, but it has been really cold and snowy in Michigan so I stopped to wash the salt off of my WK and this included and undercarriage wash. So my questions are:

1) Do I have anything to worry about since the CEL went off on its own?

2) Do you think any water or moisture from the car wash could have gotten something wet or froze a component that would trigger a 'false' code considering the extreme weather here?

3) Have you heard of these codes popping up but in all actuality, nothing is wrong?

4) Can you tell me a little about the codes I had?

5) Any explanation as to why the CEL went off on it's own?

Anything information you can provide me regarding these codes and my situation, is APPRECIATED!!!

I'm a little nervous since I recently bought my WK and plopped down $12 grand in $100 bills for it.

Thanks folks for taking the time to read and/or reply!!!!!
__________________

__________________
2006 Jeep Grand Cherokee (WK)
3.7 L V6, 4x4 Quadra I, Stone White
Reply With Quote
  #2  
Old 02-05-2013, 08:47 PM
Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2010
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1534
michael 1970 is on a distinguished road
Re: Trouble code P0700 and U0404

That are the codes that come up when there is a problem with the transmission control module

Code P0700 = Trans control malfunction.
Code Uo404 = Invalid data received from control module gear shift. This means Trans Control Sys malfunctioned.
I have a '06 G/C w/ 124K miles on it and get the code occasionally, and it always resets itself. There are a number of posts here that deal with this problem- from cleaning the gearshift module contacts to replacing the gear shift module.
Look them up and they will explain the problem.
__________________

__________________
Reply With Quote
  #3  
Old 02-05-2013, 10:59 PM
Blakese3p's Avatar
Member
My Jeep: 2006 3.6L WK
 
Join Date: Feb 2013
Location: Bryan tx
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 581
Blakese3p is on a distinguished road
Re: Trouble code P0700 and U0404

Yep just had this problem got it fixed. Started to go into limp mode felt like it would start in 3rd gear from a stop. Had output 2 sensor replaced and the shift control module replace. It's located in the shifter.also had symptoms of the gear indicator would say that I was in all gears at once.was not cheap hope this helps.i had the same codes pulled will look at the receipt tomorrow.
__________________
Reply With Quote
  #4  
Old 02-06-2013, 10:57 PM
Member
 
Join Date: Dec 2012
Posts: 63
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 687
Triplecrown is on a distinguished road
Re: Trouble code P0700 and U0404

UPDATE - PROBLEM SOLVED!

I had 149 miles left before my limited warranty expires, luckily I combed through the paperwork and realized that, or I would have had to break open the wallet, big time!!

So, I took my WK to the stealership yesterday afternoon, and got a phone call explaining what the problem is - The Electronic shift module (ECM) was going bad. I was really relieved when they told me it was a 'covered' item, under my warranty. This is awesome since some things are covered, and some things are not. But either way, this issue was fixed for no charge.

Also, I usually avoid the service dept at the stealership at all costs, but they are going to change my front/rear diff fluids, transfer case fluid and oil change for $214. I thought that was fair. I will be doing my own spark plug replacement, air filter, coolant flush, pcv valve, serpentine belt, since my 60K mile service is due.

So there ya go guys, a bad ECM caused my code p0700 and u0404.
__________________
2006 Jeep Grand Cherokee (WK)
3.7 L V6, 4x4 Quadra I, Stone White
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
P0700 code spyder873 Troubleshooting/Problems 33 01-15-2013 11:32 AM
Threw a code....... P0700 05WK Troubleshooting/Problems 9 11-01-2012 12:43 AM
Code U0404 Jeep SRT8 2006 PicuSRT8 Engine Performance/Superchargers/Turbos 5 01-13-2012 11:46 AM
P0700 code SLVRLTNG Trouble Shooting/Problems/Service 18 08-31-2011 06:30 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:18 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community