Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-08-2012, 07:12 AM
remmy's Avatar
Boopity boop sha boop!
My Jeep: 2005 5.7L WK
 
Join Date: May 2010
Location: Fort Walton Beach, FL
Posts: 455
Thanks: 1
Thanked 3 Times in 3 Posts
Rep Power: 2051
remmy is on a distinguished road
Weird A/C problem?

Is there any particular reason why one side of my WK blows ice cold and the passenger side not so much? The Jeep has 95k on it and probably needs a refill(never done it, don't know how to). Anybody have this problem?
__________________

__________________
'05 HEMI WK
Custom Long Tube Headers
Airaid Shorty Intake
Custom Exhaust
Dyno Tuned on mi-grade pump gas:
Baseline: 241whp
Final: 271whp

My Audio Build
Reply With Quote
  #2  
Old 08-08-2012, 08:21 AM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2010
Location: Kingston, Ontario
Posts: 802
Thanks: 0
Thanked 15 Times in 14 Posts
Rep Power: 276902
dr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond repute
Re: Weird A/C problem?

I doubt it has to do with the charge in the system.

If you have the dual-zone climate, the passenger side blend-door is a likely culprit.
__________________

__________________
Reply With Quote
  #3  
Old 08-08-2012, 06:56 PM
remmy's Avatar
Boopity boop sha boop!
My Jeep: 2005 5.7L WK
 
Join Date: May 2010
Location: Fort Walton Beach, FL
Posts: 455
Thanks: 1
Thanked 3 Times in 3 Posts
Rep Power: 2051
remmy is on a distinguished road
Ok, so it's the blend door actuator has takers a dump I presume? I looked it up in my car manual and looks pretty simple and straight forward to fix.

What are your thoughts?
__________________
'05 HEMI WK
Custom Long Tube Headers
Airaid Shorty Intake
Custom Exhaust
Dyno Tuned on mi-grade pump gas:
Baseline: 241whp
Final: 271whp

My Audio Build
Reply With Quote
  #4  
Old 08-08-2012, 07:30 PM
remmy's Avatar
Boopity boop sha boop!
My Jeep: 2005 5.7L WK
 
Join Date: May 2010
Location: Fort Walton Beach, FL
Posts: 455
Thanks: 1
Thanked 3 Times in 3 Posts
Rep Power: 2051
remmy is on a distinguished road
I researched more to find that these supposedly never break in the WK. only way to find out now without taking it apart is recharge the a/c. I'll pick up a kit in the morning.
__________________
'05 HEMI WK
Custom Long Tube Headers
Airaid Shorty Intake
Custom Exhaust
Dyno Tuned on mi-grade pump gas:
Baseline: 241whp
Final: 271whp

My Audio Build
Reply With Quote
  #5  
Old 08-08-2012, 07:49 PM
Galaxie500's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: Jan 2011
Location: SF Bay Area
Posts: 266
Thanks: 60
Thanked 1 Time in 1 Post
Rep Power: 8260
Galaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond repute
Re: Weird A/C problem?

Quote:
Originally Posted by remmy View Post
I researched more to find that these supposedly never break in the WK. only way to find out now without taking it apart is recharge the a/c. I'll pick up a kit in the morning.
Not sure where you got that info but it's a real problem in our Jeeps. I do not have the Auto Climate System, just manual, and I had to have the fix done. Fortunately my Jeep was still under warranty. YouTube shows fixes being done under the dash and some on here have said it can be fixed from the intake; although I don't see how that could be done. Do a search on the forrum and some info should come up. Good luck.
__________________
Stock Baby! Kicker Sub Dual 10's
Reply With Quote
  #6  
Old 08-09-2012, 08:34 AM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2010
Location: Kingston, Ontario
Posts: 802
Thanks: 0
Thanked 15 Times in 14 Posts
Rep Power: 276902
dr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond repute
Re: Weird A/C problem?

Quote:
Originally Posted by remmy View Post
I researched more to find that these supposedly never break in the WK. only way to find out now without taking it apart is recharge the a/c. I'll pick up a kit in the morning.

There have certainly been a few members on here that have experienced this problem.


Honestly, I think you're wasting your money buying a re-charge kit - it shouldn't be low on refrigerant unless there is a leak in the system.

IMO spend the money you're going to pay for the re-charge kit and take it to a shop to get diagnosed properly.
__________________
Reply With Quote
  #7  
Old 08-09-2012, 10:51 PM
remmy's Avatar
Boopity boop sha boop!
My Jeep: 2005 5.7L WK
 
Join Date: May 2010
Location: Fort Walton Beach, FL
Posts: 455
Thanks: 1
Thanked 3 Times in 3 Posts
Rep Power: 2051
remmy is on a distinguished road
I do not want to pay through the nose on this problem. It doesn't look like I need to disassemble the whole dash but I'd like a solid answer before I do exploring.
__________________
'05 HEMI WK
Custom Long Tube Headers
Airaid Shorty Intake
Custom Exhaust
Dyno Tuned on mi-grade pump gas:
Baseline: 241whp
Final: 271whp

My Audio Build
Reply With Quote
  #8  
Old 08-10-2012, 08:48 AM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Jul 2010
Location: Kingston, Ontario
Posts: 802
Thanks: 0
Thanked 15 Times in 14 Posts
Rep Power: 276902
dr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond reputedr.lee.baugh has a reputation beyond repute
Re: Weird A/C problem?

Well, let us know how it goes. We'll certainly help when possible.

Good luck.
__________________
Reply With Quote
  #9  
Old 08-10-2012, 11:28 AM
remmy's Avatar
Boopity boop sha boop!
My Jeep: 2005 5.7L WK
 
Join Date: May 2010
Location: Fort Walton Beach, FL
Posts: 455
Thanks: 1
Thanked 3 Times in 3 Posts
Rep Power: 2051
remmy is on a distinguished road
Prob won't get to it for another week but when I do I'll do a walk through
__________________
'05 HEMI WK
Custom Long Tube Headers
Airaid Shorty Intake
Custom Exhaust
Dyno Tuned on mi-grade pump gas:
Baseline: 241whp
Final: 271whp

My Audio Build
Reply With Quote
  #10  
Old 08-14-2012, 11:24 PM
Galaxie500's Avatar
Member
My Jeep: 2007 4.7L WK
 
Join Date: Jan 2011
Location: SF Bay Area
Posts: 266
Thanks: 60
Thanked 1 Time in 1 Post
Rep Power: 8260
Galaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond reputeGalaxie500 has a reputation beyond repute
Re: Weird A/C problem?

Quote:
Originally Posted by remmy View Post
Is there any particular reason why one side of my WK blows ice cold and the passenger side not so much? The Jeep has 95k on it and probably needs a refill(never done it, don't know how to). Anybody have this problem?
I found this on wkjeeps.com http://wkjeeps.com/tsb/tsb_wk_2400209.pdf
It may help you diagnose further. Look at Page2 under "MTC Repair Procedure" Step2 "Perform a Manual Door Calibration".
I am still trying to get the dealer to fix this problem below:
SYMPTOM/CONDITION:
Customer may complain that panel temperatures increase too rapidly when the temp knob is moved one or two detents from full cold while in manual mode. This service bulletin will provide the customer with smaller, more expected, panel temperature increases per detent move from the full cold temperature knob position.
MTC has been replaced but this problem still exist.
__________________
Stock Baby! Kicker Sub Dual 10's
Reply With Quote
  #11  
Old 08-15-2012, 07:36 AM
New Member
 
Join Date: Jul 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Moakley07 is on a distinguished road
Re: Weird A/C problem?

Would a bad Blend Door Actuator also contribute to my sqeaking/squeeling issue?
__________________
Reply With Quote
  #12  
Old 08-16-2012, 08:53 PM
Laredo2006's Avatar
Member
My Jeep: 2006 4.7L WK
 
Join Date: Aug 2012
Posts: 288
Thanks: 7
Thanked 1 Time in 1 Post
Rep Power: 1447
Laredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond reputeLaredo2006 has a reputation beyond repute
Garage
Re: Weird A/C problem?

I had exactly the same problem on my 2006 wk Laredo 4.7, (no cold air coming from passenger and back) did a diagnosis at the dealer for 90$ and 160$ for a recharge and it works perfectly now. They told me they added some colouring to see if it comes out from somewhere and that I'll have to bring it back to see will go soon...
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
weird trans problem help stephanwj Troubleshooting/Problems 6 02-14-2012 07:18 PM
First Weird Problem computerwiz621 Trouble Shooting/Problems/Service 2 02-07-2012 06:48 PM
weird speaker problem TurboDiesel Audio, Video, Navigation & Electronic Modifications 0 11-17-2011 12:21 AM
Weird Audio Problem... Frankie Audio, Video, Navigation & Electronic Modifications 5 11-11-2010 11:09 PM
Weird Starting Problem silversx05 Grand Cherokee - WK 7 06-06-2010 06:43 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:14 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community