Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-31-2013, 07:33 PM
hummer recovery team's Avatar
Member
My Jeep: 2006 4.7L XK
 
Join Date: Jan 2012
Location: Rochester MN
Posts: 794
Thanks: 4
Thanked 15 Times in 15 Posts
Rep Power: 1153251
hummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond repute
Unhappy Weird issue

Hi guys, I have a 2006 jeep commander and have been having a minor issue, when the jeep sits overnight in our garage and I back it out its fine until I get on an incline than the idles go up and down and the jeep is bucking. If I start it on a flat surface it's fine. I cleaned my throttle body and put on a new map sensor and I a c and tps I reset computer and everything was fine, now the issue is back. 89,000 miles and no codes. I am meticulous with maintenance.

Thanks for any help, guys.
__________________

__________________
06 XK 4.7, Lots of Mods.

"Jeep is Americas only true sports car" -Enzo Ferrari
Reply With Quote
  #2  
Old 02-01-2013, 04:12 PM
brentwoodkris's Avatar
The Ever-Dissatisfied Tinkerer
My Jeep: 2005 5.7L WK
 
Join Date: Jan 2010
Location: Columbia, MO
Posts: 980
Thanks: 4
Thanked 22 Times in 21 Posts
Rep Power: 3772
brentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond reputebrentwoodkris has a reputation beyond repute
Garage
Re: Weird issue

bucking at angles makes me think of fuel pressure regulators and fuel pump. Also in the cold season could be water in the gas lines.
__________________

__________________
'05 WK GC 5.7L HEMI, Goodyear Wrangler SilentArmors, Monroe Reflex Front Struts/Monroe Load Adjusting Rear Shocks, EBC Drilled/Slotted Sport Rotors, Wagner Ceramic Brake Pads, Taylor Shorties, SRT8 Stock CAI Conversion, K&N Drop-in, Block Heater, 18.5% Tint All Around, Boston SE Speakers, 12" Alpine Type-R Sub w/ sealed box w/ RF PRIME R1000-1D, ScanGauge II w/ windshield mount, BT Catch Can w/custom bracket, Swagman Fork Mount Bicycle Rack, WeatherTech front floor liners, SRT8 Pedal Covers, eBay full LED lighting kit, Custom MDS Indicator LED Light, Mega Raizin Voltage Stabilizer & Grounding Kit, Challenger IAT Sensor, Escort Passport 9500ix, Python 5706P RS/Security/KE w/ extras, SA 5 switch panel, Fumoto Oil Valve, Overland WG Steering wheel.
Reply With Quote
  #3  
Old 02-15-2013, 12:22 AM
hummer recovery team's Avatar
Member
My Jeep: 2006 4.7L XK
 
Join Date: Jan 2012
Location: Rochester MN
Posts: 794
Thanks: 4
Thanked 15 Times in 15 Posts
Rep Power: 1153251
hummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond reputehummer recovery team has a reputation beyond repute
Well I had replaced my tps about a year ago with a standard brand one. I recently tried a brand new mopar one and no more issue. Jeeps are picky with anything but mopar I guess. Thanks for the help.
__________________
06 XK 4.7, Lots of Mods.

"Jeep is Americas only true sports car" -Enzo Ferrari
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!! Weird electrical issue jcostri09 Troubleshooting/Problems 7 11-01-2012 09:04 AM
Weird issue with automatic headlights Darth Vapor SRT Trouble Shooting/Problems/Service 2 10-30-2012 09:14 PM
Weird automatic locking issue cherokeesrt10 Trouble Shooting/Problems/Service 3 05-11-2012 08:54 PM
weird issue with my Jeep DGoral31 Grand Cherokee - WK 6 02-21-2011 04:21 PM
Weird 4wd and brake issue baldeagle432 Grand Cherokee - WK 10 11-24-2010 09:27 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:53 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.