Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-24-2013, 06:25 PM
Member
My Jeep: 2005 4.7L WK
 
Join Date: May 2010
Location: Jacksonville, Florida
Posts: 82
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1617
Jon Krol is on a distinguished road
Well, on to the next problem.....

Just barely a week after getting a rear wheel speed sensor replaced and buying two new solid gold ignition keys, now it won't start. Thought it might be the battery as when the new solid gold ignition key is turned there as buzzing from the starter solenoid. Charged the battery up and the buzz is just louder. So am I to assume the starter may have gone bad....or at least the solenoid?

Addendum: Battery, a DieHard at least 2 years old but I suspect it was fairly new when I bought the WK. There's 91k on the clock.
__________________

__________________
Reply With Quote
  #2  
Old 08-24-2013, 06:56 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,706
Thanks: 9
Thanked 57 Times in 55 Posts
Rep Power: 525523
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Well, on to the next problem.....

You could check the thick wire connections on the starter solenoid to see if they are not corroded or not properly fastened, but big change that the starter/solenoid is the problem. Remove the negative battery terminal before attempting to put any tool on the solenoid nuts, otherwise the tool could cause large sparks or even weld itself when touching any grounded metal part.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OBD diag problem or car problem?? jeeper_57 Troubleshooting/Problems 0 06-25-2013 11:24 AM
I have a serious Problem ChrisOC Grand Cherokee - WK2 - 9 09-12-2012 05:58 PM
first problem outback Trouble Shooting/Problems/Service 2 02-24-2012 05:44 AM
Might have a problem here scrivenerc Engine Performance/Intake/Exhaust 19 02-19-2011 06:49 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:00 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community