Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-18-2013, 10:01 AM
Member
My Jeep: 2005 4.7L WK
 
Join Date: Apr 2013
Location: cold north
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 505
sunflower is on a distinguished road
4.7l misses at start up

2005 4.7l with 93000m klms. misses after start up,gets great mileage on highway and idles smooth as silk after warm up,just seems weird,only have it for 3000 klms.so still getting used to the beast.Anything to check or worry about?
__________________

__________________
Reply With Quote
  #2  
Old 05-20-2013, 06:21 PM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652942
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: 4.7l misses at start up

is it actually misfiring, or just idles rough, do you have a check engine lamp on? The 4.7l is known to have a bit of a rough idle at times, mine comes and goes. Never get a check engine lamp, last I checked I was not even getting any misfire counts on any cylinders and I haven't cared enough to recheck since then.
__________________

__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #3  
Old 05-24-2013, 10:47 AM
Member
My Jeep: 2005 4.7L WK
 
Join Date: Apr 2013
Location: cold north
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 505
sunflower is on a distinguished road
Re: 4.7l misses at start up

Thats what mine seems to do,when it is doing it seems to be a regular thump thump thump,then after running awhile become normal sounding.Don't know if it has thrown a code or not,no check engine light either.Didn't know about rough idle reputation.Thanks.
__________________
Reply With Quote
  #4  
Old 10-05-2013, 07:37 PM
Member
 
Join Date: Oct 2009
Posts: 87
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 9345
harricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond reputeharricanfloyd has a reputation beyond repute
Re: 4.7l misses at start up

You've probably got a bad coil. It misfires when cold and when it warms up it's fine. My mustang does the same thing.....especially when it hasn't run for a week or so. I know it's a coil, but since it smooths out, I won't bother with it until it completely fails. When it does, it'll be easy to tell which one it is...
__________________
Reply With Quote
  #5  
Old 10-09-2013, 10:22 AM
korrupt_jeep's Avatar
Member
My Jeep: 2005 4.7L WK
 
Join Date: Oct 2013
Location: fl
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 350
korrupt_jeep is on a distinguished road
Garage
Re: 4.7l misses at start up

Just clean your (IACV) idle air control valve whit carburetor cleaner
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2 tries to start? honda_fox3 Troubleshooting/Problems 8 07-10-2012 07:01 PM
The Start of My WK snow99dohc Members Rides 42 04-22-2012 03:48 AM
Remote Start Disabled - Start Vehicle to Reset?? bmrsooner10 Trouble Shooting/Problems/Service 3 01-02-2012 10:11 AM
07 5.7 Hemi misses under load woodywoo Grand Cherokee - WK 3 05-05-2011 07:12 PM
Where do I start Marbs Grand Cherokee - WK 21 05-10-2010 06:48 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community