Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 01-03-2012, 01:41 PM
Escape's Avatar
Senior Member
 
Join Date: Jul 2009
Location: Michigan
Posts: 1,911
Thanks: 0
Thanked 26 Times in 25 Posts
Rep Power: 113233
Escape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond repute
Re: Just shuts off?

If all else fails you can always bump the RPM's up 50-100 with a predator or trinity.
__________________

__________________
[SIGPIC][/SIGPIC]
Forged, Stroked, Blown, Bottle Fed & More
Reply With Quote
  #14  
Old 01-03-2012, 01:58 PM
JeepCoop's Avatar
Senior Member
My Jeep: 2007 5.7L WK
 
Join Date: Oct 2010
Location: Los Angeles, CA
Posts: 6,749
Thanks: 360
Thanked 75 Times in 72 Posts
Rep Power: 1892590
JeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond repute
Thanks I'll try that when I get home!!
__________________

__________________
[SIGPIC][/SIGPIC]
|Build Thread

Reply With Quote
  #15  
Old 02-07-2012, 12:23 PM
tydallas's Avatar
Member
My Jeep: 2006 6.1L SRT8
 
Join Date: Dec 2010
Location: Utah
Posts: 239
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 2080
tydallas has a reputation beyond reputetydallas has a reputation beyond reputetydallas has a reputation beyond reputetydallas has a reputation beyond reputetydallas has a reputation beyond reputetydallas has a reputation beyond reputetydallas has a reputation beyond reputetydallas has a reputation beyond reputetydallas has a reputation beyond reputetydallas has a reputation beyond reputetydallas has a reputation beyond repute
Re: Just shuts off?

Coop did you ever figure out what the issue was? My Jeep has been doing the same thing and throwing the exact same codes. Very annoying.
__________________
Reply With Quote
  #16  
Old 02-07-2012, 01:13 PM
JeepCoop's Avatar
Senior Member
My Jeep: 2007 5.7L WK
 
Join Date: Oct 2010
Location: Los Angeles, CA
Posts: 6,749
Thanks: 360
Thanked 75 Times in 72 Posts
Rep Power: 1892590
JeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond repute
Quote:
Originally Posted by tydallas View Post
Coop did you ever figure out what the issue was? My Jeep has been doing the same thing and throwing the exact same codes. Very annoying.
No and it's done it another couple times. I need to tune it back to stock and then let it throw the codes. When I then back to stock it wipes the codes clean and Jeep doesn't think there's a problem. I'll try that soon. Keep me informed too!!
__________________
[SIGPIC][/SIGPIC]
|Build Thread

Reply With Quote
  #17  
Old 02-07-2012, 02:03 PM
Member
 
Join Date: Jan 2010
Posts: 31
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1733
DirtyFrank is on a distinguished road
Re: Just shuts off?

repairs completed:

EGR replaced
new MAP sensor
new IAT sensor
new PCV valve
new Crank position sensor
re-routed passenger side wiring harnes along fire wall (away and off of coils)
re-routed driver side wiring harnes away from coils

560 miles since repairs and last stall.

I'm tempted to think in my case the issue was the egr, before the repairs I unplugged the egr harness and went 700+ miles before a stall. I could have just replaced it but basically took a shotgun approach to try anything to stop the stalling. If I can get to 1000 miles and no stall, I'll route the wiring harnesses back to the original location to see if the stall comes back......or maybe not

In my opinion the two codes we are getting are because of:

P0884 - Power up at speed, I believe this code is thrown, at least for me, when the car stalls in drive and speed is above a certain threshold, the engine will not allow itself to start. We have to put it in neutral while at speed.

P0688 - ASD circuit low, I believe the pcm shuts down everything (fuel pumps, etc) when it senses the engine has stalled, this is what I've ready anyway is the purpose of the ASD, be nice to have th e fuel pump stop if you're in a wreck...right. For me, this code only occurs when I try to simply bump the key to start. The engine turns over and starts but dies immediatly, I'm assuming because the pcm has shut down fuel to the engine, it then returns this code as the cause for the engine not starting. After stalling, if I cycle key all the way to off, then to start, this code does not appear.

Here are the scenarios I've observed:
Stall at speed:
- keep in drive, bump key to on, P0884 and P0688, will not start
- Keep in drive, key to off then start, P0884, will not start
- Shift to N, bump key to start, P0688, engine turns over, does not stay running
- Shift to N, key to off then start, no codes at all, engine restarts and stays running

Stall at stop:
- If in D, bump key to on, P0688, engine turns over, does not stay running
- If in D, key to off then on, engine starts and stays running

Hope this helps someone. Be nice if I have this licked now and can avoid buying another vehicle for a couple years.

Have you all seen the NHTSB page of complaints for the 2007 Cherokee Hemi? I'm guessing 50 different complaints about stalling.
__________________
Reply With Quote
The Following User Says Thank You to DirtyFrank For This Useful Post:
  #18  
Old 03-28-2012, 03:20 PM
JeepCoop's Avatar
Senior Member
My Jeep: 2007 5.7L WK
 
Join Date: Oct 2010
Location: Los Angeles, CA
Posts: 6,749
Thanks: 360
Thanked 75 Times in 72 Posts
Rep Power: 1892590
JeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond repute
I'm still having this issue. Brought it in Monday. Flashed PCM. Picked it up Tuesday after work. Stalled today on the freeway on my way to work. Going back to dealer tonight. Wtf?!?!
__________________
[SIGPIC][/SIGPIC]
|Build Thread

Reply With Quote
  #19  
Old 04-18-2012, 09:29 PM
Member
My Jeep: 2007 5.7L
 
Join Date: Dec 2011
Location: So. Florida
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1027
Filly1sock is on a distinguished road
Re: Just shuts off?

Much thanks to everyone,
I thank you all sincerely for the huge reply to my initial post. I have, unfortunately, stalled at least a coule more times since my initial post. Since reading all your replies & seeing the various parts some of you have replaced only to stall again, I'm plain stumped & share a common angst!
I actually thought I was gonna fix it myself by cleaning the TB blades as some suggested but...nope. Many folks have full on replaced so many parts & many of you are very wise & versed in the ways of the HEMI way beyond me & we're still all in the same quandry???

I'm taking the beast to CarMax this Friday where I bought it to not only have this stalling issue looked at but more importantly, to have the serious binding noise thatI hear& "feel" fixed. It started a few days ago & just gets more pronounced each day.

I now hear an extremely uneasy sound & feel it too every morning when I leave my driveway especially while I make a soft left to enter the thourofare out of my developement. It continues even while I'm going completely straight for a couple hundred feet. I can tell there's a lag, as if I'm not "free" to go like there's a bungi cord attached to my rear bumper tied to a stump, slowing me down.

I'm no stranger to grease, oil, cuts & burns so I have put off for a while, taking the beast back to the stealer, maybe over pride but more likely because I figured I'd fix it myself & save $$$ etc. but, the wife reminds me of the money we spent on the warranty at CarMax & the fact that the neighbors will sheet the bed if I tear down the transaxle & both difs in the driveway of my condo in "hopes" of curing the binding issue & honestly...I'm just plain tired of chasing deamons this powerful when I've only owned this beast for 5 months...so it goes.

Thanks again to all!!!
__________________
Filly1sock is hoping for the best all the time, expecting the worst most of the time & trying to stay prepared for this time & next! :thumbsup:
Reply With Quote
  #20  
Old 04-19-2012, 09:38 AM
JeepCoop's Avatar
Senior Member
My Jeep: 2007 5.7L WK
 
Join Date: Oct 2010
Location: Los Angeles, CA
Posts: 6,749
Thanks: 360
Thanked 75 Times in 72 Posts
Rep Power: 1892590
JeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond repute
Re: Just shuts off?

I finally had my issue fixed!!! (still keeping my fingers crossed haha)

I got a new PCM, coils, plugs and a sweet foil wrap around my PCM harness. Supposedly our coils are emitting an EMP which is causing our Jeep to activate the ASD and shut off. Jeep had my WK for a week and did a ton of testing and calling to Chrysler engineers and more and that's what they came up with. It has been about 2 weeks and she hasn't stalled....yet! Hopefully she never does either! Hopefully this is the solution to the stalling Hemi issue!

Alien proof foil haha (Jeep put this on the harness!!)


__________________
[SIGPIC][/SIGPIC]
|Build Thread

Reply With Quote
  #21  
Old 05-08-2012, 11:36 AM
Hemi24's Avatar
Member
My Jeep: 2005 5.7L WK
 
Join Date: Aug 2011
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1160
Hemi24 is on a distinguished road
Re: Just shuts off?

I had similar issues several months ago, my Jeep would shut off randomly especially when it was raining/wet out. After having it checked out, I found it was a cracked crank case sensor that was shorting out. I dont know if its a common problem with WK's or not but it might be worth a look.
__________________
2005 WK 5.7L Limited, K&N CAI, custom Magnaflow exhaust, Painted headlight assembly with 6000k AAC Halo's, Morimoto 5000k lows with relay, LED tinted tails, EBC Drilled and slotted rotors w/EBC Green Stuff pads, Jet 180 tstat, Jet Performance TBS, 15% tint, Blacked out emblems
Reply With Quote
  #22  
Old 08-02-2012, 02:38 PM
New Member
 
Join Date: Aug 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
juicem2 is on a distinguished road
Re: Just shuts off?

I have a 2008 Grand Cherokee limited with a 5.7 hemi experiencing the same problem of stalling and occasional rpm rev at idle.There were no codes or check engine light. I replaced the crank shaft position sensor about 1,000 miles ago and so far so good. I am keeping my fingers crossed that this was the problem.
__________________
Reply With Quote
  #23  
Old 09-25-2012, 08:22 AM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Aug 2012
Location: Keswick Ontario Canada
Posts: 80
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 851
covet66 is on a distinguished road
Re: Just shuts off?

My 07 GC Hemi has stalled twice while stopped at a light. Found code P 0688 this time. Searching posts now. I see it is fairly comman and a pain to diagnose. Will likely start with crank sensor and work from there. Damn I love this vehicle so much, hope the grmlins will be easy to solve as they arise.
__________________
Reply With Quote
  #24  
Old 09-25-2012, 11:11 AM
JeepCoop's Avatar
Senior Member
My Jeep: 2007 5.7L WK
 
Join Date: Oct 2010
Location: Los Angeles, CA
Posts: 6,749
Thanks: 360
Thanked 75 Times in 72 Posts
Rep Power: 1892590
JeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond reputeJeepCoop has a reputation beyond repute
You guys need to cover your PCM harness is aluminum foil. Had the same issue and after it being at Jeep for a month and having engineers come out, it was basically some kind of emp causing the engine to shut off. Sounds funny but it's been 5000+ miles since I've had a stall!!

Good luck!
__________________

__________________
[SIGPIC][/SIGPIC]
|Build Thread

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cell phone shuts on and off 2011Laredo Trouble Shooting/Problems/Service 2 03-11-2011 10:57 AM
HID sometimes shuts off tman4024 Visual Modifications 154 02-20-2010 10:25 PM
2000 4.7 shuts off tj389 Engine Performance/Intake/Exhaust 1 11-29-2009 02:20 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:22 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community