Several dash lights after doing brake and hub job (myself) - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK > Suspension/Brakes/Wheels/Tires

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-04-2014, 08:56 PM
Member
My Jeep: 2005 4.7L WK
 
Join Date: Aug 2012
Location: Massachusetts
Posts: 29
Thanks: 2
Thanked 1 Time in 1 Post
Rep Power: 1695
kujata has a reputation beyond reputekujata has a reputation beyond repute
Garage
Several dash lights after doing brake and hub job (myself)

What's up guys and gals,

'05 grand 4.7L Rocky Mountain edition. 110k miles. Right about that time where all the little stuff needs to get replaced...

Today I changed out all 4 rotors, parking brake shoes, 1 front caliper and 1 front hub wheel bearing.

I've never done it before but it all surprisingly went pretty smoothly other than the busted rear caliper that i replaced and the opposite front wheel bearing hub which was seized to the axle. I'll have to get that done professionally when I get the money.

After I tightened everything up and put her back on the road the dash displayed the following:

- service electrical brake system

- service 4wd system

- the icon that looks like a car with skid marks like its on a wet and windy road (that's what it looks like to me anyways lol) is on and won't disappear when I press the button. But it was raining when I got it back on the road so maybe something's wet?

- the big red "ABS" in the center is on

Everything went together fine. The new hub speed sensor cable clicked fine into the connector that goes to the computer. The hub that was seized was unplugged at hub, but after I found out it was seized I had to plug it back in and Allen wrenched it back down right.

The rear caliper that was replaced was pumped and bled to the best of my ability.

It's driving fine and the brakes are fine. Should I be worried or is this one of those things I can just wait it out and hope it disappears? I've read that some of those lights just pop up when you hit a big pot hole.

Thanks


Sent from my iPhone using JeepGarage

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 10-14-2014, 07:44 AM
Member
My Jeep: 2005 4.7L WK
 
Join Date: Aug 2012
Location: Massachusetts
Posts: 29
Thanks: 2
Thanked 1 Time in 1 Post
Rep Power: 1695
kujata has a reputation beyond reputekujata has a reputation beyond repute
Garage
Re: Several dash lights after doing brake and hub job (myself)

Update:

So the dashlight that's a car with squiggly lines under it is the Traction Control light.

The front wheel bearing hub assemblies have an ABS/Speed Sensor cable harness that connects near the engine bay. When i replaced the wheel hub the problem went away. If you mess with those things you'll get an array of dashboard lights because it's not getting a signal.

Be careful when hooking up those new harnesses, I had a local shop install mine and they mounted the first tab incorrectly so the harness cable rubbed on the inside of the tire and severed itself. A quick splice with electrical tape fixed that issue.
Reply With Quote
  #3  
Old 12-22-2014, 08:57 AM
Member
 
Join Date: Dec 2014
Posts: 45
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 819
jdmm08 is on a distinguished road
Re: Several dash lights after doing brake and hub job (myself)

Let me know what you find. I have the same light after similar work and everything went together fine.


Sent from my iPhone using JeepGarage
Reply With Quote
  #4  
Old 03-24-2015, 07:16 AM
New Member
 
Join Date: Mar 2015
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Newfie_Rider is on a distinguished road
Re: Several dash lights after doing brake and hub job (myself)

Bump the thread...

I have an '05 and replace right fron and rear calipers, pressure bled them, now I have the same lights as kujata stated above.

The lights were not there before the brake service...am I missing something? Does the system need to be reset?

Seems like the three amigos on my old Disco II
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
clunk from tranny when i go into drive or reverse i have several codes pop up P1732, jewell55 Troubleshooting/Problems 5 10-25-2012 06:12 PM
Clock display on radio stops working after driving for several hours jamisonville Grand Cherokee - WK2 - 1 10-11-2011 01:56 PM
Brake Job and Plugs Crestwood1001 Grand Cherokee - WK 19 05-26-2011 06:02 PM
Thinking of doing a Flat White Paint Job.... 402 Motoring Grand Cherokee - WK 20 04-10-2011 06:25 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:18 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.