Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Liberty-KJ and KK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-11-2011, 10:47 AM
New Member
My Jeep: 2003 3.7L KJ
 
Join Date: Jul 2011
Location: Berkeley, Wv
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Sweetz77 is on a distinguished road
03 liberty running rough need help!

I have an 03 Jeep liberty automatic 3.7 great vehicle with no issues as soon as we paid it off a matter a weeks its been breaking down isnt that how it works..

Its running rough, idling rough the other day we went to town and barely pushed 45... shut it off started it back up .. hit the gas alittle then it ran ok coming home.. wierd.. i dunno much about jeeps this is my first one..

check engine light comes on . the other day it stayed flashing. right now its just solid..

we had codes p0300 p0301 p0306 .. general misfire then the 301 cylinder 1 . cylinder 6 so forth changed spark plugs checked individual coils swapped em around to see if we got different codes.checked for wear etc.. reset it the hub drove to work this morn check engine light came on bfore he left the end of the street.. got to work now its just code p0300.. now but ran semi ok there..

i hear this model doesnt doesnt have an EGR valve would explain why i couldnot find it.. but . that would b my first guess. to check it , . im hopin nothing is wrong with the valves themself.. So what does it have that could cause this problem.. anyway to narrow it down without nickel and diming us to death with a process of eliination.


any help or guesses would be Greatly appreciated. im at a standstill..
__________________

__________________
Reply With Quote
  #2  
Old 07-11-2011, 10:51 AM
*BabyGirlJJ*'s Avatar
Love me or Hate me! Either or your thinking of me!

My Jeep: 2010 3.7L WK
 
Join Date: Jan 2011
Location: St. Charles, MO
Posts: 1,506
Thanks: 49
Thanked 25 Times in 25 Posts
Rep Power: 2713443
*BabyGirlJJ* has a reputation beyond repute*BabyGirlJJ* has a reputation beyond repute*BabyGirlJJ* has a reputation beyond repute*BabyGirlJJ* has a reputation beyond repute*BabyGirlJJ* has a reputation beyond repute*BabyGirlJJ* has a reputation beyond repute*BabyGirlJJ* has a reputation beyond repute*BabyGirlJJ* has a reputation beyond repute*BabyGirlJJ* has a reputation beyond repute*BabyGirlJJ* has a reputation beyond repute*BabyGirlJJ* has a reputation beyond repute
Re: 03 liberty running rough need help!

I had some issues with mine that may have been a bit similar. I had the throttle position sensor fail (TPS) on me twice within a couple months. I replaced it in March then my BF changed out the spark plugs and it failed immediately... stalling out and hesitant while driving. It does throw the check engine light too! Might be worth looking into, even if its just to rule that out.

__________________

__________________

2010 3.7 WK |
Reply With Quote
  #3  
Old 07-11-2011, 11:09 AM
jlewissystem's Avatar
Fo sheezy my neezy
My Jeep: 2006 5.7L WK
 
Join Date: Oct 2010
Location: STL, MO
Posts: 1,465
Thanks: 37
Thanked 67 Times in 61 Posts
Rep Power: 1278238
jlewissystem has a reputation beyond reputejlewissystem has a reputation beyond reputejlewissystem has a reputation beyond reputejlewissystem has a reputation beyond reputejlewissystem has a reputation beyond reputejlewissystem has a reputation beyond reputejlewissystem has a reputation beyond reputejlewissystem has a reputation beyond reputejlewissystem has a reputation beyond reputejlewissystem has a reputation beyond reputejlewissystem has a reputation beyond repute
Re: 03 liberty running rough need help!

P0300 - Multiple Cylinder Misfire

What types of plugs did you use? Was the gap correct - .042? Maybe some fuel injector cleaner?
__________________

2006 5.7 WK ORT | DiabloSport Predator | FlyinRyan Custom TCM Tune & Ported Throttle Body | (Painted Red) OME HD | Moto Metal 951's | 265/70/17 Duratrac's | Custom SEGUARO Front Bumper | Magnaflow Cat Back 16631 | Airaid Intake | Jet 180 T-Stat | BTT Catch Can | XenonDepot 5000 HID Lows | LED Fogs | JR's Custom Shorty Antenna | De-badged | Rola Roof Rack | MOAR LYTES: Eagle Eye HID Spots | Rigid D2's (Rear) | 7" LED SYDE Lights | 4xGuard Front Skid | Aries Rear Tail Light Guards | FULL Interior LED's | Interior VINYL Wrap | (Painted Red) Strut Bar | Pioneer AVH-4200 | Custom Rear Camera | (Painted Red) Calipers | Gorilla Black Locking "System" | SRT8 Shift Knob | (BUILD THREAD)
Reply With Quote
  #4  
Old 07-21-2011, 07:18 AM
soontobesrt's Avatar
I drive a modern day Woody
My Jeep: 2005 3.7L WK
 
Join Date: Jan 2010
Location: Philadelphia,PA ----> Trenton, NJ
Posts: 1,602
Thanks: 31
Thanked 14 Times in 14 Posts
Rep Power: 3323
soontobesrt has a reputation beyond reputesoontobesrt has a reputation beyond reputesoontobesrt has a reputation beyond reputesoontobesrt has a reputation beyond repute
Re: 03 liberty running rough need help!

could even be an O2 sensor but usually not that severe to cause misfire code? Maybe check those out. Sensor usually are causes of rough running on newer cars but as mentioned plug gap as well as clogged injectors could do it too. Spark/fuel tend to be what Id lean towards but the 02s could be going and in turn giving the pcm incorrect readings which will make it deliver incorrect fuel trims when in closed loop which can cause the symptoms you are describing. Hopefully its not worst case which would probably be a shot exhaust valve of sorts or even head gasket beginning to go It doubt its those though, plug/injector is where id put my $ - G/L with the fix.
__________________

Mods: A Bunch



Reply With Quote
  #5  
Old 05-23-2013, 06:39 PM
Member
My Jeep: 2002 3.7L KJ
 
Join Date: May 2013
Location: Manchester, NH
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 422
Silly02Jeep is on a distinguished road
Re: 03 liberty running rough need help!

The Liberty does have an evap/purge solenoid, it is next to the battery and has hard vacum lines going to the intake manifold.
As for the misfires, the coil packs are the first suspect. Next I would look at the camshaft sensor and or the crankshaft sensor. What do you have for mileage?
__________________
Reply With Quote
  #6  
Old 10-26-2013, 02:46 PM
New Member
 
Join Date: Oct 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
nikkinew is on a distinguished road
Re: 03 liberty running rough need help!

A few months ago the inside of my car started shaking when it was in idle. About two weeks ago I started getting smoke from the tail pipe so I put some stuff in my car that's suppose to help stop the smoking. Then about a week later the gas started going down way too fast so I replaced the spark plugs but that didn't seem to help with anything. Any idea on what to do next?
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
3.7 running rough, ideas? Cutthroat Grand Cherokee - WK 9 05-15-2011 09:05 AM
running rough snake678 Trouble Shooting/Problems/Service 1 04-10-2011 07:13 AM
jeep running rough Davie Troubleshooting/Problems 6 04-15-2010 07:39 PM
2 in. Rough Country Lift cort692 Grand Cherokee - WK 6 03-25-2010 06:35 PM
Rough WJ OBA install 206WJ Off Road Modifications 2 02-12-2010 03:33 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:49 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community