2006 Liberty trouble starting - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Liberty-KJ and KK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-02-2016, 12:28 PM
New Member
 
Join Date: Feb 2016
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Capitalamy214 is on a distinguished road
2006 Liberty trouble starting

I have a 2006 Jeep Liberty Sport that has trouble starting when its hot. If I drive for awhile then stop and turn off the jeep, it has to cool down 10-20 minutes before I can restart the Jeep. It turns over but does not fully engage. I have recently had new spark plugs done, new crank shaft sensor, it does not throw any codes, and put a wrap on the gas line in case the fuel was vaporizing before it reaches the engine. Any suggestions as to what could be wrong would be appreciated!

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 02-04-2016, 03:23 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,330
Thanks: 17
Thanked 378 Times in 365 Posts
Rep Power: 529495
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 2006 Liberty trouble starting

Crank sensor would be my first guess, but you changed it already. Also the cam sensor can give same symptoms. Try to put a wet cloth over the sensor when it doesn´t want to start and try again after a few minutes (to cool down the sensor)
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
The Following User Says Thank You to Frango100 For This Useful Post:
Reply

Tags
2006

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble with 08' Liberty Sky Slider pcrawf Liberty-KJ and KK 0 09-26-2013 06:42 PM
I'm a new member hello to all....trouble starting 09jgcretiredcw Troubleshooting/Problems 5 01-31-2013 06:55 PM
Liberty Trouble code issues ozzy36 Liberty-KJ and KK 0 08-11-2012 05:05 PM
05 WK - Trouble Starting W/Warm Engine! WildVisionsWK Troubleshooting/Problems 21 02-17-2012 06:53 PM
Trouble Starting 99 4.7 jimd4x4 Troubleshooting/Problems 4 03-16-2010 03:03 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:29 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.