Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Liberty-KJ and KK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 01-27-2014, 11:58 PM
Wrathwielder's Avatar
Member
My Jeep: 2011 3.7L KK
 
Join Date: Aug 2011
Location: Bloomington, MN
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1144
Wrathwielder is on a distinguished road
Re: Blower vent control question

Hi!

Sorry! I updated my post on several other forums but never updated it here...

Here's the update:

SO sorry everyone for the delay!

After the shop having my Liberty for 3 days (and each day saying they would have it ready for me that night) it's fixed!!

Like I mentioned in my last post, they first replaced a vent motor or something, and that didn't do the trick.
Then the switch panel and that didn't work either...
They FINALLY dove in for the full HVAC BOX replacement. The service manager handling it was GREAT and was totally on my side and stuck with me through this whole thing.
Apparently the 1st repair of the vent motor was never supposed to happen - he wanted the HVAC BOX done RIGHT AWAY, but there was a miscommunication and they wrote up the order for just the small repair.

Anyways, they pulled the dash and then noticed that the NEW HVAC BOX was defective - had a seam that wasn't sealed and would end up leaking air)
He said he would never install something like that cuz it could end up causing me issues later, so they ordered ANOTHER box...end DAY 1.

Now the 2nd day they went to install the SECOND HVAC BOX and noticed that there was a foam gasket of some sort that didn't come with it, so they had to order THAT. They got it the same day, and after installing everything they somehow broke the video feed to my front license plate cam. I was peaved, especially when they said they had snipped off the broken video plug at the LockPick end and put a new connector on and it still didn't work. They claimed to have tried reversing the +/- on the plug like I asked, but it still didn't work.

They wanted to replace the whole cable run to the front. I told then it had taken me 2 hours to get it just the way I wanted it, and he assured me that they had done Lockpicks and cams before (strange that a Jeep dealer would install something that overrides some features of the MyGig, but cool I guess)

So, DAY 3 was spent getting the cam working and detailing my Jeep inside and out (it's like new again! er, well at least on the inside - the outside only lasted 1 Minnesota slush-filled drive)

SO, to sum it up, when he pulled the ORIGINAL HVAC BOX out, he noticed that there was like a 1/4" play in the blend door that fed the defrost. He told me to tell you all that when your dealer checks the blend door function via the computer interface (wow! My iPhone OBD-II app can't do that - had no idea something as simple as that could be "read" through the OBD) they will APPEAR to be functioning 100%, but it doesn't read any play in the doors.
He said the force of the air would push the loose door out of the way and the air would leak out the defrost.

SO - it works WAY better now! There is a small amount of air coming out the defrost when set to 12:00, but there is now a DEFINATE difference between 12:00 and 1:00. The "paper test" doesn't lift the paper now more than 1/2" where before it went right to the windshield.

Don't give up! I personally think the Jeep HVAC boxes have an inherent problem with blend door play, so who knows if there will be a recall someday.

-Greg
__________________

__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #14  
Old 02-04-2014, 08:51 PM
Member
My Jeep: 2011 3.7L KK
 
Join Date: Jan 2014
Location: Long Island, New York
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 242
DarkSport11 is on a distinguished road
Re: Blower vent control question

Checked mine today and it's doing the same thing. Looks like I'll be making an appointment to bring it in.
__________________

__________________
2011 Dark Charcoal Metallic Pearlcoat Liberty Sport
Reply With Quote
  #15  
Old 02-05-2014, 03:32 PM
Marlon_JB2's Avatar
Premium Member

My Jeep: 2010 3.7L KK
 
Join Date: Jun 2009
Location: Jefferson North Assembly Plant
Posts: 2,495
Thanks: 43
Thanked 143 Times in 93 Posts
Rep Power: 86881
Marlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond repute
Send a message via AIM to Marlon_JB2 Send a message via Yahoo to Marlon_JB2 Send a message via Skype™ to Marlon_JB2
Re: Blower vent control question

So is mine. Never noticed it before.

Oh well. It's gonna stay like that because 1. I don't care and 2. I'm not paying for it.
__________________
JEFFERSON NORTH Assembly Plant STATUS:
PILOT/Production Build!!!!!

The Marlon Garage Contains The Following Methods of Engine Powered Transportation:
'10 Jeep Liberty Renegade 4x4 - BACK! With new TIRES and WHEELS!
- My posts are NOT a representation of the official views of Chrysler Group LLC or any of its affiliates -
Reply With Quote
  #16  
Old 02-05-2014, 04:56 PM
Member
My Jeep: 2011 3.7L KK
 
Join Date: Jan 2014
Location: Long Island, New York
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 242
DarkSport11 is on a distinguished road
Re: Blower vent control question

Quote:
Originally Posted by Marlon_JB2 View Post
So is mine. Never noticed it before.

Oh well. It's gonna stay like that because 1. I don't care and 2. I'm not paying for it.
Should be covered under Manufacturers warranty if you not over the mileage limit.
__________________
2011 Dark Charcoal Metallic Pearlcoat Liberty Sport
Reply With Quote
  #17  
Old 02-06-2014, 08:39 AM
Marlon_JB2's Avatar
Premium Member

My Jeep: 2010 3.7L KK
 
Join Date: Jun 2009
Location: Jefferson North Assembly Plant
Posts: 2,495
Thanks: 43
Thanked 143 Times in 93 Posts
Rep Power: 86881
Marlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond reputeMarlon_JB2 has a reputation beyond repute
Send a message via AIM to Marlon_JB2 Send a message via Yahoo to Marlon_JB2 Send a message via Skype™ to Marlon_JB2
Re: Blower vent control question

Quote:
Originally Posted by DarkSport11 View Post
Should be covered under Manufacturers warranty if you not over the mileage limit.
Uh huh.

It's 2014. I have a 2010. So regardless of my 84,300 miles, it still wouldn't be covered.

I never actually use that setting so that might be why I don't care. In my Jeep, it works just fine otherwise.
__________________

__________________
JEFFERSON NORTH Assembly Plant STATUS:
PILOT/Production Build!!!!!

The Marlon Garage Contains The Following Methods of Engine Powered Transportation:
'10 Jeep Liberty Renegade 4x4 - BACK! With new TIRES and WHEELS!
- My posts are NOT a representation of the official views of Chrysler Group LLC or any of its affiliates -
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No Blower Speeds, A/C Light on even when blower is off ALPINEST4RS Troubleshooting/Problems 8 08-01-2012 05:19 PM
upper control arm question stashgto Suspension/Brakes/Wheels/Tires 2 07-12-2012 10:10 PM
Audio control lc6 question Luigi Audio/Visual/Navigation 2 05-10-2012 11:05 AM
climate control swap question Divo Kinevil Troubleshooting/Problems 10 03-09-2011 09:17 PM
Replacing 99 WJ blower motor resistor-have connector question rkolex Troubleshooting/Problems 7 12-06-2010 03:26 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community