Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Liberty-KJ and KK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-18-2012, 02:02 PM
New Member
 
Join Date: Sep 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
ajaiello85 is on a distinguished road
Issues under 15mph

My 03 jeep liberty with 101 kmiles on it, has recently started to produce a clicking or ticking noise coming from the rear passenger side while slowing down or driving at speeds under 10 mph this noise stops when vehicle is over 10 miles an hour. could anyone please offer me some insight as it is starting to drive me crazy lol. Thanks in advance.

On a side note...it didnt happen until after I used my E-brake on the mountain last weekend.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Paint issues and windscreen issues mm1964 Export Grand Cherokee 2011+ 41 03-28-2013 09:26 PM
Sub issues Stickerbombed Audio/Visual/Navigation 6 04-01-2012 03:48 PM
Need help with 2.5l issues Thegtwyo86 Troubleshooting/Problems Discussion 2 03-06-2012 04:12 AM
AC issues OnedoubleL Grand Cherokee - WK 4 05-18-2011 09:04 PM
so many issues spiros Trouble Shooting/Problems/Service 11 03-07-2011 03:31 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:37 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community