Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Liberty-KJ and KK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-05-2014, 06:24 AM
New Member
My Jeep: 2006 3.7L
 
Join Date: Jan 2014
Location: New York
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Wheeler83 is on a distinguished road
Exclamation Major Electrical Problem

Hello,

My wife and I own a 2006 Jeep Liberty Renegade. It currently has 116,000 miles on. About a year ago it started having issues where at start up it would start then stall. Then when driving at first down the road it would begin slugging the throttle would rev up and down, the check engine light came on and it worked itself out. I took it down got the code read it was a bad camshaft/crankshaft sensor. I purchased them from autozone, replaced them and it still continued. It was suggested to go with mopar parts purchased and replaced them. Seemed to work fine for a bit. But like clockwork came back. Within the past year we have replaced the battery and put fuel cleaner in.
The problem has progressed. We have taken it to a garage they had it for 2 days and charged us $300 and found nothing! Every garage I have talked to has no answer unless I leave it. I can't afford to keep taking it to garages.
Now we have the situation that when she try's to start it to warm it up the jeep keeps stalling and takes at least 3 times to start and it spits and sputters when she first drives off. Today she called and told me that while driving down the road all the lights on The dashboard come on and it acts like it wants to stall. When you put in reverse it completely stalls out. I don't know what to think anymore. I have spent hours searching online. The thoughts lead me to a ECM sensor, throttle body assembly , camshaft and crankshaft sensor and wire harness, and now a alternator. So any advice or help would be greatly appreciated! Thank you,

Frustrated in NY
__________________

__________________
Reply With Quote
  #2  
Old 01-05-2014, 10:05 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,050
Thanks: 9
Thanked 102 Times in 95 Posts
Rep Power: 526035
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Major Electrical Problem

Did you recently check for any fault code set? Don't know if the keydance works on the Liberty: ignition switch off/run three times and leave in run at the third time. Odometer will show Done when no faults stored, or a fault code(s).
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 02-09-2014, 03:09 PM
New Member
 
Join Date: Feb 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
LibbyRican is on a distinguished road
Re: Major Electrical Problem

Hi Frustrated! Have you had the PCV valve checked? My wife and I own a 2004 Libby and we recently experienced problems with loss of power and sluggish performance. The code indicated that all ignition coils were failing. Our mechanic went through the paces and checked fuel pressure and PCV valve amongst other things and in the end it turned out to be the crank position sensor and not the coils. As my mechanic puts it, "sometimes the code is wrong".
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Major Electrical Problems Need Advice! Wheeler83 Trouble Shooting/Problems/Service 1 01-05-2014 01:37 AM
2012 JGC 5.7 major electrical issues jswart Trouble Shooting/Problems/Service 5 10-27-2012 12:28 AM
First major electrical failure savvas Export Grand Cherokee 2011+ 9 08-14-2012 05:16 PM
Major Electrical/Computer Problem: All warning lights on markus316 Trouble Shooting/Problems/Service 7 01-09-2012 10:30 PM
=== Electrical problem Hac_PTR Troubleshooting/Problems Discussion 4 10-12-2010 11:26 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:35 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.