U-Connect on it's own tour - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Liberty-KJ and KK

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-29-2014, 06:06 PM
New Member
My Jeep: 2012 3.7L KK
 
Join Date: Dec 2014
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Diva16 is on a distinguished road
U-Connect on it's own tour

Hi all, new to this forum and looking forward to the wisdom and experience of the community!

First a bit of background ... I have a 2012 Liberty KK Ltd although in New Zealand it is badged as a Cherokee. Love the car, the local Chrysler dealership gave one to me as a courtesy car when my 2005 PT Cruiser was in for a regular service and two days later I needed to buy one!

Haven't really had any problems with it, yes it's thirsty but on a par with the Cruiser and my 1973 V8 Rover P6B (!) so no complaints. As I say to anyone who asks, you don't buy a Jeep because fuel economy is important to you!

ANYway ... my U connect has always had a mind of its own. From time to time it asks me if I want to calibrate the reversing camera (I don't have one fitted), it will often switch on and off of it's own accord, occasionally the buttons are unresponsive and in the past several months it randomly loses (and gains) time. None of these things except the clock issue have been able to be replicated when it has gone in for a service (isn't that always the way!) and I work long hours and have been putting up with the clock issue as I did not have the time to take it in to the dealer but am now on summer holidays (yay) and am hoping to get it sorted, vehicle still under warranty.

I wondered whether any of you have had same or similar issues? I do not have the sat nav add-on ( which I have seen mentioned as a possible issue in other forums) and all the DST settings are correct.

Thoughts?

UPDATE: I see from browsing around JG there is a site where one can go to update the software ... does anyone have first hand experience of doing this for the 2012 KK Ltd? I am in NZ and running Safari on a mac. I get an error when I try to go via the site link that I have found in these forums. I have uploaded a shot from System Information. Our local dealer changed last year and no-one is very happy about it ... they are not what you would call helpful!
Attached Images
File Type: jpg IMG_2074.jpg (525.4 KB, 2 views)

Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rocks and Road Tour macpro Grand Cherokee - WK2 - 4 09-26-2010 11:54 PM
Jeep Rocks and Road Tour bluethunderjeep Grand Cherokee - WK2 - 0 07-29-2010 12:35 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:15 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.