Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Cherokee-SJ and XJ

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-20-2014, 11:58 PM
Member
My Jeep: 2001 4.0L XJ
 
Join Date: Jun 2013
Location: NE Missouri
Posts: 6
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 570
mmorris is on a distinguished road
Heater problem resolved!

I finally have enough heat to cook an egg!
I had decided to take the thing to a dealership to get it fixed. After reading through 37 pages of posts last night, today I decided to try ONE LAST TIME to resolve this.
Several months ago I used the Prestone radiator flush and left it in for 3 days while I drove it. I then flushed it completely for almost an hour through the radiator cap using a fitting in a flush kit. No change. After reading extensively last night, I decided it HAD to be a dirty heater core.
So I disconnected both heater hoses at the block and, using the hose, flushed extensively in both directions. I then blew (by mouth) into the inlet hose to clear most of the water from the heater core. It must not hold much since I only poured about half of the bottle of Prestone flush directly into the inlet hose while elevating it. I let it sit for an hour and then flushed it with a hose for about 15 minutes. I then repeated the whole process with the other half of the Prestone bottle and then filled the hose with antifreeze and reconnected them. Burped the system and drove it for 20 minutes. It was warmer, but didn't really kick in until I kicked in the passing gear a couple of times. Then the heat really kicked in and continued even at low speeds. While flushing the heater core, I collected the effluent and there didn't seem to be very much "junk" being flushed. But it worked!!!
I guess it helps to be persistent!
__________________
Reply With Quote
The Following User Says Thank You to mmorris For This Useful Post:
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
heater output problem hamilton5 Troubleshooting/Problems 8 02-25-2014 09:25 AM
Command start - heater problem Kendra-2014jeepSRT8 Troubleshooting/Problems Discussion 0 10-24-2013 02:46 PM
Heater problem!!! (Hello from the Newbie) rensaun Troubleshooting/Problems 8 02-01-2013 08:57 PM
Heater problem luisg47 Troubleshooting/Problems 3 11-12-2012 10:42 PM
2004 Liberty AC/Heater Control Problem banjokramer Liberty-KJ and KK 0 08-14-2012 11:32 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:56 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.