Problem with my 89 XJ need help - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Cherokee-SJ and XJ

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-01-2015, 10:06 PM
Member
 
Join Date: Nov 2014
Posts: 16
Thanks: 6
Thanked 4 Times in 4 Posts
Rep Power: 773
JeepPR1 is on a distinguished road
Problem with my 89 XJ need help

Hi, my jeep cherokee 89 runs fine like 10 sec and then shuts down the engine. The thing is that I disconect the cable ( the one thats connected to the trothle) from the map sensor and the jeep turn on slowly but it atays steady rpms and the engine runs smooth. If I connect the cable on the map sensor the engine turn off imediatly. I turn it on again without the cable and then it rus fine until I press the gas pedal and the car start to fail and shuts off. I think is vaccum problem or poor fuel pressure. The fuel pump sounds good and have signal. I changed the starter, fuel filter, map sensor, new battery, new relays. Same problem. Maybe its the fuel regulator? I cant check the presure right know but I notice when i press the testing in the fuel rail that has air in it. Turn it on the car and it have fuel in it. But then the same problem. Press the gas pedal and the engine dies. If i connect the line to the map sensor it dies too. Any ideas?

Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
light/dimmer switch problem. need help asap! DavidESchiller Grand Cherokee - ZJ 5 03-25-2012 11:53 PM
Transmission Problem (need help!) cyprus Grand Cherokee - WK 9 03-14-2011 04:16 AM
Strange Problem, Need Help ASAP Crestwood1001 Grand Cherokee - WK 6 01-30-2011 03:48 PM
big problem need help cutt288 Troubleshooting/Problems Discussion 7 11-30-2010 09:01 PM
P0443 Problem, need some help akabigo Troubleshooting/Problems Discussion 10 10-20-2010 09:14 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:11 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.