Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Cherokee-SJ and XJ

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-09-2011, 03:08 PM
New Member
 
Join Date: Jul 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
RobM is on a distinguished road
Unhappy Turn Signal Issue

We have a 1996 Cherokee XJ - and the turn signals have stopped working. We've tried replacing the dual relay - that didn't work - and we're beating our heads against the wall trying to figure out why they're not working. There's no fuse even thought there's a spot for one minus part of the terminal, indicating that while a fuse goes there, it can't go there. The 4-way flashers work just fine and, well, this isn't making any sense.

Is there really a fuse somewhere we haven't seen or has the multi-function switch for the turn signals/high beam/wipers failed? Any help with this would be appreciated!
__________________

__________________
Reply With Quote
  #2  
Old 07-15-2011, 01:40 PM
New Member
 
Join Date: Jul 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
RobM is on a distinguished road
Re: Turn Signal Issue

An update: We now know that it's not the dual flasher relay... but that's not telling us what it might be. Does anyone have an idea of what protects the flasher circuit? It still seems to me that there should be a fuse somewhere that guards against overloads in the electrical system - but I have no idea where it is! Still looking for any help you guys can provide with this!
__________________

__________________
Reply With Quote
  #3  
Old 07-15-2011, 03:16 PM
Member
 
Join Date: Mar 2011
Posts: 164
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1430
Sir Sam is on a distinguished road
Re: Turn Signal Issue

Check the grounds on the left front fender support behind the ECU. If these become corroded or broken they can cause all sorts of issues like you sound like you may be having.
__________________
Reply With Quote
  #4  
Old 07-15-2011, 04:12 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,349
Thanks: 487
Thanked 66 Times in 63 Posts
Rep Power: 469762
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Turn Signal Issue

Sounds like you need blinker fluid.
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #5  
Old 07-16-2011, 10:50 AM
NHWK05's Avatar
Senior Member
My Jeep: 2005 4.7L WK
 
Join Date: Jun 2009
Location: Hooksett, NH
Posts: 5,111
Thanks: 0
Thanked 13 Times in 13 Posts
Rep Power: 94595
NHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond reputeNHWK05 has a reputation beyond repute
Re: Turn Signal Issue

Its prolly the lever module/multifunction unit. Id get a used one from the salvage yard and try that.
__________________
-Kyle '05 Dark Khaki (PJT) WK Limited 4.7L V8, '08 Overland Front End, Custom Exhaust, 245/70/17 GY Silent Armors, Bilstein 4600s, K40 Calibre DL Radar Detector/Laser Diffuser, CB.
Wife's Jeep: '06 Jeep Liberty KJ 4x4 2.8L CRD Diesel
Reply With Quote
  #6  
Old 07-29-2011, 09:07 AM
New Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jul 2011
Location: Ohio
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
teets is on a distinguished road
Re: Turn Signal Issue

Quote:
Originally Posted by NHWK05 View Post
Its prolly the lever module/multifunction unit. Id get a used one from the salvage yard and try that.
2nd on the lever module.
__________________
Reply With Quote
  #7  
Old 11-07-2011, 10:08 PM
Member
My Jeep: 1999 4.0L XJ
 
Join Date: Nov 2011
Location: Cincinnati
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1036
BradXJ is on a distinguished road
Re: Turn Signal Issue

Yes, try replacing the whole lever unit. I just went through this with my XJ, but it was the relay in my case. I have a spare lever I bought to test my turn signals with if you're interested.
__________________
Reply With Quote
  #8  
Old 02-05-2012, 02:30 PM
New Member
My Jeep: 1996 4.0L XJ
 
Join Date: Feb 2012
Location: Columbus Ohio
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
RetiredLawman is on a distinguished road
Re: Turn Signal Issue

Just possibly........My 4 conductor trailer connector was on the spare side. Water got in. Shorted out. Cut it off (cause I don't need. ) And everything came back to life. Was a dead short in the connector.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signal in side mirrors mputnik Interior/Exterior/Visual 45 07-02-2013 10:18 AM
Turn signal problem SvenskaJeepGuy Grand Cherokee - WK 22 04-30-2011 09:52 PM
Chrome turn signal bulbs? NHWK05 Audio, Video, Navigation & Electronic Modifications 5 07-14-2010 08:18 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:33 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community