Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Cherokee-SJ and XJ

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-09-2013, 01:19 AM
4.whoa's Avatar
Senior Member
My Jeep: 2005 5.7L WK
 
Join Date: Nov 2010
Location: ks
Posts: 1,735
Thanks: 46
Thanked 15 Times in 13 Posts
Rep Power: 1141671
4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute4.whoa has a reputation beyond repute
Garage
weird electrical problem

I have a 95 Cherokee 4.0/auto/pwr win & locks. my control switches in the drivers door have not worked right for a while. when I took it apart I noticed the rubbery connector that plugs into the switches themselves was a little melted. also some of the switches were pretty bad. while I was tinkering with ( squeezing the connectors for a better grip on the pins ) it I think I may have shorted it somewhere. there was no spark but all the sudden the dome light, power windows, power locks ,& stereo all quit. I've checked all the fuses under the dash and under the hood 3 times. but I still have no power. it starts and runs fine. upon checking the extra terminals in the fuse block, I found only one battery and one ignition to still have power. for the time being I have used a jumper to go from the a mission that works to the ones that do not work to backfeed power for things to work. even doing that they're still are no power windows. I have several Cherokees and the older ones have the obvious fusible links over by the battery ,however I can't seem to find any on this. I haven't had any luck searching either.anybody have any ideas ?

I have replaced all the switches, but that hasn't helped either. None of the wires are touching
__________________

Build thread:http://www.jeepgarage.org/f14/whoas-...ead-33075.html
Quote:
You think that's quick................heh...wait till I hit 5th! -Sir Mix-A-Lot
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird Problem??? Idowza Troubleshooting/Problems 3 02-08-2013 09:14 PM
Weird A/C Problem Archer Troubleshooting/Problems 5 12-02-2012 10:53 AM
HELP!! Weird electrical issue jcostri09 Troubleshooting/Problems 7 11-01-2012 09:04 AM
Weird A/C problem? remmy Troubleshooting/Problems 11 08-16-2012 08:53 PM
Weird electrical zapping sound on power down xtex404 Trouble Shooting/Problems/Service 4 03-17-2011 04:23 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:52 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.