Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Export Grand Cherokee 2011+

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #37  
Old 03-04-2013, 09:40 PM
ENFORCER's Avatar
Premium Member
My Jeep: 2014 6.4L WK2
 
Join Date: May 2011
Location: Sydney, Australia
Posts: 2,184
Thanks: 29
Thanked 139 Times in 112 Posts
Rep Power: 322899
ENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond repute
Re: CRD Starting Problem

Does the Security light come on when it stalls?
__________________

__________________
Previous Ride = 2011 JGC CRD Overland
Current Ride = 2014 Silver JGC SRT with Pano, HK and Spider monkeys.
Mods = CLSTech Ribbon Mod

Best 1/4 13.4@102Mph
Reply With Quote
  #38  
Old 03-05-2013, 12:17 AM
Premium Member
My Jeep: 2015 3.0L WK2
 
Join Date: Dec 2011
Location: Gold Coast Australia
Posts: 742
Thanks: 25
Thanked 112 Times in 98 Posts
Rep Power: 35663
John47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond repute
Re: CRD Starting Problem

the only lit indicator is the oil can with the drip in the lower left corner that represents engine oil - never see it at any other time.
It is an immediate shutdown after the starter motor stops - the motor stops with the indicator on - doesn't go thru the chimes or the flashing of other lights you see on a normal start.
Otherwise, drives and behaves normally - just a pain in the butt on these infrequent times now that you have to press the button a couple of times to bring up the start screen,
Never does it twice in a row.
__________________

__________________
2015 Laredo CRD
Billet Silver with Quadralift, front recovery hook, Mopar towbar
Upgraded from 2012 CRD that did the job brilliantly for 4 years
1975 Holden HJ 308 Monaro 4dr - oldie but a goodie
Reply With Quote
  #39  
Old 03-05-2013, 12:26 AM
Sege's Avatar
Member
My Jeep: 2012 3.0L WK2
 
Join Date: May 2011
Location: Perth Western Australia
Posts: 198
Thanks: 28
Thanked 4 Times in 4 Posts
Rep Power: 2135
Sege is on a distinguished road
Re: CRD Starting Problem

Quote:
Originally Posted by John47 View Post
the only lit indicator is the oil can with the drip in the lower left corner that represents engine oil - never see it at any other time.
It is an immediate shutdown after the starter motor stops - the motor stops with the indicator on - doesn't go thru the chimes or the flashing of other lights you see on a normal start.
Otherwise, drives and behaves normally - just a pain in the butt on these infrequent times now that you have to press the button a couple of times to bring up the start screen,
Never does it twice in a row.

Exactly what mine did and displayed there is a TSB Flash for that, it fixed mine at least 12 mths ago now. Hasn't done it since!
Reply With Quote
  #40  
Old 03-05-2013, 06:06 AM
yoda42's Avatar
Member
My Jeep: 2011 3.0L WK2
 
Join Date: Dec 2011
Location: Darwin Australia
Posts: 386
Thanks: 1
Thanked 36 Times in 34 Posts
Rep Power: 2389
yoda42 has a reputation beyond reputeyoda42 has a reputation beyond reputeyoda42 has a reputation beyond reputeyoda42 has a reputation beyond reputeyoda42 has a reputation beyond reputeyoda42 has a reputation beyond reputeyoda42 has a reputation beyond reputeyoda42 has a reputation beyond reputeyoda42 has a reputation beyond reputeyoda42 has a reputation beyond repute
John, do you have your foot on the brake when you shut it down?.
There was an update that came out last year that said if you have your foot on the brake when shutting down it can confuse the GC's tiny little brain!.
So foot on brake for starting, foot off brake for shut down, if you don't already do this give it a go.
Yoda
__________________
[SIGPIC][/SIGPIC]2011 Grand Cherokee Laredo CRD & Aussieswag Rover LX Campertrailer
www.travelswithbeagles.blogspot.com
Reply With Quote
  #41  
Old 03-05-2013, 04:30 PM
Premium Member
My Jeep: 2015 3.0L WK2
 
Join Date: Dec 2011
Location: Gold Coast Australia
Posts: 742
Thanks: 25
Thanked 112 Times in 98 Posts
Rep Power: 35663
John47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond repute
Re: CRD Starting Problem

Quote:
Originally Posted by Sege View Post
Exactly what mine did and displayed there is a TSB Flash for that, it fixed mine at least 12 mths ago now. Hasn't done it since!
GDay Sege
our Jeep was delivered end March 2012 ......and I am informed by both my home dealer and the Ballarat one that any updates that are applicable to early models are incorporated in later software versions.
THey just reflashed for an unapplicable TSB just to ensure that it had the latest software available.
Made absolutely no difference - but thanks for the suggestion - maybe the bugger has found another way to wiggle thru the software to cause a problem!!
John
__________________
2015 Laredo CRD
Billet Silver with Quadralift, front recovery hook, Mopar towbar
Upgraded from 2012 CRD that did the job brilliantly for 4 years
1975 Holden HJ 308 Monaro 4dr - oldie but a goodie
Reply With Quote
  #42  
Old 03-05-2013, 04:35 PM
Premium Member
My Jeep: 2015 3.0L WK2
 
Join Date: Dec 2011
Location: Gold Coast Australia
Posts: 742
Thanks: 25
Thanked 112 Times in 98 Posts
Rep Power: 35663
John47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond repute
Re: CRD Starting Problem

Quote:
Originally Posted by yoda42 View Post
John, do you have your foot on the brake when you shut it down?.
There was an update that came out last year that said if you have your foot on the brake when shutting down it can confuse the GC's tiny little brain!.
So foot on brake for starting, foot off brake for shut down, if you don't already do this give it a go.
Yoda
Thanks Yoda
I know at the times it does it's little trick it can still happen whether your foot is on the brake or not.
Normally I wouldn't worry about whether I have my foot on the brake or not when pressing for stop.
This thing has done 27,000k without a sign of this irritation - something has changed somewhere.......just gotta find out what.
John
__________________
2015 Laredo CRD
Billet Silver with Quadralift, front recovery hook, Mopar towbar
Upgraded from 2012 CRD that did the job brilliantly for 4 years
1975 Holden HJ 308 Monaro 4dr - oldie but a goodie
Reply With Quote
  #43  
Old 03-20-2013, 01:41 AM
Premium Member
My Jeep: 2015 3.0L WK2
 
Join Date: Dec 2011
Location: Gold Coast Australia
Posts: 742
Thanks: 25
Thanked 112 Times in 98 Posts
Rep Power: 35663
John47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond repute
Re: CRD Starting Problem

Just as an update.....
I reported that the dealer couldn't find any issue and reflashed for a TSB that wasn't listed for our VIN.
4 starts after leaving the dealer (and my post) the thing started and shut down.
HOWEVER - it has now been over 2 weeks and not done it again!!
I've done nothing different to explain this and we are keeping our fingers crossed the thing has sorted whatever it was.
Curious thing we have noted however that our Iphone 4s now sounds an incoming text tone through Uconnect - never did that before. Always rang fine but never announced an incoming text - we're taking it as a bonus.
Anyway - now back home after clocking up over 6k on our travel loop and it was an absolute pleasure to cover the km - that included 750 odd k of rough and dusty dirt between Broken Hill, Tibooburra, Wanaaring and Hungerford. Plenty of cleaning up to do......
__________________
2015 Laredo CRD
Billet Silver with Quadralift, front recovery hook, Mopar towbar
Upgraded from 2012 CRD that did the job brilliantly for 4 years
1975 Holden HJ 308 Monaro 4dr - oldie but a goodie
Reply With Quote
  #44  
Old 03-22-2013, 05:49 AM
Member
My Jeep: 2011 3.0L WK2
 
Join Date: Dec 2011
Location: Italy
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1758
enricodg is on a distinguished road
Re: CRD Starting Problem

My CRD had this problem for 7 months (more or less 1 time a month).

My dealer made a software upgrade (don't know exactly wich TSB) and now the issue is resolved (6 months and no more issue).
__________________
[SIGPIC][/SIGPIC]
My GC
Reply With Quote
  #45  
Old 03-22-2013, 09:05 AM
SunShine31x's Avatar
Member
My Jeep: 2012 3.0L WK2
 
Join Date: Feb 2013
Location: Düsseldorf, Germany
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1344
SunShine31x is on a distinguished road
Re: CRD Starting Problem

have heard about this problem too.

here it was told, just to keep the "start" button as long pressed until the engine runs.
but there was an update here too some time ago.
__________________
Grand Cherokee Overland 3.0L CRD O.CT - MY2012 - brilliant black - leather frost beige
Reply With Quote
  #46  
Old 08-18-2016, 06:16 AM
gorman's Avatar
Member
My Jeep: 2012 3.0L WK2
 
Join Date: Aug 2016
Location: Cape Town, South Africa
Posts: 5
Thanks: 0
Thanked 2 Times in 1 Post
Rep Power: 35
gorman is on a distinguished road
Re: CRD Starting Problem

This is digging up a very old thread, but I'm the new owner of a 2012 GC CRD and I'm experiencing the exact start stop issue explained here. Has any new information come to light thus far that pin points the issue to a specific TSB or other solution? This morning it did the start stop sequence a few times in a row and in the end it just stopped. Thereafter the lights on the dash came on as usual, but no starting - not cranking at all. It was taken to the local Jeep dealer on a flatbed where it is now awaiting scanning for fault codes. Would be great if, from others experiences, I can nudge them in the right direction as to where to look for a solution...any help would be appreciated.
Reply With Quote
  #47  
Old 08-19-2016, 03:28 AM
gorman's Avatar
Member
My Jeep: 2012 3.0L WK2
 
Join Date: Aug 2016
Location: Cape Town, South Africa
Posts: 5
Thanks: 0
Thanked 2 Times in 1 Post
Rep Power: 35
gorman is on a distinguished road
Re: CRD Starting Problem

For what its worth, the dealer scanned the Jeep yesterday and identified issues with the WIN module. They suggest replacing the WIN module, steering lock and two new key fobs as the solution to the problem. I've been searching on many other forums for answers as well as it seems to be a fairly accurate diagnosis. Here's with John posted in AUSJEEPOFFROAD.COM:

AUSJEEPOFFROAD.COM - AJOR - View Single Post - WK2 Won't Start?

Quote:
Just to top up this thread with additional info that may help someone else.

We also experienced an intermittent start issue with our 2012 CRD - from around 20,000k. Jump in, press the button and about once every 20 starts the engine would fire and immediately shut down, displaying the oil pressure light. It would happen with either key fob, engine hot or cold, at any fuel tank level.
Checked numerous times by several dealers as we travelled, no codes ever stored - never fixed.

The problem persisted for 10 months with no change in frequency, and every time on a second try the thing started fine. Every service I complained to the dealer, every time they checked it out and could find no fault.

Totally frustrated, I spoke to another dealer service manager who undertook to have a crack at it.

Dropped the vehicle in and several hours later had a call saying they believed the WIN module was the issue, and had ordered parts - they also wanted our second key fob.
The WIN, plus steering lock module, plus both key fobs were replaced - it was explained that all these items are apparently coded together.

40,000k later and the issue has never reappeared - definitely fixed, and a delight to jump in.

Our experience absolutely mirrors some of the excellent advice already given in previous posts. You do need a dealer who cares though, and has clued up people.
John
__________________
2015 Laredo CRD with QL - that replaced our 2012 Laredo CRD Bright Silver with QL
Reply With Quote
  #48  
Old 08-19-2016, 06:09 PM
Premium Member
My Jeep: 2015 3.0L WK2
 
Join Date: Dec 2011
Location: Gold Coast Australia
Posts: 742
Thanks: 25
Thanked 112 Times in 98 Posts
Rep Power: 35663
John47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond repute
Re: CRD Starting Problem

Quote:
Originally Posted by gorman View Post
For what its worth, the dealer scanned the Jeep yesterday and identified issues with the WIN module. They suggest replacing the WIN module, steering lock and two new key fobs as the solution to the problem. I've been searching on many other forums for answers as well as it seems to be a fairly accurate diagnosis. Here's with John posted in AUSJEEPOFFROAD.COM:

AUSJEEPOFFROAD.COM - AJOR - View Single Post - WK2 Won't Start?
Hi Gorman
I can confirm that when the WIN module was replaced (along with the steering lock and fobs) our 2012 happily ran right thru to 97,000K (when it went to a new home), with no recurrence of the random shutdown.
It never set a code before it was diagnosed however, and it took a switched on and caring service manager to sort the issue.

We are just back from spending the winter in Darwin and our 2015 made the journey up and back an absolute pleasure.
John
__________________

__________________
2015 Laredo CRD
Billet Silver with Quadralift, front recovery hook, Mopar towbar
Upgraded from 2012 CRD that did the job brilliantly for 4 years
1975 Holden HJ 308 Monaro 4dr - oldie but a goodie
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Grand Cherokee Starting Problem Please Help Nick2 Engine Performance/Intake/Exhaust 16 11-24-2011 09:56 AM
Starting problem jdb2797 Engine Performance/Intake/Exhaust 15 08-06-2011 07:24 PM
jeep starting problem jdubgrand Grand Cherokee - WK 10 07-03-2011 04:14 PM
Weird Starting Problem silversx05 Grand Cherokee - WK 7 06-06-2010 06:43 PM
Problem starting Jeep StoneCold Troubleshooting/Problems 15 02-23-2010 07:13 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:53 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.