Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Export Grand Cherokee 2011+

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #37  
Old 03-04-2013, 09:40 PM
ENFORCER's Avatar
Premium Member
My Jeep: 2014 6.4L WK2
 
Join Date: May 2011
Location: Sydney, Australia
Posts: 1,931
Thanks: 23
Thanked 78 Times in 64 Posts
Rep Power: 321882
ENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond repute
Re: CRD Starting Problem

Does the Security light come on when it stalls?
__________________

__________________
Previous Ride = 2011 JGC CRD Overland
Current Ride = 2014 Silver JGC SRT with Pano, HK and Spider monkeys.
Mods = CLSTech Ribbon Mod
Reply With Quote
  #38  
Old 03-05-2013, 12:17 AM
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Dec 2011
Location: Gold Coast Australia
Posts: 623
Thanks: 1
Thanked 51 Times in 48 Posts
Rep Power: 34313
John47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond repute
Re: CRD Starting Problem

the only lit indicator is the oil can with the drip in the lower left corner that represents engine oil - never see it at any other time.
It is an immediate shutdown after the starter motor stops - the motor stops with the indicator on - doesn't go thru the chimes or the flashing of other lights you see on a normal start.
Otherwise, drives and behaves normally - just a pain in the butt on these infrequent times now that you have to press the button a couple of times to bring up the start screen,
Never does it twice in a row.
__________________

__________________
2012 Laredo CRD
Bright Silver with Quadralift & front recovery hook - (that has been used unfortunately)
Mopar towbar
Reply With Quote
  #39  
Old 03-05-2013, 12:26 AM
Sege's Avatar
Member
My Jeep: 2012 3.0L WK2
 
Join Date: May 2011
Location: Perth Western Australia
Posts: 175
Thanks: 22
Thanked 2 Times in 2 Posts
Rep Power: 1348
Sege is on a distinguished road
Re: CRD Starting Problem

Quote:
Originally Posted by John47 View Post
the only lit indicator is the oil can with the drip in the lower left corner that represents engine oil - never see it at any other time.
It is an immediate shutdown after the starter motor stops - the motor stops with the indicator on - doesn't go thru the chimes or the flashing of other lights you see on a normal start.
Otherwise, drives and behaves normally - just a pain in the butt on these infrequent times now that you have to press the button a couple of times to bring up the start screen,
Never does it twice in a row.

Exactly what mine did and displayed there is a TSB Flash for that, it fixed mine at least 12 mths ago now. Hasn't done it since!
__________________
Reply With Quote
  #40  
Old 03-05-2013, 06:06 AM
yoda42's Avatar
Member
My Jeep: 2011 3.0L WK2
 
Join Date: Dec 2011
Location: Darwin Australia
Posts: 351
Thanks: 0
Thanked 22 Times in 22 Posts
Rep Power: 1591
yoda42 has a reputation beyond reputeyoda42 has a reputation beyond reputeyoda42 has a reputation beyond reputeyoda42 has a reputation beyond reputeyoda42 has a reputation beyond reputeyoda42 has a reputation beyond reputeyoda42 has a reputation beyond reputeyoda42 has a reputation beyond reputeyoda42 has a reputation beyond reputeyoda42 has a reputation beyond repute
John, do you have your foot on the brake when you shut it down?.
There was an update that came out last year that said if you have your foot on the brake when shutting down it can confuse the GC's tiny little brain!.
So foot on brake for starting, foot off brake for shut down, if you don't already do this give it a go.
Yoda
__________________
[SIGPIC][/SIGPIC]2011 Grand Cherokee Laredo CRD & Aussieswag Rover LX Campertrailer
www.travelswithbeagles.blogspot.com
Reply With Quote
  #41  
Old 03-05-2013, 04:30 PM
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Dec 2011
Location: Gold Coast Australia
Posts: 623
Thanks: 1
Thanked 51 Times in 48 Posts
Rep Power: 34313
John47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond repute
Re: CRD Starting Problem

Quote:
Originally Posted by Sege View Post
Exactly what mine did and displayed there is a TSB Flash for that, it fixed mine at least 12 mths ago now. Hasn't done it since!
GDay Sege
our Jeep was delivered end March 2012 ......and I am informed by both my home dealer and the Ballarat one that any updates that are applicable to early models are incorporated in later software versions.
THey just reflashed for an unapplicable TSB just to ensure that it had the latest software available.
Made absolutely no difference - but thanks for the suggestion - maybe the bugger has found another way to wiggle thru the software to cause a problem!!
John
__________________
2012 Laredo CRD
Bright Silver with Quadralift & front recovery hook - (that has been used unfortunately)
Mopar towbar
Reply With Quote
  #42  
Old 03-05-2013, 04:35 PM
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Dec 2011
Location: Gold Coast Australia
Posts: 623
Thanks: 1
Thanked 51 Times in 48 Posts
Rep Power: 34313
John47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond repute
Re: CRD Starting Problem

Quote:
Originally Posted by yoda42 View Post
John, do you have your foot on the brake when you shut it down?.
There was an update that came out last year that said if you have your foot on the brake when shutting down it can confuse the GC's tiny little brain!.
So foot on brake for starting, foot off brake for shut down, if you don't already do this give it a go.
Yoda
Thanks Yoda
I know at the times it does it's little trick it can still happen whether your foot is on the brake or not.
Normally I wouldn't worry about whether I have my foot on the brake or not when pressing for stop.
This thing has done 27,000k without a sign of this irritation - something has changed somewhere.......just gotta find out what.
John
__________________
2012 Laredo CRD
Bright Silver with Quadralift & front recovery hook - (that has been used unfortunately)
Mopar towbar
Reply With Quote
  #43  
Old 03-20-2013, 01:41 AM
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Dec 2011
Location: Gold Coast Australia
Posts: 623
Thanks: 1
Thanked 51 Times in 48 Posts
Rep Power: 34313
John47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond repute
Re: CRD Starting Problem

Just as an update.....
I reported that the dealer couldn't find any issue and reflashed for a TSB that wasn't listed for our VIN.
4 starts after leaving the dealer (and my post) the thing started and shut down.
HOWEVER - it has now been over 2 weeks and not done it again!!
I've done nothing different to explain this and we are keeping our fingers crossed the thing has sorted whatever it was.
Curious thing we have noted however that our Iphone 4s now sounds an incoming text tone through Uconnect - never did that before. Always rang fine but never announced an incoming text - we're taking it as a bonus.
Anyway - now back home after clocking up over 6k on our travel loop and it was an absolute pleasure to cover the km - that included 750 odd k of rough and dusty dirt between Broken Hill, Tibooburra, Wanaaring and Hungerford. Plenty of cleaning up to do......
__________________
2012 Laredo CRD
Bright Silver with Quadralift & front recovery hook - (that has been used unfortunately)
Mopar towbar
Reply With Quote
  #44  
Old 03-22-2013, 05:49 AM
Member
My Jeep: 2011 3.0L WK2
 
Join Date: Dec 2011
Location: Italy
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 994
enricodg is on a distinguished road
Re: CRD Starting Problem

My CRD had this problem for 7 months (more or less 1 time a month).

My dealer made a software upgrade (don't know exactly wich TSB) and now the issue is resolved (6 months and no more issue).
__________________
[SIGPIC][/SIGPIC]
My GC
Reply With Quote
  #45  
Old 03-22-2013, 09:05 AM
SunShine31x's Avatar
Member
My Jeep: 2012 3.0L WK2
 
Join Date: Feb 2013
Location: Düsseldorf, Germany
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 581
SunShine31x is on a distinguished road
Re: CRD Starting Problem

have heard about this problem too.

here it was told, just to keep the "start" button as long pressed until the engine runs.
but there was an update here too some time ago.
__________________

__________________
Grand Cherokee Overland 3.0L CRD O.CT - MY2012 - brilliant black - leather frost beige
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Grand Cherokee Starting Problem Please Help Nick2 Engine Performance/Intake/Exhaust 16 11-24-2011 09:56 AM
Starting problem jdb2797 Engine Performance/Intake/Exhaust 15 08-06-2011 07:24 PM
jeep starting problem jdubgrand Grand Cherokee - WK 10 07-03-2011 04:14 PM
Weird Starting Problem silversx05 Grand Cherokee - WK 7 06-06-2010 06:43 PM
Problem starting Jeep StoneCold Troubleshooting/Problems 15 02-23-2010 07:13 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:23 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community