Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Export Grand Cherokee 2011+

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-28-2013, 07:29 AM
Member
 
Join Date: Aug 2013
Posts: 15
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 382
TurboTaxi is on a distinguished road
Cruise Control . Just stops

Hi all ,
Brand new 3.0 crd limited grand
When useing the Cruise Control i want to go faster i press the + and 9 times out of 10 it does what its supposed to

3 times now (its got 600 km on it ) the cruise just disconects and the cruise indicator goes out on the dash . if i turn it back on nothing happens . the indicator will not come back on

The only way to get ti to work is pull over and turn off . Start it back up and all is fine

Is it passionate fingers and im doing something wrong or do i have a fault and has anyyone experienced it
Thanks
LEN
__________________

__________________
Reply With Quote
  #2  
Old 08-28-2013, 10:02 AM
Barboots's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: Perth, Western Australia
Posts: 1,054
Thanks: 10
Thanked 71 Times in 60 Posts
Rep Power: 2258
Barboots has disabled reputation
Re: Cruise Control . Just stops

Len I've not been here long, but I've read of this happening. Unfortunately I can't recall where it went.

To be honest, I originally joined just to get the pictures and be able to search directly. Have you given the search feature a nudge? You can also use Google to search the site if that works better for you... just add site:jeepgarage.org to the end of your Google search.

Cheers,
Steve
__________________

__________________
2014 Overland CRD
Perth, Western Australia
Reply With Quote
  #3  
Old 08-28-2013, 05:32 PM
allypally's Avatar
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Aug 2011
Location: NW Sydney
Posts: 2,142
Thanks: 23
Thanked 122 Times in 102 Posts
Rep Power: 55517
allypally has a reputation beyond reputeallypally has a reputation beyond reputeallypally has a reputation beyond reputeallypally has a reputation beyond reputeallypally has a reputation beyond reputeallypally has a reputation beyond reputeallypally has a reputation beyond reputeallypally has a reputation beyond reputeallypally has a reputation beyond reputeallypally has a reputation beyond reputeallypally has a reputation beyond repute
Re: Cruise Control . Just stops

Issues with Cruise Control in the MY11-MY13's was generally associated with the brake pedal being activated. Commonly found to be a short in the wiring under the carpet due to the stretching of the cable from Lefthand drive to Righthand drive. Firstly check that wiring to ensure it has not come adrift. If you search these Aussie threads, you will find refererences to it
__________________
MY12 Overland CRD
Cherry Red
Saddle Interior.
Front Recovery Hook.
Reply With Quote
  #4  
Old 08-28-2013, 07:03 PM
Member
 
Join Date: Aug 2013
Posts: 15
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 382
TurboTaxi is on a distinguished road
Re: Cruise Control . Just stops

Thanks for the thoughts ,
ill have another look tonight , i spend about half an hour searching before i posted

the interesting thing is the icon disapears to say the cruise is on and cannot be switched back on without a full car restart .
thanks
len
__________________
Reply With Quote
  #5  
Old 08-28-2013, 08:33 PM
Barboots's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: Perth, Western Australia
Posts: 1,054
Thanks: 10
Thanked 71 Times in 60 Posts
Rep Power: 2258
Barboots has disabled reputation
Re: Cruise Control . Just stops

Quote:
Originally Posted by TurboTaxi View Post
Thanks for the thoughts ,
ill have another look tonight , i spend about half an hour searching before i posted

the interesting thing is the icon disapears to say the cruise is on and cannot be switched back on without a full car restart .
thanks
len
Yep that pretty much wipes out the brake wire causing it.

I thought I saw something on the US forum, but if you've searched I dunno what else to do but wait... or post in the main forum. If you get no bites here I'd hit them up over there.

Cheers,
Steve
__________________
2014 Overland CRD
Perth, Western Australia
Reply With Quote
  #6  
Old 08-29-2013, 12:05 AM
pomdave's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Jul 2013
Location: Vic, AU
Posts: 37
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 454
pomdave is on a distinguished road
Re: Cruise Control . Just stops

I have experienced this a few times.

It is definetly related to increasing the speed, it seems more stable if you increase the the speed incrementaly (multiple presses of the + button) rather than holding down the + button until you get up to the desired speed, and like you said when it happens the Cruise Control goes awol until the engine is restarted ... it is quite annoying if it happens near the begining of your journey.
__________________
Reply With Quote
  #7  
Old 08-29-2013, 12:21 AM
mm1964's Avatar
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Feb 2012
Location: Sydney Australia
Posts: 209
Thanks: 36
Thanked 3 Times in 3 Posts
Rep Power: 1136
mm1964 is on a distinguished road
Re: Cruise Control . Just stops

It occurred to me once in a MY12 Overland. I had used the cruise control often but once after a good 60 min trip the cruise control just switched off on it's own and refused to come back on. I did the complete shutdown routine and nothing. 20 mins later I retried and nothing. Got to my destination and when I got back in and set off it was fine. Never reoccurred again but I only had the car for a few thousand klms. As it was an Overland I had numerous messages in the EVIC display coming up relating to Adaptive Cruise Control, Blind Spot monitoring failures or there unavailablity. Believe I may have posted this here on the forums at the time.
__________________
MY2013 Overland 3.0 CRD In Mineral Grey
Reply With Quote
  #8  
Old 08-29-2013, 05:27 PM
Member
 
Join Date: Aug 2013
Posts: 15
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 382
TurboTaxi is on a distinguished road
It seems the problem has now diagnosed itself

I have an error that says service electronic throttle control on the dash

image-1962541612.jpg

At least I have something to report at first service
Len
__________________
Reply With Quote
  #9  
Old 08-29-2013, 08:50 PM
Barboots's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: Perth, Western Australia
Posts: 1,054
Thanks: 10
Thanked 71 Times in 60 Posts
Rep Power: 2258
Barboots has disabled reputation
Re: Cruise Control . Just stops

Well that's good news Len as it's something that clearly requires repair. Definitely better than an intermittent fault that the workshop can never find.

Cheers,
Steve
__________________
2014 Overland CRD
Perth, Western Australia
Reply With Quote
  #10  
Old 09-02-2013, 09:43 PM
Member
 
Join Date: Aug 2013
Posts: 15
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 382
TurboTaxi is on a distinguished road
Well a call to the dealer and he booked it into the local dealer up the road

They had it for an hour

The error has gone off the dash and I haven't had the problem since

Very impressed wit arm strings in toowoomba and sunco on the sunny coast for some good old fashioned service .

Adjustment of brake pedal switch so it doesn't trigger while accelerating
__________________
Reply With Quote
  #11  
Old 09-12-2013, 07:12 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Location: Rockingham, WA
Posts: 58
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 527
adriwood is on a distinguished road
Re: Cruise Control . Just stops

Quote:
Originally Posted by TurboTaxi View Post
Hi all ,
Brand new 3.0 crd limited grand
When useing the Cruise Control i want to go faster i press the + and 9 times out of 10 it does what its supposed to

3 times now (its got 600 km on it ) the cruise just disconects and the cruise indicator goes out on the dash . if i turn it back on nothing happens . the indicator will not come back on

The only way to get ti to work is pull over and turn off . Start it back up and all is fine

Is it passionate fingers and im doing something wrong or do i have a fault and has anyyone experienced it
Thanks
LEN
Done it now to the trouble and strife four times in 3400 kms. I cannot seem to replicate it.

Once it decides that it does not want to play then it's a stop and start again.

Am now keeping a log of when it happens

Regards

Adrian
__________________
Reply With Quote
  #12  
Old 09-15-2013, 10:50 PM
Member
 
Join Date: Jul 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 411
9greasemonkey9 is on a distinguished road
Re: Cruise Control . Just stops

Hi everyone , first post . I just thought I would let you know your not alone .
I picked up my Laredo on friday and have encountered the same cruise control problem twice in 500KM . It has only faulted when using the + or resume feature . I will let you guys know what the outcome when I finally get it back to the dealer .
JOEL
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cruise control dippinsoldier92 Troubleshooting/Problems 0 05-28-2013 01:12 PM
Cruise control Armstrong437 Trouble Shooting/Problems/Service 1 09-27-2012 02:11 AM
Cruise Control issue a65thor Troubleshooting/Problems 8 08-17-2012 09:09 PM
Cruise Control kazak Grand Cherokee - WK2 - 9 03-16-2012 11:55 AM
cruise control windycityjeep Trouble Shooting/Problems/Service 7 02-26-2012 12:14 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:42 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community