Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Export Grand Cherokee 2011+

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-15-2012, 07:07 PM
ENFORCER's Avatar
Premium Member
My Jeep: 2011 3.0L WK2
 
Join Date: May 2011
Location: Sydney, Australia
Posts: 1,719
Thanks: 18
Thanked 62 Times in 49 Posts
Rep Power: 321569
ENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond repute
First Service - List of issues

Ok,
We are getting our Jeep serviced for the first time next week.
I hope they do a decent job, as I am very fussy. The list of things to fix has grown in the past weeks.
So far I have:
6 month 10,000km Service (No oil change)

TSB for 1/2 shaft in steering. (I feel a clunk in the steering when stopping)

Car starts and stalls. This has happened about 6 times now. You start the motor and it stalls a second later. You can get this happening 6 times in a row. Fix is to exit and lock the car and try again. Seems to work after a full lock and unlock. Could be the WIM or FOBIK.

Alarm: last saturday and last night the alarm went off for no reason.

DRL's do not work as they should. No idea, as they stopped working after the LED's were installed and have not worked since. Even after putting the OEM globes back in. Checked all fuses and globes.


I will report back once the work is done.
__________________

__________________
MY2011 CRD Overland in Bright Silver

I Bought an SRT - Bright Silver, HK + Roof
Reply With Quote
  #2  
Old 03-15-2012, 07:43 PM
Member
 
Join Date: Sep 2011
Posts: 300
Thanks: 0
Thanked 7 Times in 6 Posts
Rep Power: 1537
frog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond repute
Re: First Service - List of issues

Alarm.. is this an aftermarket alarm? Or do the GCs come with an alarm that im not aware of?

Why no oil change, i thought they where ment to do it every 10,000ks.

DRLs may be a hidden fuse or somthing? or ECU sensor? meh they can fix it
__________________

__________________
2012 Grand Cherokee True Blue CRD :D
Reply With Quote
  #3  
Old 03-15-2012, 08:40 PM
ENFORCER's Avatar
Premium Member
My Jeep: 2011 3.0L WK2
 
Join Date: May 2011
Location: Sydney, Australia
Posts: 1,719
Thanks: 18
Thanked 62 Times in 49 Posts
Rep Power: 321569
ENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond repute
Re: First Service - List of issues

All the Overlands have a factory alarm that sounds the horn. Mine has now gone off twice without any reason.
I only changed the oil less than 1,000km ago. I will do it again when it hits 15,000km.
I have checked everything to do with the DRL's. I think it is a switch in the ECU that needs to be re-enabled, as they work when the lights are on, but duller.
__________________
MY2011 CRD Overland in Bright Silver

I Bought an SRT - Bright Silver, HK + Roof
Reply With Quote
  #4  
Old 03-15-2012, 09:14 PM
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Dec 2011
Location: Gold Coast Australia
Posts: 575
Thanks: 0
Thanked 45 Times in 43 Posts
Rep Power: 34164
John47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond repute
Re: First Service - List of issues

Quote:
Originally Posted by frog_a_lot View Post
Alarm.. is this an aftermarket alarm? Or do the GCs come with an alarm that im not aware of?

it
Our Laredo has an alarm from the factory that I believe is standard.....has gone off a few times by us playing with doors and getting familiar with locking and unlocking.
it is described in the owners manual.
__________________
2012 Laredo CRD
Bright Silver with Quadralift & front recovery hook - (that has been used unfortunately)
Mopar towbar
Reply With Quote
  #5  
Old 03-15-2012, 10:34 PM
Member
 
Join Date: Sep 2011
Posts: 300
Thanks: 0
Thanked 7 Times in 6 Posts
Rep Power: 1537
frog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond reputefrog_a_lot has a reputation beyond repute
Re: First Service - List of issues

Ha, well i guess i do have an alarm. Its never gone off i guess that is why i haven't noticed it. Wow i really should read the manual.. hmm naaa..
__________________
2012 Grand Cherokee True Blue CRD :D
Reply With Quote
  #6  
Old 03-16-2012, 05:02 AM
Member
 
Join Date: Jun 2011
Posts: 81
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1134
Gabs is on a distinguished road
Re: First Service - List of issues

Hi Enforcer I hope your experience is better than mine went in with 3 issues I wanted sorted drove out around the corner and still had the same issues. It was after 5 and peak traffic couldn't be bothered turning back so it will be another visit.
__________________
Reply With Quote
  #7  
Old 03-16-2012, 08:41 AM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,477
Thanks: 0
Thanked 20 Times in 17 Posts
Rep Power: 79942
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: First Service - List of issues

From OM the 5th: "NOTE: Entering a vehicle using the emergency key with
the theft alarm armed, will result in the alarm sounding.
Insert the Key Fob (even if the Key Fob battery is dead)
into the ignition switch to disarm theft alarm.
"

My usual test is to open the door, lock the door with the window down, close the door, move the fobic far engough away (or wrap with tinfoil) so is not detected, the reach in the window and open the door.

My Laredo does not seem to have this module so connot verify. Anyone know how difficult it is to add ? (Suspect just a module).
__________________
Web home. Notary Sojac Y'all
One of these is a diesel:
Reply With Quote
  #8  
Old 03-16-2012, 09:18 AM
Deserthucker's Avatar
Premium Member
My Jeep: 2011 5.7L WK2
 
Join Date: Mar 2011
Location: Kalgoorlie WA
Posts: 860
Thanks: 6
Thanked 11 Times in 11 Posts
Rep Power: 2005
Deserthucker has a reputation beyond reputeDeserthucker has a reputation beyond repute
Re: First Service - List of issues

Don't forget to leave it locked long enough for the alarm to activate.
Laredo and limited have Sentry Key theft deterrent system. and Overland has Deluxe security alarm.
I read somewhere there is not much difference, Overland has motion sensor and tilt sensor.
If they are going to get in the car they most likely will open the doors after breaking the laminated front window which then will set the alarm of.
__________________

Ordered WK2 Mineral Grey (was Blackberry) Hopefully. 18th March 2011
ETA late June now late September
Got it 9th September
Australian Outback
Reply With Quote
  #9  
Old 03-16-2012, 03:25 PM
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Dec 2011
Location: Gold Coast Australia
Posts: 575
Thanks: 0
Thanked 45 Times in 43 Posts
Rep Power: 34164
John47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond repute
Re: First Service - List of issues

Quote:
Originally Posted by John47 View Post
Our Laredo has an alarm from the factory that I believe is standard.....has gone off a few times by us playing with doors and getting familiar with locking and unlocking.
it is described in the owners manual.
Actually found out yesterday why the alarm was going off......the drivers side rear door isn't locking!
All buttons on all doors go up and down with the fob and passive lock on the drivers door.
All looks good and the alarm will arm after a time delay - walk up to vehicle without fob - try DS R door - opens - voila - alarm goes off.
No other doors will do this.
Very tricky because if you visually check you can see the buttons are all down - easy to walk away thinking it is locked and armed.
Off to dealer this morning to sort.
__________________
2012 Laredo CRD
Bright Silver with Quadralift & front recovery hook - (that has been used unfortunately)
Mopar towbar
Reply With Quote
  #10  
Old 03-19-2012, 05:26 AM
ENFORCER's Avatar
Premium Member
My Jeep: 2011 3.0L WK2
 
Join Date: May 2011
Location: Sydney, Australia
Posts: 1,719
Thanks: 18
Thanked 62 Times in 49 Posts
Rep Power: 321569
ENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond repute
Re: First Service - List of issues

Going in tomorrow for the service. I hope they have a clue.
__________________
MY2011 CRD Overland in Bright Silver

I Bought an SRT - Bright Silver, HK + Roof
Reply With Quote
  #11  
Old 03-20-2012, 02:08 AM
ENFORCER's Avatar
Premium Member
My Jeep: 2011 3.0L WK2
 
Join Date: May 2011
Location: Sydney, Australia
Posts: 1,719
Thanks: 18
Thanked 62 Times in 49 Posts
Rep Power: 321569
ENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond repute
Re: First Service - List of issues

Well got the car done. They were fine with me doing the oil changes, they still carried out the rest of the service and stamped the book.
They updated the ECU to fix the alarm and starting problems, hopefully this will fix it.
Got my DRL's working again.
Could not fault the steering, as my car already had the 1/2 shaft. I can feel a slight clunk through the steering wheel when stopping

Couple of problems.
They carried out a wheel balance and wheel alignment, without request.
They broke my ACC/FCW. It was working fine when I dropped the car off and it has never been a problem. When I picked it up they said it would take several weeks to get the part in. So now we have FCW OFF on the dash for the next x weeks.

Total service cost was $282 inc GST (alignment and balance $92)
__________________
MY2011 CRD Overland in Bright Silver

I Bought an SRT - Bright Silver, HK + Roof
Reply With Quote
  #12  
Old 03-20-2012, 05:16 AM
Deserthucker's Avatar
Premium Member
My Jeep: 2011 5.7L WK2
 
Join Date: Mar 2011
Location: Kalgoorlie WA
Posts: 860
Thanks: 6
Thanked 11 Times in 11 Posts
Rep Power: 2005
Deserthucker has a reputation beyond reputeDeserthucker has a reputation beyond repute
Re: First Service - List of issues

Was that your 12000km service.

Mine did not get a wheel alignment at 12000km.
__________________

__________________

Ordered WK2 Mineral Grey (was Blackberry) Hopefully. 18th March 2011
ETA late June now late September
Got it 9th September
Australian Outback
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
List of TSBs gonzanc Trouble Shooting/Problems/Service 3 03-29-2011 09:25 AM
Jeep.com Owners site. Incomplete service history and missing service contract info the1jake Trouble Shooting/Problems/Service 4 02-24-2011 06:14 PM
Service Light - SERVICE 4WD SYSTEM - ?? Only 30K miles.... babygorilla Grand Cherokee - WK 4 02-17-2011 08:09 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:24 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community