Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Export Grand Cherokee 2011+

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #61  
Old 03-11-2014, 01:12 AM
Peanut's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Location: Port Hedland WA
Posts: 81
Thanks: 5
Thanked 4 Times in 2 Posts
Rep Power: 653
Peanut has disabled reputation
Re: Is DPF issue for 2014 CRD fixed now?

I think my DPF is fixed now since it through it's wobbly nearly 4 weeks ago, but still unsure as we still haven't seen the car yet. Starting to get really pissed of with the lying bastards at Jeep and Jeep assist, 12 days ago one rung up saying car on truck be back soon, other says car missed mid week truck leave on weekend. 11 days later get SMS from car carry company "Picked up car be there 2 Days". Sent emails, phoned companies etc. all refer to notes and say "we were told".
Now after telling them what to stick in their notes I have 2 more phone numbers and 3 email addresses to pester about this debacle and how the hell to I get refunded for the hire car I had to use because no one wanted to bear the cost of it.
This car goes into limp mode again, I will drive it back to them and sit and wait till they rip that filter out and get the thing going properly, I don't care how many Dolphins or Whales die because of it (the Japanese need to diet anyway). I want my Jeep!!!!

Wait: phone call from car carrier, car will be here 7am tomorrow, for pick up, 4 weeks to the day.
__________________

__________________
Bryan
Reply With Quote
  #62  
Old 03-11-2014, 01:35 AM
GMWK2's Avatar
Member
 
Join Date: May 2012
Location: Sydney
Posts: 988
Thanks: 23
Thanked 60 Times in 54 Posts
Rep Power: 2007
GMWK2 has a reputation beyond reputeGMWK2 has a reputation beyond reputeGMWK2 has a reputation beyond reputeGMWK2 has a reputation beyond repute
That really is shocking peanut.
__________________

__________________
2012 Mineral Grey CRD Laredo, Off Road Adventure II, Quadra Drive II, Quadra Lift, Cooper AT3, Stupid Useless JA Recovery Hook (modified) and sand mode software upgrade on 8 April 2013, full size alloy spare, GME TX3345, Chief Products recovery hook and bash plate, Jeep Garage sticker
Reply With Quote
  #63  
Old 03-11-2014, 05:52 PM
ENFORCER's Avatar
Premium Member
My Jeep: 2014 6.4L WK2
 
Join Date: May 2011
Location: Sydney, Australia
Posts: 2,052
Thanks: 23
Thanked 99 Times in 81 Posts
Rep Power: 322147
ENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond repute
Re: Is DPF issue for 2014 CRD fixed now?

Peanut,
Your story is a prime example of pathetic customer service. Nobody has taken ownership of your problem and that just stems form JeepAU's total disregard to looking after their customers.

I would draft up a letter of demand to Melbourne head office to the CEO Veronica Johns with a cover letter to explain the events and that you demand they cover the cost of the hire car.
I would also make it clear that if the same DFP problems happens again that you will expect a full refund and compensation.
You are far more patient that I, as I would have gone postal by now if it was my car and I was treated like you were.
__________________
Previous Ride = 2011 JGC CRD Overland
Current Ride = 2014 Silver JGC SRT with Pano, HK and Spider monkeys.
Mods = CLSTech Ribbon Mod

Best 1/4 13.4@102Mph
Reply With Quote
  #64  
Old 03-11-2014, 06:11 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Oct 2013
Location: NSW AUSTRALIA
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 436
fforacing is on a distinguished road
Re: Is DPF issue for 2014 CRD fixed now?

Just an update on my dpf issue. I did as the computer suggested and drive at Highway speed to 'remedy'.... yeah right.
Drive back home and called local Jeep dealer service Centre. They said to call Jeep Assist. They said they would look at it later in afternoon if towed in. Jeep assist sent a tow truck straight away. It arrived my house about 30 mins later.
I contacted the dealer a couple of times to ensure it would get looked at same day.
Picked car up late arvo with problem resolved.
They told me they did a forced regeneration which cleared it out.
They also informed me that it shouldn't happen again and that it was more than likely caused from pre delivery starting stopping etc. They told me to take on freeway 1 tune per fortnight and use it in manual mode and keep rpm between 2500-3000rpm for about 20 mins and it shouldn't happen again.
I had only just returned from 2000k trip on freeways but rpm was only about 2000 or under.
Anyway, happy to have back quickly and going well.
Oh. I think mine is a June 14 build with 6500km on clock.
Cheers
__________________
Reply With Quote
  #65  
Old 03-11-2014, 06:24 PM
Swampy's Avatar
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Jul 2011
Location: Oakford, Western Australia
Posts: 661
Thanks: 2
Thanked 36 Times in 27 Posts
Rep Power: 34682
Swampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond repute
This pre-delivery stop starts excuse for DPF clogging must be about the biggest load of Wank that I have ever heard.
__________________
Regards

Swampy

JGC Overland CRD, Deep Cherry Red

"I'm just here for the biscuits!"
Reply With Quote
  #66  
Old 03-11-2014, 06:30 PM
Benn0's Avatar
Premium Member
 
Join Date: Oct 2013
Location: Brisbane, Australia
Posts: 1,123
Thanks: 25
Thanked 79 Times in 69 Posts
Rep Power: 16275
Benn0 has a reputation beyond reputeBenn0 has a reputation beyond reputeBenn0 has a reputation beyond reputeBenn0 has a reputation beyond reputeBenn0 has a reputation beyond reputeBenn0 has a reputation beyond reputeBenn0 has a reputation beyond reputeBenn0 has a reputation beyond reputeBenn0 has a reputation beyond reputeBenn0 has a reputation beyond reputeBenn0 has a reputation beyond repute
Garage
Re: Is DPF issue for 2014 CRD fixed now?

Quote:
Originally Posted by fforacing View Post
Just an update on my dpf issue. I did as the computer suggested and drive at Highway speed to 'remedy'.... yeah right.
Drive back home and called local Jeep dealer service Centre. They said to call Jeep Assist. They said they would look at it later in afternoon if towed in. Jeep assist sent a tow truck straight away. It arrived my house about 30 mins later.
I contacted the dealer a couple of times to ensure it would get looked at same day.
Picked car up late arvo with problem resolved.
They told me they did a forced regeneration which cleared it out.
They also informed me that it shouldn't happen again and that it was more than likely caused from pre delivery starting stopping etc. They told me to take on freeway 1 tune per fortnight and use it in manual mode and keep rpm between 2500-3000rpm for about 20 mins and it shouldn't happen again.
I had only just returned from 2000k trip on freeways but rpm was only about 2000 or under.
Anyway, happy to have back quickly and going well.
Oh. I think mine is a June 14 build with 6500km on clock.
Cheers
So while you were on the highway and you had the message to drive at highway speed, were you able to drive at full speed, or were you in limp mode, being kept to ~70kph?

Or did it go into limp mode as soon as you came off the freeway?

It is funny how many of these problems come up even though the owner has recently been driving on the highway. RPMs shouldn't matter, they are good for passive regen, but active regen should occur no matter what the revs are, if the sensors detect a blockage.

Absolute rubbish the be blaming some stop start at predelivery, when you have since done 2000kms on the highway.

Thanks for the info.
__________________
Reply With Quote
  #67  
Old 03-11-2014, 06:44 PM
Benn0's Avatar
Premium Member
 
Join Date: Oct 2013
Location: Brisbane, Australia
Posts: 1,123
Thanks: 25
Thanked 79 Times in 69 Posts
Rep Power: 16275
Benn0 has a reputation beyond reputeBenn0 has a reputation beyond reputeBenn0 has a reputation beyond reputeBenn0 has a reputation beyond reputeBenn0 has a reputation beyond reputeBenn0 has a reputation beyond reputeBenn0 has a reputation beyond reputeBenn0 has a reputation beyond reputeBenn0 has a reputation beyond reputeBenn0 has a reputation beyond reputeBenn0 has a reputation beyond repute
Garage
Re: Is DPF issue for 2014 CRD fixed now?

Updated info:
Missionman Filter nearly full message then limp mode despite recent highway driving
Fatboy Exhaust system required message my13 trailhawk
Fireball Filter nearly full message then limp mode despite being at highway speed 1900kms
Chooke Filter nearly full message then limp mode despite being at highway speed May 2013
Peanut Filter nearly full message then limp mode.
Twscoot Filter nearly full message then limp mode despite recent highway driving 6000kms April 13
ansamoiz filter nearly full message but couldn't get to a highway before limp mode kicked in 4189kms July 2013
mbro filter nearly full message but couldn't get to a highway before limp mode kicked in 1300kms Dec 2013?
A10-6 filter nearly full message but couldn't get to a highway before limp mode kicked in 1600kms July 2013
Dreamer filter nearly full message but couldn't get to a highway before limp mode kicked in 14,000kms April 13
fforacing Filter nearly full message then limp mode despite recent highway driving 6,500kms June 13
__________________
Reply With Quote
  #68  
Old 03-12-2014, 03:34 AM
ansamoiz's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Sep 2013
Location: Sydney
Posts: 77
Thanks: 9
Thanked 6 Times in 6 Posts
Rep Power: 539
ansamoiz is on a distinguished road
Quote:
Originally Posted by Benn0 View Post
Updated info: Missionman Filter nearly full message then limp mode despite recent highway driving Fatboy Exhaust system required message my13 trailhawk Fireball Filter nearly full message then limp mode despite being at highway speed 1900kms Chooke Filter nearly full message then limp mode despite being at highway speed May 2013 Peanut Filter nearly full message then limp mode. Twscoot Filter nearly full message then limp mode despite recent highway driving 6000kms April 13 ansamoiz filter nearly full message but couldn't get to a highway before limp mode kicked in 4189kms July 2013 mbro filter nearly full message but couldn't get to a highway before limp mode kicked in 1300kms Dec 2013? A10-6 filter nearly full message but couldn't get to a highway before limp mode kicked in 1600kms July 2013 Dreamer filter nearly full message but couldn't get to a highway before limp mode kicked in 14,000kms April 13 fforacing Filter nearly full message then limp mode despite recent highway driving 6,500kms June 13
Just to add my first limp mode happened without warning at only 280 km on the clock.
__________________
2014 Overland CRD Granite Crystal
Reply With Quote
  #69  
Old 03-12-2014, 03:40 AM
Barboots's Avatar
Senior Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: Perth, Western Australia
Posts: 1,438
Thanks: 42
Thanked 125 Times in 111 Posts
Rep Power: 3719
Barboots has disabled reputation
Peanut has had two also.

Speaking of which... Peanut did your car arrive this morning as promised?

Cheers,
Steve
__________________
2014 Overland CRD
Perth, Western Australia
Reply With Quote
  #70  
Old 03-12-2014, 03:44 AM
Barboots's Avatar
Senior Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: Perth, Western Australia
Posts: 1,438
Thanks: 42
Thanked 125 Times in 111 Posts
Rep Power: 3719
Barboots has disabled reputation
Quote:
Originally Posted by Swampy View Post
This pre-delivery stop starts excuse for DPF clogging must be about the biggest load of Wank that I have ever heard.
If it was an issue then they should do a burn before delivery. It's that simple.

Though it does sound like a toss-fest.

Cheers,
Steve
__________________
2014 Overland CRD
Perth, Western Australia
Reply With Quote
  #71  
Old 03-12-2014, 03:48 AM
Barboots's Avatar
Senior Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: Perth, Western Australia
Posts: 1,438
Thanks: 42
Thanked 125 Times in 111 Posts
Rep Power: 3719
Barboots has disabled reputation
Quote:
Originally Posted by fforacing View Post
They told me to take on freeway 1 tune per fortnight and use it in manual mode and keep rpm between 2500-3000rpm for about 20 mins and it shouldn't happen again.
Yeah right... I'm happy with this solution. Awesome that it's solved now.

I wonder if these guys hear what they just said?

Ciao,
Steve
__________________
2014 Overland CRD
Perth, Western Australia
Reply With Quote
  #72  
Old 03-12-2014, 04:49 AM
Swampy's Avatar
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Jul 2011
Location: Oakford, Western Australia
Posts: 661
Thanks: 2
Thanked 36 Times in 27 Posts
Rep Power: 34682
Swampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond reputeSwampy has a reputation beyond repute
Quote:
Originally Posted by Barboots View Post
If it was an issue then they should do a burn before delivery. It's that simple. Though it does sound like a toss-fest. Cheers, Steve
I wonder why wouldn't the vehicle go into burn mode at the very next opportunity after delivery? Can't help but suspect that the issues have occurred after adding the urea injection for North America. Not sure if any other countries had the urea injection before it was added for North America...
__________________

__________________
Regards

Swampy

JGC Overland CRD, Deep Cherry Red

"I'm just here for the biscuits!"
Reply With Quote
Reply

Tags
2014

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
' SERV 4WD' beach driving issue fixed?? (TSB in) UNCjeepWK2 Grand Cherokee - WK2 - 6 04-30-2013 10:19 PM
2014 Grand Cherokee CRD / 2014 Touareg CRD LJS8510 Diesel Powered 2012+ Export Grand Cherokee 6 04-11-2013 11:19 PM
RHR 730 with CHR550 - backup camera issue fixed lakercr Audio/Visual/Navigation 24 02-16-2013 04:11 PM
'04 WJ 2.7 CRD not starting - SKIM or other issue?? arievanbekkum Troubleshooting/Problems 22 01-27-2013 08:06 AM
Heater issue on 2005 GC CRD. Surfer01 Troubleshooting/Problems 5 01-02-2013 05:51 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:38 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.