Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Export Grand Cherokee 2011+

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 02-25-2013, 08:55 PM
Deserthucker's Avatar
Premium Member
My Jeep: 2011 5.7L WK2
 
Join Date: Mar 2011
Location: Kalgoorlie WA
Posts: 860
Thanks: 6
Thanked 11 Times in 11 Posts
Rep Power: 2004
Deserthucker has a reputation beyond reputeDeserthucker has a reputation beyond repute
Re: New windscreen. Wiper rain sensor fault

Mine is still the same.
See how it goes today with the rain.
__________________

__________________

Ordered WK2 Mineral Grey (was Blackberry) Hopefully. 18th March 2011
ETA late June now late September
Got it 9th September
Australian Outback
Reply With Quote
  #14  
Old 09-11-2013, 04:40 AM
Member
My Jeep: 2013 3.0L WK2
 
Join Date: Oct 2012
Location: Wagga Wagga, Australia
Posts: 70
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 617
Roachy is on a distinguished road
Re: New windscreen. Wiper rain sensor fault

Was wondering how you guys went with the wipers? I have the same one wipe thing going on after replacing my windscreen with a OEM screen.
__________________

__________________
Reply With Quote
  #15  
Old 09-11-2013, 05:15 AM
Deserthucker's Avatar
Premium Member
My Jeep: 2011 5.7L WK2
 
Join Date: Mar 2011
Location: Kalgoorlie WA
Posts: 860
Thanks: 6
Thanked 11 Times in 11 Posts
Rep Power: 2004
Deserthucker has a reputation beyond reputeDeserthucker has a reputation beyond repute
Re: New windscreen. Wiper rain sensor fault

Quote:
Originally Posted by Roachy View Post
Was wondering how you guys went with the wipers? I have the same one wipe thing going on after replacing my windscreen with a OEM screen.
Drive through a car was half dozen times fixes it.

Had 2 replacement screens now and found that fixes it.
Tried spraying with water from the hose did not work.
Think it needs the change of light as well as water.
__________________

Ordered WK2 Mineral Grey (was Blackberry) Hopefully. 18th March 2011
ETA late June now late September
Got it 9th September
Australian Outback
Reply With Quote
  #16  
Old 09-11-2013, 05:37 AM
Member
My Jeep: 2013 3.0L WK2
 
Join Date: Oct 2012
Location: Wagga Wagga, Australia
Posts: 70
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 617
Roachy is on a distinguished road
Re: New windscreen. Wiper rain sensor fault

cheers, for that. Will see what happens over the next few days and if it sorts itself out otherwise its off to the carwash.
__________________
Reply With Quote
  #17  
Old 09-11-2013, 08:31 AM
Barboots's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: Perth, Western Australia
Posts: 688
Thanks: 0
Thanked 49 Times in 38 Posts
Rep Power: 986
Barboots has disabled reputation
Re: New windscreen. Wiper rain sensor fault

Six runs through the carwash! Sheesh... can you claim that on insurance???

Steve
__________________
2014 Overland CRD
Perth, Western Australia
Reply With Quote
  #18  
Old 09-11-2013, 05:50 PM
ENFORCER's Avatar
Premium Member
My Jeep: 2011 3.0L WK2
 
Join Date: May 2011
Location: Sydney, Australia
Posts: 1,714
Thanks: 16
Thanked 61 Times in 48 Posts
Rep Power: 321563
ENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond repute
Re: New windscreen. Wiper rain sensor fault

Mine was fine after a few days and has not been an issue. The rain sensor is hit and miss sometimes, but overall fine.
Mine was an OEM screen and did wipe on startup for the first 2 days.
__________________
MY2011 CRD Overland in Bright Silver

I Bought an SRT - Bright Silver, HK + Roof
Reply With Quote
  #19  
Old 09-11-2013, 07:05 PM
Deserthucker's Avatar
Premium Member
My Jeep: 2011 5.7L WK2
 
Join Date: Mar 2011
Location: Kalgoorlie WA
Posts: 860
Thanks: 6
Thanked 11 Times in 11 Posts
Rep Power: 2004
Deserthucker has a reputation beyond reputeDeserthucker has a reputation beyond repute
Re: New windscreen. Wiper rain sensor fault

Quote:
Originally Posted by ENFORCER View Post
Mine was fine after a few days and has not been an issue. The rain sensor is hit and miss sometimes, but overall fine.
Mine was an OEM screen and did wipe on startup for the first 2 days.
My first was an aftermarket one 3 weeks later still one wipe at start.
Would not auto wipe rain until you could not see out the windscreen.
Went to Perth through the car wash noticed it was a little more sensitive still one wipe. tried again got better then the 3rd time no more one wipe but still had to have full wet screen before auto wipe. Another two times it worked like new. $6 a wash $36 for the self repair.
Sick of complaining to the windscreen guys and no help from Chrysler. Not fitted by them or OEM.
Second screen was the same but the same installer put the cost of the carwash on his invoice to insurance and paid for my carwash.
__________________

Ordered WK2 Mineral Grey (was Blackberry) Hopefully. 18th March 2011
ETA late June now late September
Got it 9th September
Australian Outback
Reply With Quote
  #20  
Old 09-16-2013, 07:08 AM
JustinS's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jan 2013
Location: Western Australia
Posts: 84
Thanks: 74
Thanked 4 Times in 4 Posts
Rep Power: 543
JustinS is on a distinguished road
Re: New windscreen. Wiper rain sensor fault

Ah good, so you've got a new screen & working wipers, but your paint's stuffed after all the carwashes
__________________
'14 GC Overland Granite
Reply With Quote
  #21  
Old 09-16-2013, 07:21 PM
AAAA's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jan 2011
Location: Upstate NY
Posts: 2,424
Thanks: 0
Thanked 35 Times in 31 Posts
Rep Power: 1543052
AAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond reputeAAAA has a reputation beyond repute
Re: New windscreen. Wiper rain sensor fault

OK, I have the answer as I went through this earlier this summer (northern hemisphere resident). I had windshield replaced at dealer with OEM. As I feared, wipers did not respond as with original windshield. Turns out the replacement windshield needs to be hooked up to the dealer computer and be reprogrammed once installed. My usually first rate dealer did not know this until I returned 10 minutes later (fortunately it was done on a rainy day). While they claim they replace windshields daily (usually use Globe Glass), apparently not one with rainsensor/UConnect. Hope this helps.
__________________
Limited, White Gold/Frost Beige- Michelin LTX M/S 2's, chrome fog bezels, front and t. c. skid plates.
Reply With Quote
  #22  
Old 09-16-2013, 08:38 PM
Milous's Avatar
Senior Member


 
Join Date: Nov 2009
Location: Nottsure, Wair
Posts: 5,856
Thanks: 31
Thanked 1,576 Times in 707 Posts
Rep Power: 2391537
Milous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond reputeMilous has a reputation beyond repute
Re: New windscreen. Wiper rain sensor fault

Quote:
Originally Posted by Deserthucker View Post
the sensor is part of the windscreen.
They showed me the old one
Only the sensor module mounting bracket is attached to/part of the windscreen.

No dealer re-programming is necessary after windscreen replacement.
__________________
Reply With Quote
  #23  
Old 09-16-2013, 10:03 PM
Barboots's Avatar
Premium Member
My Jeep: 2014 3.0L WK2
 
Join Date: Aug 2013
Location: Perth, Western Australia
Posts: 688
Thanks: 0
Thanked 49 Times in 38 Posts
Rep Power: 986
Barboots has disabled reputation
Re: New windscreen. Wiper rain sensor fault

Quote:
Originally Posted by Milous View Post
Only the sensor module mounting bracket is attached to/part of the windscreen.

No dealer re-programming is necessary after windscreen replacement.
So what do you suspect is the solution to these problems Milous? If the sensor is retained with the vehicle when the screen is replaced, I can't understand what is happening... especially when it's happening with OEM glass.

Cheers,
Steve
__________________
2014 Overland CRD
Perth, Western Australia
Reply With Quote
  #24  
Old 09-17-2013, 03:22 PM
Member
 
Join Date: Apr 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 742
nealie84 is on a distinguished road
Re: New windscreen. Wiper rain sensor fault

I had my windscreen replaced at O'Briens (non-genuine) and he told me to expect the wipers to play up for around a month. He said it happens occasionally on all brands of car with auto wiper windscreens. Mine played up for about two and a half weeks and was fine from then on.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
intermittent wiper fault jeepnuts Troubleshooting/Problems 11 11-25-2013 10:38 PM
Coolant Temp Sensor Fault Ozz1967 Grand Cherokee - ZJ 18 08-21-2012 05:27 PM
Does rain sensing option operate rear wiper? bbjrhome Grand Cherokee - WK2 - 15 11-04-2011 04:43 AM
Auto headlight nor Rain Sensing Wiper working! kennethmt Troubleshooting/Problems 7 10-04-2011 06:19 PM
Rain sense wiper issue JSmall Grand Cherokee - WK 9 04-25-2011 09:34 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:45 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community