Rear safety camera - Page 38 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Export Grand Cherokee 2011+

Reply
 
Thread Tools Display Modes
 
  #445  
Old 05-31-2015, 07:06 AM
Member
My Jeep: 2014 WK2
 
Join Date: Nov 2013
Posts: 40
Thanks: 12
Thanked 6 Times in 4 Posts
Rep Power: 1364
MadMapMan is on a distinguished road
Re: Rear safety camera

Quote:
Originally Posted by Red PeeKay View Post
I have a WK2 Laredo here in Oz with the new camera fitted. I also have the option to turn the gridlines on or off in Uconnect..makes no difference, I don't get the gridlines.
That's because your UConnect isn't receiving any instruction to tell it to display the lines! I've just posted what you need to do...

MMM

Reply With Quote
Sponsored Links
Advertisement
 
  #446  
Old 05-31-2015, 09:12 AM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Nov 2014
Location: Sydney, AU
Posts: 216
Thanks: 4
Thanked 69 Times in 39 Posts
Rep Power: 1240
Steve1307 has a reputation beyond reputeSteve1307 has a reputation beyond reputeSteve1307 has a reputation beyond reputeSteve1307 has a reputation beyond repute
Re: Rear safety camera

Quote:
Originally Posted by MadMapMan View Post

I'm going in for a service this week, so I'll check that the correct sales code has been uploaded, and see if that adds the gridlines option.

@Steve1307 - Did you said you were getting a service Monday? Could you let us know if your Laredo has the correct sales code added (if your dealer knows what that means)? This is probably why you and @67HR (and others) have the UConnect gridline setting, but ironically, can't use it...

MMM
I have Uconnect 14.25.5 standard. I don't have any RAX software installed (or their rollback)

I have the checkbox for Parkview Active Gridlines and when i press and "untick" it the tick returns about 5 sec later
Anyway the crapcam has no lines so the function doesnt work of course.


Maybe the rollback software that Magnus gave you doesn't have that function checkbox.

I'm not quite sure how the rollback works, but the way I saw it, it removes the Customtronix package entirely so the system is totally blank and then it installs a whole new "stock 14.25.5 factory ROW spec" software.

This rollback version, might not be exactly identical to what you might have had in the beginning when the car was delivered. Did you ever have the checkbox before installing the RAX software?


My service isn't until Friday.

I booked it in a bit over a week ago, spoke to them about the crapcam and then wrote an email to the service manager about requesting the camera be replaced with the genuine one.
Coincidentally, on the same day FCA issued that cam replacement letter (& dealer bulletin).

The dealer sent me a letter reminding me to book a service, but it was dated 4 days after I'd already booked, so I rang them to make sure.
I rang the service place last Friday to confirm and to see if they knew about the cam replacement offer from FCA, or if they'd reviewed my case.
They didn't know anything about it. of course.

Very much doubt they'll have the camera bits in stock to replace it even if it is approved though.

I haven't received the same letter that Mr@Bigskiddy has,.... yet, but have printed it to take in on Friday.
__________________
2014 Grand Cherokee Laredo CRD - Granite - towing pack only - dodgy proper reverse camera :)
ScanTool OBDLink
Reply With Quote
  #447  
Old 05-31-2015, 03:23 PM
Member
My Jeep: 2014 WK2
 
Join Date: Nov 2013
Posts: 40
Thanks: 12
Thanked 6 Times in 4 Posts
Rep Power: 1364
MadMapMan is on a distinguished road
Re: Rear safety camera

Quote:
Originally Posted by Steve1307 View Post
I have the checkbox for Parkview Active Gridlines and when i press and "untick" it the tick returns about 5 sec later
Interesting... Only postulating, but perhaps the UConnect s/w reactivates it because there's no active line signal. Who knows what 'logic' some of these s/w engineers put in...

Quote:
Originally Posted by Steve1307 View Post
Maybe the rollback software that Magnus gave you doesn't have that function checkbox.
Hmmm, doubt it. In all my dealings with Magnus, I've never got the impression that they've disabled (or messed) with the underlying functionality of the unit. Typically, they've enabled things that Harmon disabled, or added something that is possible given the various inputs, but which Harmon decided not to provide. In my case, the reason I wanted the RAX silver package (original recommendation from Barboots - another Steve!) was to enable an aux input for a rear-facing caravan mounted camera that was switchable.

WRT my gridlines setting, my money's on this not being enabled because the correct code is not in the ECU/PCM/whatever. (The UConnect reads this to determine the vehicle in which its operating - e.g. the same basic UConnect firmware runs in RAM and Chrysler cars, and all the logos/icons etc are present in the firmware that comes from Chrysler).

Quote:
Originally Posted by Steve1307 View Post
I'm not quite sure how the rollback works, but the way I saw it, it removes the Customtronix package entirely so the system is totally blank and then it installs a whole new "stock 14.25.5 factory ROW spec" software.

This rollback version, might not be exactly identical to what you might have had in the beginning when the car was delivered.
The rollback I have takes the UConnect back to 14.22.13 (which, as you said: "might not be exactly identical to what you might have had"), and then I 'roll forward' to whatever firmware version I want - in my case I roll forward to 14.25.5, which I downloaded from the original Chrysler UConnect update site which is nothing to do with Customtronix.

FWIW, I don't believe that the Customtronix rollback removes RAX entirely. I suspect that there's an extra 'bootloader' (or something similar) in there somewhere to read the CTX token files, so that they can determine which features you've purchased.

Quote:
Originally Posted by Steve1307 View Post
Did you ever have the checkbox before installing the RAX software?
Nope!

Quote:
Originally Posted by Steve1307 View Post
My service isn't until Friday.
Ditto, Friday for me too. Looks like once again, we're on the bleeding edge...

Good luck with getting the replacement cam, and I'll see if I can get the UConnect gridline on/off option - plus the couple of TSB's I think need doing...

MMM
Reply With Quote
Sponsored Links
Advertisement
 
  #448  
Old 05-31-2015, 10:17 PM
Bigskiddy's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Location: Sydney - Australia
Posts: 664
Thanks: 99
Thanked 123 Times in 88 Posts
Rep Power: 2177
Bigskiddy is on a distinguished road
MMM, I too have the new camera installed and don't have the 'gridlines off' option in the settings.

Who knows what's going on, Jeep certainly don't. I have had DAB button showing in the radio since day one. My Uconnect version is 14.25.5.
Reply With Quote
  #449  
Old 05-31-2015, 10:50 PM
67HR's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2014
Location: Albany Western Australia
Posts: 347
Thanks: 180
Thanked 53 Times in 50 Posts
Rep Power: 1279
67HR is on a distinguished road
Re: Rear safety camera

Quote:
Originally Posted by Bigskiddy View Post
MMM, I too have the new camera installed and don't have the 'gridlines off' option in the settings.

Who knows what's going on, Jeep certainly don't. I have had DAB button showing in the radio since day one. My Uconnect version is 14.25.5.
Just found a pic of my settings I took as I was contemplating an update, but I've second thoughs now

Mines 13.43.7

So have they "taketh away!"
Attached Images
File Type: jpg IMAG0948-r.jpg (156.4 KB, 23 views)
__________________
Other Rides:
1967 Holden HR Ute (second owner)
2012 Gen5 Subaru Liberty Sports Premium
Classified R.E.D. (Retired & Extremely Disinterested Locksmith)
Reply With Quote
  #450  
Old 05-31-2015, 11:54 PM
Bigskiddy's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Location: Sydney - Australia
Posts: 664
Thanks: 99
Thanked 123 Times in 88 Posts
Rep Power: 2177
Bigskiddy is on a distinguished road
Quote:
Originally Posted by MadMapMan View Post

...So, 'all' we need to do is provide that signal. The trigger gets raised on pin 4 of connector D6685A (inside the tailgate on the newcam plug)....
MMM
I gather this is the connector. Which is pin 4?
There appears to be an unshielded wire that has been cut..?
Reply With Quote
  #451  
Old 05-31-2015, 11:56 PM
Bigskiddy's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Location: Sydney - Australia
Posts: 664
Thanks: 99
Thanked 123 Times in 88 Posts
Rep Power: 2177
Bigskiddy is on a distinguished road
Sorry photos didn't attach...

I give up.
Reply With Quote
  #452  
Old 06-01-2015, 12:35 AM
67HR's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2014
Location: Albany Western Australia
Posts: 347
Thanks: 180
Thanked 53 Times in 50 Posts
Rep Power: 1279
67HR is on a distinguished road
Re: Rear safety camera

Quote:
Originally Posted by Bigskiddy View Post
Sorry photos didn't attach...

I give up.
__________________
Other Rides:
1967 Holden HR Ute (second owner)
2012 Gen5 Subaru Liberty Sports Premium
Classified R.E.D. (Retired & Extremely Disinterested Locksmith)
Reply With Quote
  #453  
Old 06-01-2015, 01:45 AM
Bigskiddy's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Location: Sydney - Australia
Posts: 664
Thanks: 99
Thanked 123 Times in 88 Posts
Rep Power: 2177
Bigskiddy is on a distinguished road
Quote:
Originally Posted by Bigskiddy View Post
Sorry photos didn't attach...

I give up.
Thanks 67HR. Back on WIFI now.


ForumRunner_20150601_164341.jpg



ForumRunner_20150601_164414.jpg
Reply With Quote
  #454  
Old 06-01-2015, 04:03 AM
67HR's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2014
Location: Albany Western Australia
Posts: 347
Thanks: 180
Thanked 53 Times in 50 Posts
Rep Power: 1279
67HR is on a distinguished road
Re: Rear safety camera

Techauthority is awesome : https://techauthorityonlinedemo.extr...ew/classic.htm

Just put your vin in and go searching.

Here's some pics of the connectors MMM & Bigskiddy have been talking about.

Just need to get a roll of wire and make the connection.
Attached Images
File Type: jpg bodyharnessWK2.JPG (78.6 KB, 27 views)
File Type: jpg I5010WK2Plug.JPG (57.9 KB, 30 views)
File Type: jpg tailgateWK2.JPG (64.6 KB, 30 views)
__________________
Other Rides:
1967 Holden HR Ute (second owner)
2012 Gen5 Subaru Liberty Sports Premium
Classified R.E.D. (Retired & Extremely Disinterested Locksmith)
Reply With Quote
The Following 2 Users Say Thank You to 67HR For This Useful Post:
  #455  
Old 06-01-2015, 06:45 AM
Member
My Jeep: 2014 WK2
 
Join Date: Nov 2013
Posts: 40
Thanks: 12
Thanked 6 Times in 4 Posts
Rep Power: 1364
MadMapMan is on a distinguished road
Re: Rear safety camera

Quote:
Originally Posted by Bigskiddy View Post
MMM, I too have the new camera installed and don't have the 'gridlines off' option in the settings.

Who knows what's going on, Jeep certainly don't. I have had DAB button showing in the radio since day one. My Uconnect version is 14.25.5.
Yes - confusing. I've arranged with my dealer to check the status of the "XAC" sales code in DealerCONNECT when I go in for my service on Friday. We'll see if this is the cause.

Did you have your original cam replaced a while ago or recently?

FWIW, I've had the DAB button on mine since last service (can't remember what version of firmware I had before). I believe that Laredo's don't have the necessary digital antenna, so an extra one is required. I've not done this yet - another project waiting for time I don't have...
Reply With Quote
  #456  
Old 06-01-2015, 06:49 AM
Member
My Jeep: 2014 WK2
 
Join Date: Nov 2013
Posts: 40
Thanks: 12
Thanked 6 Times in 4 Posts
Rep Power: 1364
MadMapMan is on a distinguished road
Re: Rear safety camera

Quote:
Originally Posted by 67HR View Post
Just found a pic of my settings I took as I was contemplating an update, but I've second thoughs now

Mines 13.43.7

So have they "taketh away!"
So, are you asking me to roll back to 13.43.7 to see if I get the on/off option back?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear camera not displaying RKlimas Trouble Shooting/Problems/Service 13 06-16-2015 09:57 AM
Rear parking sensors/camera billyp Trouble Shooting/Problems/Service 22 12-13-2012 12:15 AM
Rear View camera wiring?? laxer44 Troubleshooting/Problems 5 03-03-2012 07:08 AM
Rear Door Child Safety?? bmooreSRT8 Trouble Shooting/Problems/Service 1 12-08-2011 12:43 AM
Custom Rear Camera...For Those Interested lll2for3lll Audio, Video, Navigation & Electronic Modifications 4 04-26-2011 11:11 AM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:23 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.