Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-12-2011, 04:10 PM
StoneCold's Avatar
Senior Member
My Jeep: 2000 4.7L WJ
 
Join Date: Feb 2010
Location: Bankfoot, Scotland
Posts: 3,204
Thanks: 8
Thanked 27 Times in 26 Posts
Rep Power: 153387
StoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond repute
Garage
2000 WJ Starting issue?

My Jeep has this intermittent starting problem. It's happened a couple of times and only seems to last for a week then it goes away. It turns over fine, justs cranks a bit too long before it kicks in and even then it's quite weak. Oddly enough, if I crank it for a few seconds and turn it off again, the second crank, it starts perfectly.

Well it reared its ugly head once more. I have in the past, had everything apart, checked and cleaned. I cannot find a single mechanical fault anywhere.

But interestingly, today I noticed that when it did start, the alarm light on the dash flashed once. This happened each time, today.

This has got me thinking. Is it possible there's a problem with the chip in the key? I've yet to try the spare key and see what happens. But has anyone had any experience of such a problem or heard of it?

As I said everything else is fine. New plugs, engine is spotless inside and out, no issues with fuel pump/ filter, starter motor etc etc all fine.

Any advice?


Thanks

Aaron
__________________

__________________
Tinted tails - Custom intake with mushroom filter - Superchips performance tuned - 20" SRT reps - Alcantara headliner - Magnaflow exhaust - Roush performance tips - LED conversion - Carbon Fibre/Alcantara interior - 20% tint -Bright Jeep pedals - Matte black viper stripes - Gauge pod - Gen 3 halo projectors & HID's - Airbrushed engine bay - Mesh grille - Snakeskin green calipers and accents(inspired by DAVY27)

www.facebook.com/stonecoldpaintwerks
Reply With Quote
  #2  
Old 02-12-2011, 07:42 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,667
Thanks: 9
Thanked 56 Times in 54 Posts
Rep Power: 525476
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 2000 WJ Starting issue?

Hi Aaron, the Jeep manual says regarding the Sentry key, that when an invalid key is used, or no signal is received, the engine will be shut down in 2 seconds. So it should start normally. Maybe you can try to turn the key as rapidly as possible to see if it will start and then shutt down after the 2 seconds. You don't have a spare key to see if that does something? And regarding the alarm light, you mean the Sentry key light?
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 02-12-2011, 08:05 PM
Joe's2001Laredo's Avatar
Member
My Jeep: 2001 4.7L
 
Join Date: Nov 2010
Location: New Jersey
Posts: 74
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1431
Joe's2001Laredo is on a distinguished road
Re: 2000 WJ Starting issue?

Mine does the same thing.I tried the 2nd key but that doesn't fix anything.If I turn the key to the run position and then back it off and then start it she will fire up right away.If the truck hasn't been sitting for that long after shutting down the engine then it will start fine as well but if it's cold she cranks slow.So I dropped mine off to my mechanic so he could try and start it cold to see what was going on.He checked out the fuel system and all its components and told me that he tested the pressure on startup and it was really low.Recommended changing the fuel pump which I have yet to do.
__________________
Reply With Quote
  #4  
Old 02-12-2011, 08:30 PM
black_wj's Avatar
Member
My Jeep: 2000 4.0L WJ
 
Join Date: Dec 2010
Location: SO CAL
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1387
black_wj is on a distinguished road
Re: 2000 WJ Starting issue?

are u shure its not the fuel pump even if it turns on u hear it and all it could be that it doesnt have enough pressure i used to have this problem with my wj and it was the fuel pump the reason why it turns on just fine the second time u turn the key is because the fuel pump started up twice which build enough pressure to start u should get it pressure test it

if u cant the way i do it is have some one crank it or just turn the key to on while ur under the hood pressing the shrader valve under the hood that is located in the fuel line with a green cap there should be a stream of fuel come out if there is just drops coming out then you know its your fuel pump and by the way have u changed ur fuel filter sorry if i miss read

sources: my fuel pump has gone bad twice please updates us on the situation
__________________
3 Kicker CVR's Hifonics amp Fosgate speakers Absolute amp Clarion EQ Soundstream epicenter
Reply With Quote
  #5  
Old 02-13-2011, 03:25 AM
StoneCold's Avatar
Senior Member
My Jeep: 2000 4.7L WJ
 
Join Date: Feb 2010
Location: Bankfoot, Scotland
Posts: 3,204
Thanks: 8
Thanked 27 Times in 26 Posts
Rep Power: 153387
StoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond repute
Garage
Re: 2000 WJ Starting issue?

Thanks guys

Frank, I have got a spare key to try, will do that today. The light I'm referring to is the red one on the passenger side, near the dash speakers. The engine doesn't shut down at all, runs perfectly.

The strange thing is, that this only happens every so often. It'll have this problem for about a week, then for months its fine.

I thought it was the fuel pump, when this first started, but it cured itself and I left it at that.

It does sound like it's the pump from what everyone's saying. Gonna get it checked again and see how it goes.

Thanks again
__________________
Tinted tails - Custom intake with mushroom filter - Superchips performance tuned - 20" SRT reps - Alcantara headliner - Magnaflow exhaust - Roush performance tips - LED conversion - Carbon Fibre/Alcantara interior - 20% tint -Bright Jeep pedals - Matte black viper stripes - Gauge pod - Gen 3 halo projectors & HID's - Airbrushed engine bay - Mesh grille - Snakeskin green calipers and accents(inspired by DAVY27)

www.facebook.com/stonecoldpaintwerks
Reply With Quote
  #6  
Old 02-13-2011, 10:52 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,667
Thanks: 9
Thanked 56 Times in 54 Posts
Rep Power: 525476
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 2000 WJ Starting issue?

The fuel filter also contains the fuel pressure regulator. So it could be the pump, but also the filter/regulator. Very strange though that the problem is not always there. Regarding the red light on top of the dash (i have it on the drivers side, LH steering wheel) is from the Vehicle Theft Security System and doesn´t show sentry key problems nor failures. That light is controlled by the Body Control Module. As far as i know this system will only activate the alarm and will not shut down the engine nor prevent it from starting.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #7  
Old 02-14-2011, 02:47 PM
StoneCold's Avatar
Senior Member
My Jeep: 2000 4.7L WJ
 
Join Date: Feb 2010
Location: Bankfoot, Scotland
Posts: 3,204
Thanks: 8
Thanked 27 Times in 26 Posts
Rep Power: 153387
StoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond repute
Garage
Re: 2000 WJ Starting issue?

That's what's got me so puzzled Frank. I would have thought it would be a consistent problem. I do have a new fuel filter sitting in my gym/ workshop, so I will give that a try. I've no idea about the light either. I wondered if there was something up with the key or alarm, was it potentially causing it not to start.
__________________

__________________
Tinted tails - Custom intake with mushroom filter - Superchips performance tuned - 20" SRT reps - Alcantara headliner - Magnaflow exhaust - Roush performance tips - LED conversion - Carbon Fibre/Alcantara interior - 20% tint -Bright Jeep pedals - Matte black viper stripes - Gauge pod - Gen 3 halo projectors & HID's - Airbrushed engine bay - Mesh grille - Snakeskin green calipers and accents(inspired by DAVY27)

www.facebook.com/stonecoldpaintwerks
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
help. starting issue. carfreak493 Trouble Shooting/Problems/Service 3 09-20-2010 08:14 PM
WJ 4.7 2000 starting probs when cold pitman1031 Engine Performance/Intake/Exhaust 5 05-21-2010 11:34 AM
Not starting... Gunswinger Troubleshooting/Problems 8 04-03-2010 08:26 PM
2005 wk 3.7 Starting issue speakerboy38 Troubleshooting/Problems 10 03-24-2010 07:00 AM
Problems with 2000 4.7 v8 starting StoneCold Engine Performance/Intake/Exhaust 13 02-15-2010 11:09 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:47 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community